Xenith Wyse Client – SSL connections to XenApp Pub desktop

  • This topic is empty.
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #7078
    Avatarmikull
    Member
    • Total Post: 5
    • Newbie

    hi all,

    i have a xenith wyse client IW AUNZ with HDX support.
    I am trying to run the Citrix Xen App published desktop on this on an SSL connection and below is the error message logged:

    21: ICA: pnhost = “https://
    22: ICA: Connecting to “Published Desktop” …
    23: https: connect via SOCKS
    24: SSL: retcode=45 a bad mac alert was received
    25: https: SSLconnect failed, err = -1
    26: SSL: retcode=4 an error occurred while reading/writing

    I have been searching for the past 4 days and there has been no progress. could someone please help me here asap as I have a project deadline to meet. . . (-.-)
    thanks.

    also, just to add, this is a published dekstop using Citrix Xen App 6.5 and this setup works perfectly fine on a windows box.
    lastly, i had to import the root cert from my CA onto the Wyse client to get to this point wherein I seem to have hit a bick wall.
    look forward to your response.
    thanks.

    #21683
    ConfGenConfGen
    Keymaster
    • Total Post: 11116
    • Jedi Master
    • ★★★★★★★

    Are you using a timeserver?

    CG

    #21691
    Avatarmikull
    Member
    • Total Post: 5
    • Newbie

    hi CG, yes, I am using an NTP server.
    Any other suggestions?
    Also, jsut out of curiosity does this wyse client support a 4096 public key strength?? my CA has a benchmark of 4096 as the public key strength. i am guessing you support upto 2048 only?

    #21695
    ConfGenConfGen
    Keymaster
    • Total Post: 11116
    • Jedi Master
    • ★★★★★★★

    not 100% sure, but I think 2048 is max.

    CG

    #21700
    Avatarmikull
    Member
    • Total Post: 5
    • Newbie

    hmmm, what else would you suggest?!!? i am looking at deploying this in a multi tenant setup and get access to users from the internet using SSL..

    anybody else has got any other suggestions?

    #21702
    ConfGenConfGen
    Keymaster
    • Total Post: 11116
    • Jedi Master
    • ★★★★★★★

    Is this a self-signed cert? In all cases make sure, that you have installed all certs in the chain (root!!! and intermediate).

    CG

    #21712
    Avatarmikull
    Member
    • Total Post: 5
    • Newbie

    no, i bought the cert from my CA. netscaler has the SSL cert + the intermediate.
    i had to upload the root cert into the wyse for me to get to his point.
    if i didn have the root cert on the wyse i would have got an ssl error 61.
    anyway, any other ideas?
    i reckon it is a limitation of the wyse not able to work in a wan environment using ssl.
    on lan and http it works like a charm.

    #21713
    Avatarmikull
    Member
    • Total Post: 5
    • Newbie

    i purchased another cert with a public key strength of 2048 and it worked great.
    youtube still sucks though on xen app published desktop.
    i have got custom compression policies on my netscaler but yet there is a big lag in the video.
    xen dekstop in a multi tenant environment should be interesting.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.