Xenith Cx0 and USB Redirection

  • This topic is empty.
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #6811
    surebridge
    Member
    • Total Post: 2
    • Newbie

    Hi There,
    I am having an issue where when I try to redirect a USB thumbdrive via the Xenith and XenApp6 (directly), it will not appear…

    I have added the following into the ini file:
    SessionConfig=All Mapdisks=yes
    SessionConfig=ICA MapDisksUnderZ=yes

    but with no success…

    I can confirm that the System Information on the Xenith shows me the following:
    USB: Found a new device “Mass Storage” on port 1 or 2 (depending on the firmware)
    D: file system register, type 0x6, size 3819 MB

    The 0x6 changes depending on what FAT style the USB key has been formatted. If I format the USB Drive to NTFS then the “D: file system register” message will not appear. This seems to be design as I did read that NTFS is not supported somewhere in a Wyse Admin doco…

    I also understand that the USB key will appear as a Floppy drive and that I need to turn on floppy drive redirection which I have done. All other redirection seems to be turned on as well…

    I can log into the Citrix environment via my laptop and the USB redirection works but using the same account on the Xenith does not work…

    I have also tried this on firmware 1.0.0.34 and also 1.5_007

    Can anyone else offer any other suggestion or see what I maybe missing…

    Cheers
    Stewy

    #20971
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    Add “
    SessionConfig=ALL UnmapUSB=yes” to your wnos.ini.

    CG

    #20988
    surebridge
    Member
    • Total Post: 2
    • Newbie

    Gday CG…

    Cheers for that. That worked a treat… I misread what the unmapusb function was…

    As per a readme file (for other readers who don’t know)

    If you are using Citrix XenApp and want to map USB disk drives, you will need to add “Sessionconfig=all unmapusb=yes mapdisks=yes” in your INI file. This disables HDX USB (which only XenDesktop supports) and allows the traditional disk drive mapping to be enabled.

    Cheers

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.