Xen Desktop 5 & Terminal Server Shortcuts Simultaneously

  • This topic is empty.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #6746
    Avatarcmcguire
    Member
    • Total Post: 6
    • Newbie

    I have an environment that is currently 100% Terminal Server

    All of our ThinOS clients use a common (and pretty simple) wnos.ini with an RDP shortcut to the Terminal Server.

    We’re looking to transition this environment from Terminal Server to Xen Desktop 5.

    Because there will be an overlap/transition/training period, we need to come up with a configuration solution that allows the user to login to the Xen Desktop broker _or_ launch an RDP shortcut. (Launching RDP from within the Xen desktops or using the Xen Client from within the Terminal Server are not options for a couple of reasons)

    My testing thus far would seem to indicate that once you provide a broker URL, the config for RDP shortcuts is ignored.

    Any advice on how to approach this would be most appreciated!

    Thanks,

    Colin

    #20798
    ConfGenConfGen
    Keymaster
    • Total Post: 11116
    • Jedi Master
    • ★★★★★★★

    This is pretty simple.
    Post your wnos.ini and I help you to alter it.

    CG

    #22335
    Avatarmarcschubert
    Member
    • Total Post: 1
    • Newbie

    ich think i have a similar problem.

    ich want auto login to pnlite but autostart an rdp session. i want start the xendesktop manual if it ist necessary. Username and password are predefinied (kiosk mode)

    in my config both autostart xendesktop and rdp. how can i prevent the autostart of xendesktop?

    and what i have to do, that usb sticks are useable via rdp session on terminal server?

    excuse my english, schooltime ist long time ago. 🙂

    ;*************************************************************
    ;* General 1 *
    ;*************************************************************

    autoload=2
    AdminMode=yes Admin-Username=OGCMOHCEMGAGMN Admin-Password=OGCMOHCEMGAGMN
    Privilege=None

    ;*************************************************************
    ;* Peripherals *
    ;*************************************************************

    Language=De

    ;*************************************************************
    ;* Display *
    ;*************************************************************

    ; If you are using a version of WTOS code < 7.0.1_13 please use:
    ; Resolution=DDC Refresh=
    Screen=1 Resolution=DDC

    ;*************************************************************
    ;* Time *
    ;*************************************************************

    Timeserver=hanserver Timeformat="24-hour format"
    TimeZone='GMT + 01:00' ManualOverride=yes

    ;*************************************************************
    ;* Network *
    ;*************************************************************

    SignOn=Yes
    DomainList="xxxx"
    DefaultUser=xxxx
    Password=xxxx

    ;*************************************************************
    ;* ICA *
    ;*************************************************************

    PnliteServer=vcontroller AutoConnectList=""


    ;*************************************************************
    ;* RDP *
    ;*************************************************************

    SessionConfig=RDP DefaultColor=2 USBRedirection=RDP

    ;
    ;- RDP Session 1 -
    ;- Each line but the last must end with a '' -
    ;

    CONNECT=RDP
    Host=ts
    Description="Terminalserver"
    Username=xxxxx
    Password=xxxxx
    Domainname=xxxx
    Autoconnect=1
    LocalCopy=no

    thx a lot

    Marc

    #22338
    ConfGenConfGen
    Keymaster
    • Total Post: 11116
    • Jedi Master
    • ★★★★★★★

    Hi Marc,

    looks like school is not that long ago 😉
    To get the USB sticks running add
    SessionConfig=ALL MapDisks=yes
    to your wnos.ini and all should be fine.

    If you have only one published app defined for the user who is logging in, then Thin OS will start is automatically. AFAIK there is no way to prevent this beside defining a second published app for that user.
    The optional parameter “AutoconnectList=” is not necessary in your setup.

    CG

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.