wyste c10le + citrix xenapp6 published desktop

  • This topic is empty.
Viewing 15 posts - 1 through 15 (of 27 total)
  • Author
    Posts
  • #6832
    Avatarwysetc
    Member
    • Total Post: 14
    • Regular Joe
    • ★★

    I just made a wnos.ini file to connect to a citrix published desktop.
    Everything looks fine but I have still 2 issues. I am brand new with wyse so it coulde be very easy things.

    Problem 1.
    I have 6 xenapp servers and the desktops are delivered from the servers with the less users. Now when i do a citrix session disconnect the next time I logon on citrix I open not the disconnected session but a brand new session on another server. So my disconnected session was not seen. I do authentication on my published desktop.

    Problem2.
    Configuration was made and ica start tot published desktop logon screen. but every 20 secs the ica connection relaunch while it must stay at the logon screen.

    Can anyone help me to fix this?

    thanks

    #21007
    AvataraLiE
    Participant
    • Total Post: 320
    • Jacked into The Matrix
    • ★★★★★★

    Could you post your wnos.ini ?

    I can think of 2 options right now, logon = and the reconnect option in your wnos.ini but not sure if this is the solution without checking the wnos.ini but you can have a look for yourself or post your wnos.ini

    #21008
    Avatarwysetc
    Member
    • Total Post: 14
    • Regular Joe
    • ★★

    Language=Nl_be Charset=ISO-8859-1

    Screen=1 Resolution=1280×1024

    Timeserver=10.81.0.10; 10.81.0.20 Timeformat=”12-hour format” Dateformat=dd/mm/yyyy
    TimeZone=’GMT + 01:00′ ManualOverride=yes

    SignOn=No

    SessionConfig=ALL UnmapPrinters=no UnmapSerials=no MapDisks=yes

    IcaBrowsing=HTTP
    Seamless=no FullscreenReserved=yes

    CONNECT=ICA
    BrowserIP=”10.81.2.81; 10.81.2.82; 10.81.2.83; 10.81.2.84; 10.81.2.85; 10.81.2.86″
    Application=Desktop
    Description=”Citrix Desktop”
    Reconnect=1
    Resolution=1280×1024
    Logon_Mode=user-specified
    HTTPBrowsing=yes
    SessionReliability=yes
    Mapdisks=yes
    LocalCopy=no
    Desktopmode=fullscreen
    Autoconnect=2
    Fullscreen=yes

    #21009
    AvataraLiE
    Participant
    • Total Post: 320
    • Jacked into The Matrix
    • ★★★★★★

    If you want your users tobe able to reconnect to any lost connection (disconnected session) your should use logon=1 in your wnos.ini.
    I know the pain, we are using logon=0 aswell (and using the connection manager) but the side way is no option to reconnect but this is something we chosen for.

    Try logon=1 (authentication will be on the wyse device not the published desktop) and see if this is something you like, using this option you will be able to reconnect to any lost connection.

    Remove the “Reconnect=1” this will prevent the reconnecting every 20 sec.

    #21010
    Avatarwysetc
    Member
    • Total Post: 14
    • Regular Joe
    • ★★

    should I put logon=1 on a specific place.
    This doesn’t work for me.
    THe reconnect = 1 I put over there when a user does a logoff there need to come again a citrix logon screen.

    Are your clients in the domain, We don’t like that for thin clients?

    #21011
    AvataraLiE
    Participant
    • Total Post: 320
    • Jacked into The Matrix
    • ★★★★★★

    No i don’t think you can join WTOS in your domain.

    Oh just saw i made a mistake …. sorry about that, logon=0/1 should have been SignOn=0/1

    If you or any user logoff they will get back to the logon screen, i don’t think you want to reconnect without entering the userid and password.
    Try out authentication to the Wyse device and see if this will work for you.

    #21014
    ConfGenConfGen
    Keymaster
    • Total Post: 11116
    • Jedi Master
    • ★★★★★★★

    Delete the whole ICA section and replace it with
    PnliteServer=10.81.2.81; 10.81.2.82; 10.81.2.83; 10.81.2.84; 10.81.2.85; 10.81.2.86 ReconnectAtLogon=2 ReconnectFromButton=2 AutoConnectList=”Farm:Desktop”

    Replace “Farm:” with your farmname.

    This should fix both issues.

    CG

    #21110
    Avatarwysetc
    Member
    • Total Post: 14
    • Regular Joe
    • ★★

    @ConfGen wrote:

    Delete the whole ICA section and replace it with
    PnliteServer=10.81.2.81; 10.81.2.82; 10.81.2.83; 10.81.2.84; 10.81.2.85; 10.81.2.86 ReconnectAtLogon=2 ReconnectFromButton=2 AutoConnectList=”Farm:Desktop”

    Replace “Farm:” with your farmname.

    This should fix both issues.

    CG

    When I replace the whole section this doesn’t work at all.
    In the connect manager I don’t see anything. And nothing is started
    Can you give some more explanation?

    Thanks

    #21111
    ConfGenConfGen
    Keymaster
    • Total Post: 11116
    • Jedi Master
    • ★★★★★★★

    Of course you have to alter SignOn=no to =yes.

    CG

    #21114
    Avatarwysetc
    Member
    • Total Post: 14
    • Regular Joe
    • ★★

    @ConfGen wrote:

    Of course you have to alter SignOn=no to =yes.

    CG

    Just figured it out

    Language=Nl_be Charset=ISO-8859-1
    autoload=2
    Privilege=High EnableTrace=yes Lockdown=yes HidePPP=yes HidePN=yes HideConnectionManager=no EnableNetworkTest=yes ShowDisplaySettings=yes
    DeskColor=”255 255 255″
    LowBand=yes
    SaveSysinfo=ftp
    Timeserver=
    TimeZone=’GMT + 01:00′ ManualOverride=yes Daylight=yes Start=030107 End=110107 TimeZoneName=”Pacific Standard Time” DayLightName=”Pacific Daylight Time”
    SignOn=Yes ConnectionManager=Minimize EnableOK=Yes LastUsername=yes
    Seamless=yes
    DisableDomain=yes
    DomainList=domain
    SessionConfig=ICA DesktopMode=fullscreen
    IcaBrowsing=HTTP
    PnliteServer=http://xenapp.boss.be
    ReconnectAtLogon=2 ReconnectFromButton=2
    Autoconnect=0
    AutoConnectList=”Boss Paints Farm:Desktop”

    Only one last thing. When my user had a disconnected session everything is ok, but when he logon and has no session the destkop wouldn’t start automatically. is there something wrong in the syntax of autoconnectlist?

    #21115
    AvataraLiE
    Participant
    • Total Post: 320
    • Jacked into The Matrix
    • ★★★★★★

    Try using “AutoConnect=1” for the connection you would like to autoconnect to.

    #21116
    Avatarwysetc
    Member
    • Total Post: 14
    • Regular Joe
    • ★★

    @aLiE wrote:

    Try using “AutoConnect=1” for the connection you would like to autoconnect to.

    ok that works also.
    Just one more thing. I am logged on to tc1 with a published desktop open.
    I go to another desk were I can find tc2. I logon over there. My session disconnects on tc but I don’t get the session on TC2.
    So I’m Opening a brand new session. My session need to follow me form one device to another device

    Can anyone help me with this last step.

    thanks

    #21118
    ConfGenConfGen
    Keymaster
    • Total Post: 11116
    • Jedi Master
    • ★★★★★★★

    PnliteServer=http://xenapp.boss.be
    ReconnectAtLogon=2 ReconnectFromButton=2
    AutoConnectList=”Boss Paints Farm:Desktop”

    This has all to be on one line!
    Use this instead:
    PnliteServer=http://xenapp.boss.be ReconnectAtLogon=2 ReconnectFromButton=2 AutoConnectList=”Boss Paints Farm:Desktop”

    CG

    #21122
    Avatarwysetc
    Member
    • Total Post: 14
    • Regular Joe
    • ★★

    @ConfGen wrote:

    PnliteServer=http://xenapp.boss.be
    ReconnectAtLogon=2 ReconnectFromButton=2
    AutoConnectList=”Boss Paints Farm:Desktop”

    This has all to be on one line!
    Use this instead:
    PnliteServer=http://xenapp.boss.be ReconnectAtLogon=2 ReconnectFromButton=2 AutoConnectList=”Boss Paints Farm:Desktop”

    CG

    I have done that allready but this doesn’t work for session following.
    When I have a session on a fat client and then logon to a wyse thin client my session on the fat client disconnects but doesn’t reconnect on the thin client. The thin clients opens a complete new wession. And on between 2 thin clients it’s just the same scenario.

    my wnos.ini file looks now like this

    autoload=2
    Privilege=none EnableTrace=yes Lockdown=yes HidePPP=yes HidePN=yes HideConnectionManager=yes HideSysInfo=yes ShowDisplaySettings=yes HideTaskBar=Yes
    LowBand=yes
    Timeserver=10.81.0.10; 10.81.0.20
    TimeZone=’GMT + 01:00′
    SignOn=Yes ConnectionManager=Minimize EnableOK=Yes LastUsername=yes
    AutoSignoff=yes
    Seamless=yes
    DisableDomain=yes
    DomainList=bossdom
    autoconnect=1
    SessionConfig=ICA DesktopMode=fullscreen
    IcaBrowsing=HTTP
    PnliteServer=http://xenapp.boss.be ReconnectAtLogon=2 ReconnectFromButton=2 AutoConnectList=”Boss Paints Farm:Desktop”
    Language=Nl_be Charset=ISO-8859-1
    Mapdisks=yes

    Also on the wyse tc my usb removable drives were not mapped. On a fat client there is no problem.

    Mapdisks=yes
    UnmapUSB=yes
    Looks like these 2 options don’t work.

    Any idea?

    #21125
    AvataraLiE
    Participant
    • Total Post: 320
    • Jacked into The Matrix
    • ★★★★★★

    You are missing “mapdisksunderz=yes” i guess

Viewing 15 posts - 1 through 15 (of 27 total)
  • You must be logged in to reply to this topic.