WYSE Xenith 2 cannot get IP

  • This topic is empty.
Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #8131
    Avatarshandy
    Member
    • Total Post: 7
    • Newbie

    Hi all,

    I really hope someone can help, as this has been a major pain trying to fault find – any assistance appreciated.

    very similar to previous post http://www.freewysemonkeys.com/modules.php?name=Forums&file=viewtopic&p=24226&PHPSESSID=qqpjhgula4jm3d95vifohpors1 xenith 2 hanging on startup showing waiting for IP.

    I removed fileserver= from my xen.ini but my issue remains.

    DHCP
    option 161 now http://xxx.xxx.xxx.xxx IP of our Citrix server, hosting IIS etc
    option 162: /
    option 181: http://citrix.domain.xxx

    xen.ini located in C:inetpubwwwrootWYSEwnosxen.ini and can access via http://citrix.domain.xxx/WYSE/wnos/xen.ini on LAN and http://xxx.xxx.xxx.xxx/WYSE/wnos/xen.ini on LAN

    log files show (replaced IP’s with xxx.xxx.xxx.xxx)

    13:06:05 Looking up IP address from DHCP …
    13:08:38 DHCP failed, “Network Setup” invoked …
    13:08:49 Looking up IP address from DHCP …
    13:08:52 Obtain IP[xxx.xxx.xxx.xxx] from DHCP server[xxx.xxx.xxx.xxx]
    13:08:52 DHCP lease time: 4 day 00:00:00
    13:08:52 Contacting File Server …
    13:08:52 Accessing system profile …
    13:08:52 GeoTrustGlobalCA.crt: file already exists.
    13:08:52 Contacting File Server …
    13:08:52 Cannot access system profile
    13:08:52 Checking Software http:/wnos/T00_xen.bin …
    13:08:56 VUSB: Redirected Device(0x0951,0x1665,0x08,0x06,0x50)
    13:08:56 USB: Found a new device “Mass Storage” on port 2
    13:08:57 D: file system register, type 0xb, size 7387 MB
    13:10:05 Event Log: output to D:/WTOS_log.txt

    Log files show it is reading the xen.ini, hence the attempt to update the cert, yet global.ini is blank on the device. This seems odd behaviour.

    Also shows “13:08:52 Checking Software http:/wnos/T00_xen.bin” is not including the server domain name, so I’m guessing that’s wrong…

    here is my xen.ini

    ;*************************************************************
    ;* *
    ;* This xen.ini file was generated with the *
    ;* Configuration File Generator 7.0.010 *
    ;* Copyright by Thomas Moellerbernd *
    ;* *
    ;* http://www.technicalhelp.de *
    ;* *
    ;*************************************************************

    ;*************************************************************
    ;* General 1 *
    ;*************************************************************

    autoload=0
    Rootpath=/

    ;*************************************************************
    ;* General 2 *
    ;*************************************************************

    Locale=English

    ;*************************************************************
    ;* General 3 *
    ;*************************************************************

    AutoSignoff=yes
    AddCertificate=GeoTrustGlobalCA.crt

    ;*************************************************************
    ;* Peripherals *
    ;*************************************************************

    Language=Uk ImageSuffix=gb

    ;*************************************************************
    ;* Display *
    ;*************************************************************

    Screensaver=30 LockTerminal=no Type=0

    ;*************************************************************
    ;* Time *
    ;*************************************************************

    Timeserver=0.uk.pool.ntp.org Timeformat=”12-hour format” Dateformat=dd/mm/yyyy
    ; If you are using an older version of WTOS code please use:
    ; TimeZone= ‘GMT’ ManualOverride=yes Daylight=yes Start=030507 End=100507 TimeZoneName=GMT DayLightName=GMT

    TimeZone=’Greenwich Mean Time’ ManualOverride=yes Daylight=yes Start=030507 End=100507 TimeZoneName=”GMT Standard Time” DayLightName=”GMT Daylight Time”

    I’ve ticked “Disable WYSE Device Manager” as we are not using WDM & previously I was seeing the below in the logs.

    Looking up WDM server by DNS hostname …
    12:13:41 DNS/WINS can’t resolve [wdmserver]
    12:13:41 Looking up WDM server by DNS SRV record …
    12:13:41 DNS/WINS can’t resolve [_wdmserver._tcp.domain.xxx]

    Any suggestions?

    Cheers

    Shandy

    #24590
    ConfGenConfGen
    Keymaster
    • Total Post: 9810
    • Jedi Master
    • ★★★★★★★

    Can you remove the OT 162 for testing?
    What do you see under Central Configuration-Fileserver?

    CG

    #24593
    Avatarshandy
    Member
    • Total Post: 7
    • Newbie

    Hi,

    Thanks for the (really quick!) response.

    I’ve passed the request to networking to change DHCP to remove the / from option 162

    Under central Configuration > Fileserver I saw http://xxx.xxx.xxx.xxx// noting the double slash at the end – so I’m guessing that’s the cause of our issues?

    Thanks

    Shandy

    #24620
    Avatarshandy
    Member
    • Total Post: 7
    • Newbie

    Hello,

    We’ve changed the DHCP 162 – it’s now empty (but still being handed out as an option)

    The issues remain & we still have http://xxx.xxx.xxx.xxx// under central Configuration > Fileserver

    Any further suggestions, as I’m getting desperate!

    Thanks again,

    Shandy

    #24622
    ConfGenConfGen
    Keymaster
    • Total Post: 9810
    • Jedi Master
    • ★★★★★★★

    Either remove(!) OT 162 or give it a value of “$” (without quotes).

    CG

    #24623
    Avatarshandy
    Member
    • Total Post: 7
    • Newbie

    Thanks CG option 162 now $

    we now have http://xxx.xxx.xxx.xxx under central configuration > fileserver (no /’s at all)

    global.ini remains blank & same DHCP freeze on startup.

    Is there anything else we can try?

    Thanks again for the assistance, much appreciated!

    Shandy

    #24627
    ConfGenConfGen
    Keymaster
    • Total Post: 9810
    • Jedi Master
    • ★★★★★★★

    In that case the INI file has to be now in ftproot/wnos
    What do you mean by DHCP freeze? Doesn’t the Xenith get an IP at all?

    CG

    #24630
    Avatarshandy
    Member
    • Total Post: 7
    • Newbie

    Hi CG,

    The device will boot, state “looking up IP address from DHCP” then sit there for 3-5min. It will then display the network setup menu. Clicking OK without making any changes, the device will then state “retry DHCP” then get an IP address without further issue.

    This happens every time the device is restarted.

    The xen.ini file is located in C:inetpubwwwrootWYSEwnosxen.ini as we want to host it via HTTP not via FTP (I’d rather not have to install a FTP server if the WYSE client supports http)

    #24631
    Avatarshandy
    Member
    • Total Post: 7
    • Newbie

    Hi CG,

    We’ve been able to identify the root cause of the DHCP issue via our vendor – details below in case others encounter similar issues:

    “A cause could be if they have Spanning Tree Protocol enabled on their network switches. This can cause a problem when the switch ports are not put in the forwarding state quickly enough for the Wyse thin-clients to obtain a DHCP address.

    If Spanning Tree Protocol is in use on their switch, they will need to enable ‘Port Fast’ (Cisco and Dell) or equivalent:

    ‘Fast Search’ – Nortel
    ‘Fast Port’ or ‘admin-edge-port’ – HP”

    So our only remaining issue is the xen.ini issue, as before any suggestions most welcome!

    Shandy

    #24634
    ConfGenConfGen
    Keymaster
    • Total Post: 9810
    • Jedi Master
    • ★★★★★★★

    If OT 162 is $ then xen.ini located in C:inetpubwwwrootwnosxen.ini

    CG

    #24635
    Avatarshandy
    Member
    • Total Post: 7
    • Newbie

    Fantastic, that’s nailed it.

    Really appreciate the help & assistance.

    Kind regards

    Sleepy

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.