Wyse V10 – USB disk question

  • This topic is empty.
Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #1590
    Avatartosodj
    Member
    • Total Post: 19
    • Regular Joe
    • ★★

    Hi,
    I have some V10L Wyse and I have configured wnos.ini for connection USB pen drives.
    I have published a Citrix desktop with Presentation Server 4.5 .
    When I connect an usb pen drive, on My Computer I see the pen drive: when I open it I find “Drive” folder and inside this folder all the data on the pen drive.

    For example I map usb pen driver as Q: disk.
    I see Q: disk on My computer
    Open Q: driver –> I see D folder (I suppose made by thin client)
    Open D folder I see all the data on the pen drive.

    Is there a way to eliminate D Folder and see directly all the data when I open Q: disk ?

    thanks
    bye

    #14404
    ConfGenConfGen
    Keymaster
    • Total Post: 11109
    • Jedi Master
    • ★★★★★★★

    Can you post you wnos.ini? I do not see this issue here.
    Which WTOS version are you using?

    CG

    #14405
    Avatartosodj
    Member
    • Total Post: 19
    • Regular Joe
    • ★★

    Here the wnos.ini

    ;*************************************************************
    ;* *
    ;* This wnos.ini file was generated with the *
    ;* Configuration File Generator 4.5.13 *
    ;* Copyright by Thomas Moellerbernd *
    ;* *
    ;*************************************************************

    ;*************************************************************
    ;* General 1 *
    ;*************************************************************

    autoload=1
    Privilege=None Lockdown=Yes HideSysInfo=yes HidePPP=yes ShowDisplaySettings=yes

    EnableKeyboardMouseSettings=yes
    SessionConfig=ALL MapDisks=yes DisksReadOnly=yes

    ;*************************************************************
    ;* General 2 *
    ;*************************************************************

    FormURL=phib_login.bmp

    ;*************************************************************
    ;* General 3 *
    ;*************************************************************

    AutoSignoff=yes Shutdown=yes
    Shutdowncounter=0

    ;*************************************************************
    ;* Input Devices *
    ;*************************************************************

    Language=It

    ;*************************************************************
    ;* Display *
    ;*************************************************************

    Resolution=DDC Refresh=60
    DeskColor=”206 206 206″
    Desktop=phib_bk.bmp
    Screensaver=”0″ LockTerminal=no Type=2 Image=screensave.jpg

    ;*************************************************************
    ;* Time *
    ;*************************************************************

    Timeserver=ntp.crtnet
    TimeZone=’GMT + 01:00′ ManualOverride=yes Daylight=yes Start=100507 End=030507

    TimeZoneName=”W. Europe Standard Time” DayLightName=”W. Europe Daylight Time”

    ;*************************************************************
    ;* Network *
    ;*************************************************************

    SignOn=Yes EnableOK=yes

    ;*************************************************************
    ;* ICA *
    ;*************************************************************

    Seamless=yes
    PnliteServer=fcswps01,fcswps02 AutoConnectList=”Desktop PS07″
    DomainList=fcdb
    SessionConfig=ICA MapDisksUnderZ=yes

    #14406
    ConfGenConfGen
    Keymaster
    • Total Post: 11109
    • Jedi Master
    • ★★★★★★★

    OK, here is your problem.
    I assume you are configuring the “Q” letter directly on the unit under Start-System Setup-Preferences, right?
    In your wnos.ini you are saying to map all drives under letter “Z” (last line in your wnos.ini).
    Both is not working.
    Either remove the local or the wnos.ini parameter.
    You can replace the last line by “SessionConfig=ICA DiskMapTo=Q ” to get the needed result.
    Mapping disks under a special drive name will only work, if the disk is already attached when starting the ICA session. Otherwise you have to use “SessionConfig=ICA MapDisksUnderZ=yes”

    CG

    #14407
    Avatartosodj
    Member
    • Total Post: 19
    • Regular Joe
    • ★★

    @ConfGen wrote:

    OK, here is your problem.
    I assume you are configuring the “Q” letter directly on the unit under Start-System Setup-Preferences, right?
    In your wnos.ini you are saying to map all drives under letter “Z” (last line in your wnos.ini).
    Both is not working.
    Either remove the local or the wnos.ini parameter.
    You can replace the last line by “SessionConfig=ICA DiskMapTo=Q ” to get the needed result.
    Mapping disks under a special drive name will only work, if the disk is already attached when starting the ICA session. Otherwise you have to use “SessionConfig=ICA MapDisksUnderZ=yes”

    CG

    hi ConfGen,
    No I map the drive as Q: using a script at user logon.

    #14408
    ConfGenConfGen
    Keymaster
    • Total Post: 11109
    • Jedi Master
    • ★★★★★★★

    So you are using kind of SUBST to map Z: with Q:?
    As “mapping all drives to Z:” is creating a virtual drive Z: and showing all attached drives as subfolders, this is the default behaviour.
    No chance to change beside using SessionConfig=ICA DiskMapTo=Q

    CG

    #14409
    Avatartosodj
    Member
    • Total Post: 19
    • Regular Joe
    • ★★

    I have tried with “SessionConfig=ICA DiskMapTo=Q ” but when the system try to map the pen drive a password request is shown…and the pen drive is not protected by a password!

    #14410
    ConfGenConfGen
    Keymaster
    • Total Post: 11109
    • Jedi Master
    • ★★★★★★★

    Never seen that.
    Is your pen drive formatted with FAT or FAT32 or something else? WTOS only supports Fat/Fat32.
    Have you removed your login script?

    CG

    #14411
    Avatartosodj
    Member
    • Total Post: 19
    • Regular Joe
    • ★★

    I try removing the script.
    I will post the result.

    #14413
    Avatartosodj
    Member
    • Total Post: 19
    • Regular Joe
    • ★★

    The pen drive is formatted with FAT.
    Removing the script, the pen drive is not mapped… 😯

    #14414
    ConfGenConfGen
    Keymaster
    • Total Post: 11109
    • Jedi Master
    • ★★★★★★★

    Once again post your wnos.ini as you are using is right now, please.
    Have you had attached the pen drive before starting the ICA connection?

    CG

    #14415
    Avatartosodj
    Member
    • Total Post: 19
    • Regular Joe
    • ★★

    Yes I have connected the pen drive.
    Here the wnos.ini

    ;*************************************************************
    ;* *
    ;* This wnos.ini file was generated with the *
    ;* Configuration File Generator 4.5.13 *
    ;* Copyright by Thomas Moellerbernd *
    ;* *
    ;*************************************************************

    ;*************************************************************
    ;* General 1 *
    ;*************************************************************

    autoload=1
    Privilege=None Lockdown=Yes HideSysInfo=yes HidePPP=yes ShowDisplaySettings=yes

    EnableKeyboardMouseSettings=yes
    SessionConfig=ALL MapDisks=yes DisksReadOnly=yes

    ;*************************************************************
    ;* General 2 *
    ;*************************************************************

    FormURL=phib_login.bmp

    ;*************************************************************
    ;* General 3 *
    ;*************************************************************

    AutoSignoff=yes Shutdown=yes
    Shutdowncounter=0

    ;*************************************************************
    ;* Input Devices *
    ;*************************************************************

    Language=It

    ;*************************************************************
    ;* Display *
    ;*************************************************************

    Resolution=DDC Refresh=60
    DeskColor=”206 206 206″
    Desktop=phib_bk.bmp
    Screensaver=”0″ LockTerminal=no Type=2 Image=screensave.jpg

    ;*************************************************************
    ;* Time *
    ;*************************************************************

    Timeserver=ntp.crtnet
    TimeZone=’GMT + 01:00′ ManualOverride=yes Daylight=yes Start=100507 End=030507

    TimeZoneName=”W. Europe Standard Time” DayLightName=”W. Europe Daylight Time”

    ;*************************************************************
    ;* Network *
    ;*************************************************************

    SignOn=Yes EnableOK=yes

    ;*************************************************************
    ;* ICA *
    ;*************************************************************

    Seamless=yes
    PnliteServer=fcswps01,fcswps02 AutoConnectList=”Desktop PS07″
    DomainList=fcdb
    SessionConfig=ICA DiskMapTo=Q

    #14416
    ConfGenConfGen
    Keymaster
    • Total Post: 11109
    • Jedi Master
    • ★★★★★★★

    Looks fine to me. (BTW, there is a newer version of ConfGen available)

    Do you see any comment in the WTOS eventlog when connecting the drive? Like mounting drive D: or similar?

    CG

    #14417
    Avatartosodj
    Member
    • Total Post: 19
    • Regular Joe
    • ★★

    No… I can see the boot event log lines with USB pen drive mapping.

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.