Wyse Thin OS built-in password change?

  • This topic is empty.
Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #7022
    AvatarAmerist
    Participant
    • Total Post: 61
    • Back Stage Pass
    • ★★★★

    I can’t get ICA password change to work (for expired passwords). I tried the settings in the guide posted on this site, but I always get the error:

    Citrix signon failed.

    When I enabled signon=NTLM I do get a prompt about a password needing to be changed in a new session, etc. If I don’t actually make the change (hit cancel) I am brought back to the login box where it says “Enter New Password…” and I enter the original password. Then, a new box that I’ve never seen before pops up that prompts me to set a new password. It has two boxes, one for new password and one to confirm new password. If I use this “built-in” password changing box, I get a confirmation on the screen that says “SMB: Password Changed”. I would like to use this built-in password changing mechanism without having to pop open the RDP session first, but I can’t get this second box to appear without first seeing the RDP session and cancelling out of it.

    What am I doing wrong. Here’s my settings that allows me to see this.


    ;*************************************************************
    ;* Global Parameters *
    ;*************************************************************

    Signon=NTLM DisableGuest=yes
    PasswordServer=10.201.8.211 Connect=ica encryption=Basic

    RegisterWINS=yes
    autoload=2
    AdminMode=yes
    Admin-Username=OECFONCBOKCGPACBPGDCODCJPO
    Admin-Password=REDACTED
    EnableGKey=yes
    Vncprompt=0

    ;*************************************************************
    ;* General 3 *
    ;*************************************************************

    FixLicense=clean
    SysMode=Classic
    toolbardelay=2
    LightGray="145 155 160"
    MediumGray="65 85 95"
    DisableAddConnection=yes

    ;*************************************************************
    ;* Input Devices *
    ;*************************************************************

    Language=Us

    ;*************************************************************
    ;* Display *
    ;*************************************************************

    Privilege=None ShowDisplaySettings=DDC-Only
    DeskColor="150 0 45"
    Desktop=maroon_agm_background1920x1200.bmp Layout=Center
    FormURL=AGM_logo_352x80.gif
    ScreenSaver=15 SoftSaver=no LockTerminal=no Type=2 Image=AGM_wb_499x170.bmp

    ;*************************************************************
    ;* Time *
    ;*************************************************************

    Timeserver=TUCAD1 Timeformat="12-hour format" Dateformat=mm/dd/yyyy
    TimeZone='GMT - 07:00' ManualOverride=yes

    ;*************************************************************
    ;* Network *
    ;*************************************************************

    Community=public
    DomainList=REDACTED
    MaxVNCD=1
    VncPassword=REDACTED Encrypt=yes

    ;*************************************************************
    ;* Services *
    ;*************************************************************

    Service=WDM disable=yes

    ;*************************************************************
    ;* Printing *
    ;*************************************************************

    # Printing is handled in the MAC.ini file


    ;*************************************************************
    ;* General Session *
    ;*************************************************************

    SessionConfig=ALL UnmapPrinters=no MapDisks=yes
    LowBand=No

    ;*************************************************************
    ;* ICA *
    ;*************************************************************

    IcaBrowsing=UDP
    Seamless=yes FullscreenReserved=yes
    PnliteServer=10.201.8.221
    ReconnectAtLogon=0
    ReconnectFromButton=1
    RequestIconDataCount=50

    SessionConfig=ICA
    DesktopMode=Fullscreen
    Mapdisksunderz=yes
    AudioQuality=High

    ;
    ;- ICA Session 1 -
    ;- Each line but the last must end with a '' -
    ;

    CONNECT=ICA
    BrowserIP="10.201.8.219:6599;10.201.8.211:6599"
    Application=
    Description=
    Colors=true
    AudioQualityMode=1
    Fullscreen=yes
    Resolution=seamless
    Logon_Mode=local-user
    LocalCopy=no
    #21516
    AvatarAmerist
    Participant
    • Total Post: 61
    • Back Stage Pass
    • ★★★★

    I figured it out on my own.

    I just had to remove the PasswordServer= line from my WNOS.INI and leave everything else the same.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.