WYSE TCX USB not functioning on R50L

  • This topic is empty.
Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #6261
    mpaltom
    Member
    • Total Post: 7
    • Newbie

    Hi all, we have the Wyse R50L thin clients and have been having some difficulties. We installed the TCX Suite onto the server that WDM is on, and we can’t seem to get everything functioning properly. We can get a USB mouse to work when we remote into our windows terminal servers, but when we plug in a flash drive nothing appears in the remote session. Any ideas? Thanks.

    #19471
    ConfGen
    Keymaster
    • Total Post: 11410
    • Jedi Master
    • ★★★★★★★

    What server OS are you using? Which R50L firmware? Have you enabled USB redirection in the Control Panel?

    CG

    #19476
    mpaltom
    Member
    • Total Post: 7
    • Newbie

    The Server with TCX and WDM installed is a VM on XenCenter running Windows Server 2008 R2 64 bit.

    The Terminal Servers we are connecting to are also VMs on XenCenter running Windows Server 2008 R2 64 bit.

    Do we need to enable USB redirection on the terminal servers or the WDM server?

    The firmware we are running is 11.0.112

    #19479
    ConfGen
    Keymaster
    • Total Post: 11410
    • Jedi Master
    • ★★★★★★★

    No, on the R50L in the Control Center. There is an applet TCX USB where you have to enable TCX first.

    CG

    #19485
    mpaltom
    Member
    • Total Post: 7
    • Newbie

    Yes it’s enabled. On the control center under TCX USB virtualizer it says it’s in enabled and under the configuration tab all but 3 boxes are checked.

    #19487
    ConfGen
    Keymaster
    • Total Post: 11410
    • Jedi Master
    • ★★★★★★★

    In the session open the TCX Configuration and go to General – Troubleshooting. Enable troubleshooting for USB. Use “Advanced” and Type “textfile”.
    Now start a new session, plug in some USB devices and check the usbv.log in c: for hints.

    CG

    #19490
    mpaltom
    Member
    • Total Post: 7
    • Newbie

    Ok doing that now, another quick question. The TCX Suite we install on the server side… does that get installed on the WDM server or the terminal servers we are using to remote into with the clients?

    #19491
    mpaltom
    Member
    • Total Post: 7
    • Newbie

    Ok, I did what you said and then I remoted into the server with TCX Server installed on it. I opened the log file and this is what it says:

    ****************************************************************************
    TCX USB Virtualizer : 4.0.1.21
    ****************************************************************************
    g_nDebugZone = 0xffff, “File logging” enabled

    Logging time: Wed Dec 01 09:13:31 2010
    +OnSessionChange(), Event = WTS_SESSION_LOGOFF, ActiveConsole SessionId = 1, SessionId = 3
    +ProcessRemoveSessionNotifications(): Trying to stop USB redirection for session id = 3
    +~CSessionServer()
    -__CleanupThread(), TID = 0x00002dac
    -~CSessionServer()
    USB Redirection disabled for session id = 3

    Logging time: Wed Dec 01 09:13:31 2010
    +OnSessionChange(), Event = WTS_REMOTE_DISCONNECT, ActiveConsole SessionId = 1, SessionId = 3
    HandleRemoteDisconnect(): failed to get protocol, Error = 0x2
    +ProcessRemoveSessionNotifications(): Trying to stop USB redirection for session id = 3
    Session object not found in m_mapSession corresponding to session id = 3

    Logging time: Wed Dec 01 09:13:48 2010
    +OnSessionChange(), Event = WTS_REMOTE_CONNECT, ActiveConsole SessionId = 1, SessionId = 4
    HandleRemoteConnect(): Not handling this notification: Protocol = 2, ConnectionState = 1

    Logging time: Wed Dec 01 09:14:02 2010
    +OnSessionChange(), Event = WTS_SESSION_LOGON, ActiveConsole SessionId = 1, SessionId = 4
    Trying to enable USB redirection for RDP session id = 4
    RDP: Sending ServerInfo to the client via virtualchannel = USBVDX
    USB Redirection enabled for session id = 4 and is active now…
    +__CleanupThread(), TID = 0x00009fc4

    #19492
    ConfGen
    Keymaster
    • Total Post: 11410
    • Jedi Master
    • ★★★★★★★

    This indicates that TCX is running and worlking:
    USB Redirection enabled for session id = 4 and is active now…

    So when you insert any USB device while in the session, nothing happens? Anything in the local SUSE Eventlog?

    CG

    #19494
    mpaltom
    Member
    • Total Post: 7
    • Newbie

    We did some more testing and TCX is working. I can see the usb device and use it. We are now facing the issue of the USB device being visible and usable to all users logged onto the server.

    I saw an older topic dealing with this issue, has there been anymore progress on resolving it or is there a way to work around it? We are setting these up for a college campus computer lab and due to privacy among other things, we can not allow every user logged on to see every usb device someone connects.

    Thanks so much for helping us get this far, TCX has been a thorn in our side for weeks now.

    #19499
    ConfGen
    Keymaster
    • Total Post: 11410
    • Jedi Master
    • ★★★★★★★

    First question, what have you done that it is working now? What was the problem?

    Second, the sharing of the USB devices is by deisgn. The only current option would be a XenDesktop or View environment.

    CG

    #19502
    mpaltom
    Member
    • Total Post: 7
    • Newbie

    The problem was we had the TCX Server Software installed on our WDM server, not our terminal servers. The way it was explained to us was that it need to be on the WDM Server. So pretty much our problem was we just had TCX software installed on the wrong server.

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.