Wyse S10 “HTTP-Header Bad response”

  • This topic is empty.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #3928
    edv
    Participant
    • Total Post: 56
    • Back Stage Pass
    • ★★★★

    Hello,

    first our enviroment:
    – Windows 2003 SP2 (32Bit) / Citrix PS4.0 Rollup 6 (32Bit)
    – several published applications
    – Wyse Thin-Client S10, firmware 5.1.0_28 / 6.3.0_22

    The problem we have is that sometimes the users are not able to establish a connection to the published application, I noticed the following messages in the log file:
    – HTTP-Header: BAD response
    – DNS/WINS can’t resolve

    When the users restart the Wyse-Client it works almost always

    I tried several options in the WNOS.INI (tcptimeout, fixlicense) but no success yet.

    our WNOS.INI configuration:

    #Enable sign-on process
    signon=1
    #Default signo-on user = PC-Name
    Defaultuser=$TN

    #Bitmap filename displayed in the sing-on window
    FormURL=logo.jpg

    #Display all 38 characters in a desktop icon name
    LongApplicationName=yes

    #Controls how the system starts when the power ist first applied to the thin client
    AutoPower=no

    #Save connections persistent in NVRAM (prevent FTP-Single Point of Failure)
    enablelocal=yes

    #Screensaver
    screensaver=0

    #Do not save license in NVRAM
    FixLicense=clean

    #Specifies the local audio volume
    device=audio volume=0

    #Set the time
    TimeZone=”GMT + 01:00″ ManualOverride=yes daylight=yes start=030507 end=100507
    TimeServer=x.x.x.x;x.x.x.x

    #Specifies the desktop background color in RGB string format
    DeskColor=”0 128 128″

    #Lock down thin client
    privilege=none lockdown=no

    #Remote shadow options
    VNCPrompt=no
    VNCPassword=xxxxx

    #This will upgrade to firmware if a newer version exists in the ftp directory
    AutoLoad=1

    user specified INI (example):

    #set screen resolution and refresh rate
    resolution=1280×1024 Refresh=60

    #Lock down thin client
    privilege=none

    #Set correct language
    language=xx

    #Set Mouse Speed
    MouseSpeed=0

    #Setup a connection to an ica server
    connect=ica
    description=”xxxxx”
    icon=ica.bmp
    domainname=domain.com
    HttpBrowsing=yes
    browserip=ica2.domain.com
    application=”
    username=”
    Fullscreen=yes
    autoconnect=yes
    localcopy=yes

    any suggestions would be greatly appreciated,

    best regards,

    Sarge

    #16467
    ConfGen
    Keymaster
    • Total Post: 11417
    • Jedi Master
    • ★★★★★★★

    What happens when the session Could not be established beside the message in the eventlog?
    Does it connect for a second and then stop, doesn’t it connect at all, any pop-up messages, any messages on the Citrix server or on the TS License Server?

    CG

    #16468
    edv
    Participant
    • Total Post: 56
    • Back Stage Pass
    • ★★★★

    Hello ConfGen,

    doesn’t connect at all, when I manually start the connection I recieve the message “ICA connection timed out”. I have to restart the Wyse, then it works!

    In the event logs on the TS License Server (we have user CALs) I see no errors, either on the Citrix Server(s).

    We also use a lot of HP Thin Clients without any problems, so I think it must be a configuration issue.

    best regards,

    Sarge

    #16469
    ConfGen
    Keymaster
    • Total Post: 11417
    • Jedi Master
    • ★★★★★★★

    Can you try to use
    HttpBrowsing=no inside your session configuration
    and
    IcaBrowsing=UDP inside the general ICA configuration
    as well as IcaBrowsing=HTTP and HttpBrowsing=yes as an alternativ to test 1.

    CG

    #16478
    edv
    Participant
    • Total Post: 56
    • Back Stage Pass
    • ★★★★

    Hello ConfGen,

    I’ve inserted the options “HttpBrowsing=no” and “IcaBrowsing=UDP”, at the moment looks good! I’ll have a try until the end of the week with the other Wyse-Clients, let you know if the problem is solved definitely.

    Thanks a lot!

    regards,

    Sarge

    @ConfGen wrote:

    Can you try to use
    HttpBrowsing=no inside your session configuration
    and
    IcaBrowsing=UDP inside the general ICA configuration
    as well as IcaBrowsing=HTTP and HttpBrowsing=yes as an alternativ to test 1.

    CG

    #16491
    edv
    Participant
    • Total Post: 56
    • Back Stage Pass
    • ★★★★

    Problem seems to be solved! No problems or connections timed out.

    thanks again to ConfGen!

    regards,

    Sarge

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.