WYSE S10 – Autoconnect to Published Desktop WTOS 6.5

  • This topic is empty.
Viewing 15 posts - 1 through 15 (of 23 total)
  • Author
    Posts
  • #7444
    Avatarspammeh
    Member
    • Total Post: 8
    • Newbie

    Hi All,

    We’ve got a number of WYSE S10 that’s we’ve upgraded to WTOS 6.5 that we want to autoconnect to a published desktop on XenApp 6.5.

    We can get this to do it if we define a particular XenApp host server, but I dont want to do that incase that particular host server is unavailable at any time, therefore preventing S10 users logging on.

    Ideally, they would connect to the web interface (which will always be available) and connect to the published desktop that way. Unfortunately, despite being able to ping the web interface with no issues from the terminal, it cannot find the published applications on there.

    Is there any way round this or is the only way to get the users to log on to the terminal with their domain credentials and get them to manually click on the published desktop every time?

    Thanks in advance,

    Sam

    #22622
    Avatarspammeh
    Member
    • Total Post: 8
    • Newbie

    I’ve re-read my post and I think I should clarify a few things.

    Our S10’s (on firmware 5.0) used to have a predefined application (the PS4.5 Desktop) which used to autoconnect on startup and present the user with the server 2003 logon screen.

    What I want is for the same to happen on the S10’s (firmware 6.5) but on to our XenApp 6.5 desktop.

    The only way I’ve managed to get this working at the moment is directly to a XenApp server, however this will mean that all users will connect to that particular server as opposed to the other servers in the farm.

    Hopefully I’ve explained that a little better now..!

    #22623
    ConfGenConfGen
    Keymaster
    • Total Post: 11114
    • Jedi Master
    • ★★★★★★★

    This is quite simple.
    Create a PNAgent site along with your webinterface and point the S10 to that site. If you are using a wnos.ini just add
    SignOn=yes
    Pnliteserver=your_pnagent_site

    If not, add “your_pnagent_site” to the PNliteserver field in the server connection.

    CG

    #22630
    Avatarspammeh
    Member
    • Total Post: 8
    • Newbie

    Below is my wnos.ini. When logging in I get prompted with the username / password / domain prompt for PNAgent. Credentials are entered and it accepts it fine. It then logs me in (name changes on bottomleft hand corner) and the connect manager window comes up. Listed there are all the available application from that pnagent site, including the “XenApp Desktop” app. I can manually connect to it and works perfectly, but I can’t get it to connect automatically once a user has logged into PNAgent. Any ideas?

    autoload=2
    Privilege=High

    Language=Uk

    Screen=1 Resolution=1280×1024

    Timeformat=”24-hour format”
    Daylight=yes Start=030507 End=100507
    TimeZone=’Greenwich Mean Time’ ManualOverride=yes

    SignOn=Yes
    DisableDomain=yes
    DomainList=”domain”

    IcaBrowsing=HTTP
    Pnliteserver=http://access/Citrix/PNAgent1/config.xml ReconnectAtLogon=2 ReconnectFromButton=2 AutoConnect=1

    AutoConnectList=”XENAPP6LIVE:XenApp Desktop”

    #22632
    ConfGenConfGen
    Keymaster
    • Total Post: 11114
    • Jedi Master
    • ★★★★★★★

    Change your wnos.ini to this:

    Pnliteserver=http://access/Citrix/PNAgent1/config.xml ReconnectAtLogon=2 ReconnectFromButton=2 AutoConnectList=”XENAPP6LIVE:XenApp Desktop”

    The autoconnectlist string is case sensitive.

    CG

    #22634
    Avatarspammeh
    Member
    • Total Post: 8
    • Newbie

    I’ve just made that change, same results infortunately. Any other ideas?

    #22636
    ConfGenConfGen
    Keymaster
    • Total Post: 11114
    • Jedi Master
    • ★★★★★★★

    When you edit the connection on the S10, then you should see the correct name in the “Application Name” field. Use this with the Autoconnectlist parameter.

    Anything in the log file?

    CG

    #22638
    Avatarspammeh
    Member
    • Total Post: 8
    • Newbie

    I’ve checked the connection details within the application properties and it displays as “XENAPP6LIVE:XenApp Desktop”

    How do I see the logs?

    #22642
    ConfGenConfGen
    Keymaster
    • Total Post: 11114
    • Jedi Master
    • ★★★★★★★

    In the System Information.
    Can you test with a published name without a space?

    CG

    #22645
    Avatarspammeh
    Member
    • Total Post: 8
    • Newbie

    The last line on the System Information after I’ve logged into the PNAgent is as follows:

    ICA: pnhost = “access”

    I’ve tested with an application that has no space as unfortunately the same result occurs.

    #22664
    Avatarspammeh
    Member
    • Total Post: 8
    • Newbie

    Still not managed to resolve this, has anyone got any more ideas?

    #22669
    ConfGenConfGen
    Keymaster
    • Total Post: 11114
    • Jedi Master
    • ★★★★★★★

    What happens when you use
    Pnliteserver=http://access/Citrix/PNAgent1/config.xml ReconnectAtLogon=2 ReconnectFromButton=2 AutoConnectList=”XENAPP6LIVE:*”

    This should autostart ALL published apps.
    If that works you can narrow it down by using
    Pnliteserver=http://access/Citrix/PNAgent1/config.xml ReconnectAtLogon=2 ReconnectFromButton=2 AutoConnectList=”XENAPP6LIVE:Xen*”
    or
    AutoConnectList=”XENAPP6LIVE:XenApp*”
    and so on.

    CG

    #22704
    Avatarlufc1919
    Member
    • Total Post: 2
    • Newbie

    Hello

    I work alongside Spammeh and we have no managed to get this autoconnect working.

    I just have a couple of new questions if I may?

    How do I force the connected session to run in acertain resolution? The terminal works at 1280×1024 but the desktop session doesnt.

    How do I force the session to completely log out when the user logs out of the desktop application? (The terminal remains logged in as them)

    How do I enable session reliability for sessions.

    Finally, for some reason the terminal takes 2 attempts of picking up a DHCP when booted up…….any ideas?

    Many thanks

    #22706
    ConfGenConfGen
    Keymaster
    • Total Post: 11114
    • Jedi Master
    • ★★★★★★★

    How do I force the connected session to run in acertain resolution? The terminal works at 1280×1024 but the desktop session doesnt.

    Not possible if you login via PNagent service. You can create ICA connection manually (via wnos.ini) and define the resolution in there.

    How do I force the session to completely log out when the user logs out of the desktop application? (The terminal remains logged in as them)

    Put “AutoSignoff=yes” in your wnos.ini

    How do I enable session reliability for sessions.

    Put “SessionConfig=ICA SessionReliability=yes” in your wnos.ini

    Finally, for some reason the terminal takes 2 attempts of picking up a DHCP when booted up…….any ideas?

    Put “BootpDisable=yes” in your wnos.ini.

    CG

    #22726
    Avatarlufc1919
    Member
    • Total Post: 2
    • Newbie

    Thanks for this, much appreciated.

    Where abouts do I need to input these into the wnos? Below is a copy of ours.

    ;*************************************************************
    ;* *
    ;* This wnos.ini file was generated with the *
    ;* Configuration File Generator 6.3.06 *
    ;* Copyright by Thomas Moellerbernd *
    ;* *
    ;* http://www.technicalhelp.de *
    ;* *
    ;*************************************************************

    ;*************************************************************
    ;* General 1 *
    ;*************************************************************

    autoload=2
    Privilege=high
    AutoSignoff=yes

    ;*************************************************************
    ;* Peripherals *
    ;*************************************************************

    Language=Uk

    ;*************************************************************
    ;* Display *
    ;*************************************************************

    ; If you are using a version of WTOS code < 7.0.1_13 please use:
    ; Resolution=1280×1024 Refresh=
    Screen=1 Resolution=1280×1024

    ;*************************************************************
    ;* Time *
    ;*************************************************************

    Timeserver=Timeserver Timeformat=”24-hour format”
    ; If you are using an older version of WTOS code please use:
    ; TimeZone= ‘GMT’ ManualOverride=yes Daylight=yes Start=030507 End=100507

    TimeZone=’Greenwich Mean Time’ ManualOverride=yes

    ;*************************************************************
    ;* Network *
    ;*************************************************************
    SignOn=Yes
    DisableDomain=yes
    DomainList=”net1″

    ;*************************************************************
    ;* ICA *
    ;*************************************************************

    IcaBrowsing=HTTP
    Pnliteserver=http://server1/Citrix/PNAgent1/config.xml ReconnectAtLogon=2 ReconnectFromButton=2 AutoConnectList=”XENAPP6LIVE:XenApp Desktop”

Viewing 15 posts - 1 through 15 (of 23 total)
  • You must be logged in to reply to this topic.