Wyse S10 Administrator Mode

  • This topic is empty.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #5832
    Aten
    Member
    • Total Post: 4
    • Newbie

    Hello,

    I am new to Wyse clients and can not get into administrator mode its greyed out I have searched high and low and used keys shift escape with no joy would appreciate some help please

    #18146
    Aten
    Member
    • Total Post: 4
    • Newbie

    Just to add to this here is my ini config file I can get to my FTP server etc I just want to get into admin mode and also setup single sign on with a published citrix desktop launching the moment they login, I want to get into admin mode to set a static ip and file server to a dev ftp server with the new ini without changing my live ftp details which are published through DHCP as we currently have users access the wyse clients.

    # Enable the sign-on process. Default=1 (enabled)
    #SignOn=Yes
    #SignOn=No
    SignOn=Yes ConnectionManager=Hide DisableGuest=yes
    # List of domain names that appear in Thin Appliances sign-on
    # window to help users select domain to sign on to PNLite servers
    #DomainList=mydomain
    DomainList=”mydomain”
    #
    # Selects firmware update mode. 0=Disable checking for image,
    # 1(default)=Enable upgrade/downgrade, 2=Enable upgrade only
    autoload=0
    #
    # This FTP Server IP address or DNS name is entered into Thin Applicnce local setup (non volatile)
    # and the Thin Appliances immediately use this server to access files.
    # N/A, as DHCP sets this.
    #FileServer=10.0.0.0
    #
    #Default sign-on user.
    #DefaultUser=guest
    #DefaultUser=testuser
    #
    # SelectServerList and PasswordServer??? what are these??? will they help with no domain accounts?
    #SelectServerList=PNA ; pnagentserver
    #PasswordServer=passwordserver

    ;*************************************************************
    ;* ICA *
    ;*************************************************************
    #Controls the default setting for ICA connections, ver 4.2+
    Seamless=yes
    # List of IP addresses or host names with optional port number of PNLite servers. Default=empty
    # Must be a PNLite server (Citrix PN Agent), i.e. Web Interface with a PN Agent site
    #PnliteServer=10.0.0.0 ReconnectAtLogon=1 ReconnectFromButton=2
    #PnliteServer=Myserver
    PNLITESERVER=”MyServer”
    #PnliteServer=10.0.0.0
    # Enable Alt Tab function between published apps
    #SwitchApplication=yes
    #
    # Enables ICA7.0 Speedscreen Browser Acceleration Function
    Speedbrowser=on

    ;*************************************************************
    ;* Security *
    ;*************************************************************
    # Controls operator access to Thin Appliance resources:
    # None=System Setup disabled, setup submenu cannot be displayed
    # Low(default)=network selection disabled
    # High=No restrictions; all Thin Appliance resources available
    # Lockdown=Optional parameter, prevents use of G-key reset and removal of LAN cable to gain access to settings.
    # LockDown is persistent over reboots as it’s written to Flash, only another Priveledge or Lockdown=no command
    # will counter the Lockdown=yes, so if FTP server is unavailable then it’s possible to be shutout (i.e. if your
    # off the subnet, have no ethernet etc, and Lockdown=yes was the last setting written to Flash from wnos.ini).
    # USE THIS LINE WHEN RESTRICTED USE REQD, once Winterms are inplace and security is desired
    #Privilege=High LockDown=no
    # USE THIS LINE WHEN RESTRICTED USE REQD, but allow ‘Network Test’ and ‘Mouse Settings’
    Privilege=None Lockdown=yes EnableNetworkTest=yes EnableKeyboardMouseSettings=yes
    # USE THIS LINE WHEN ADMIN USE REQD
    #Privilege=High LockDown=no
    # USE THIS LINE FOR when configuring and moving Winterms around subnets, so as not to get locked out
    #Privilege=High Lockdown=no

    ;*************************************************************
    ;* Display *
    ;*************************************************************
    # Maximum connection resolution
    #Resolution=1024×768
    Resolution=1280×1024
    # Specifies the desktop background color in RGB, 255 255 255 = White, 16 100 36 = green, 58 110 165 = Windows Blue
    DeskColor=”255 255 255″
    # BMP, jpeg of gif file to be used for the desktop wallpaper
    Desktop=bucklogo.gif Layout=Center
    # ScreenSaver time, LockTerminal, Type 2 = Moving image, Image = imagefile
    Screensaver=”60″ LockTerminal=yes Type=2 Image=bucklogo.gif
    # URL to a sign-on window form or a bitmap filename displayed in the sign-on window
    formurl=bucklogo.gif

    ;*************************************************************
    ;* VNC *
    ;*************************************************************
    # Version 4.3 and later only. Default=0 (disabled), non zero = count of concurrent VNC sessions, Max = 5
    MaxVNCD=1
    #VncPassword=plaintext
    VncPassword=”helpmeNOW” Encrypt=yes
    #VncPrompt=0
    VncPrompt=No Accept=5

    ;*************************************************************
    ;* Time *
    ;*************************************************************
    # IP address of a network Time Server
    Timeserver=10.0.0.0 Timeformat=”12-hour format” Dateformat=dd/mm/yyyy
    #TimeServer=dc001.mydomain.com Timeformat=”12-hour format”
    TimeZone=’Greenwich Mean Time’ ManualOverride=yes Daylight=yes Start=030507 End=100507 TimeZoneName=”Greenwich Standard Time”

    ;*************************************************************
    ;* General 3 *
    ;*************************************************************
    # Notice File is a text file to display before logon. Timeout is the period before it returns if no logon.
    NoticeFile=notice.txt Timeout=60

    #18148
    aLiE
    Participant
    • Total Post: 320
    • Jacked into The Matrix
    • ★★★★★★

    First of all i would really advise you to use the ‘Configuration Generator” if not already if you just started using Wyse terminals.
    When using the Configuration Generator you can also encrypt passwords which is always a good idea.

    The reason you can’t get into the admin mode is because you are missing the adminmode parameter.

    example :

    AdminMode=yes Admin-Username=blabla Admin-Password=blabla
    Privilege=none Lockdown=no HideSysInfo=no HidePPP=yes HidePN=yes HideConnectionManager=no EnableNetworkTest=yes EnableTrace=yes ShowDisplaySettings=yes EnableKeyboardMouseSettings=yes

    So you will need to change your line :

    Privilege=None Lockdown=yes EnableNetworkTest=yes EnableKeyboardMouseSettings=yes

    into something like the example above.

    #18149
    Aten
    Member
    • Total Post: 4
    • Newbie

    Hello,

    Thanks I managed to get this sorted last night I only have one problem which is auto launching a published desktop it just times out any ideas config below:

    The Desktop published app is on my wyse client desktop and works when I manually double click it but now when I use the below in the ini

    CONNECT=ICA
    BrowserIP=10.203.251.99
    Application=”Desktop”
    Description=”Login to Network…”
    Icon=ica.bmp
    AutoConnect=1
    HTTPBrowsing=yes
    LocalCopy=no

    #18150
    aLiE
    Participant
    • Total Post: 320
    • Jacked into The Matrix
    • ★★★★★★

    The reason it times out is because “nobody/none” is logging into the publish desktop, it’s a windows default behavior.
    By default Windows won’t stay and wait for ever on the login screen untill someone logins, it will time out and disconnects you the main reason behind this is the “Load Throttling”.

    If you want to see this (on Citrix) just connect to any Citrix Server and wait at the login screen, connect with admin rights to any Citrix server on the same farm and type “qfarm /ltload” you will see the “load” at that point.

    #18151
    Aten
    Member
    • Total Post: 4
    • Newbie

    Hello Alie,

    Thanks for all your input so far even when I use the following I still get the same issue

    CONNECT=ICA
    BrowserIP=10.203.251.99
    Application=”Desktop”
    Description=”Login to Network…”
    Icon=ica.bmp
    AutoConnect=1
    Username=$UN
    Password=$PW
    Domainname=$DN
    HTTPBrowsing=yes
    LocalCopy=no

    My citrix servers do pass through connection so my assumption was if I remove Username, Password and Domain this should pass through the credentials already used any ideas why it still does not work.

    1, I login fine to the terminal it then automatically attempts to launch the desktop reads Connecting to “Desktop” and then ICA[Desktop]: Connection timed out

    I have tried it by specifying username, password and domain in the ini without any joy

    CONNECT=ICA
    BrowserIP=10.203.251.99:
    Application=”Desktop”
    Description=”Login to Network…”
    Icon=ica.bmp
    AutoConnect=1
    Username=User
    Password=Password
    Domainname=Mydomain
    HTTPBrowsing=yes
    LocalCopy=no

    Log is reading

    23: http header: Bad Response
    24: Socket Connect: Connection timed out

    #18152
    ConfGen
    Keymaster
    • Total Post: 11425
    • Jedi Master
    • ★★★★★★★

    Hi,

    remove the ICA connection again from your ini file. It does not mak sense to login to your XA server and then not use the publihed apps.

    Edit your line
    PnliteServer=MyServer
    and change to
    PnliteServer=MyServer AutoConnectList=”Desktop”

    This will autolaunch the published app “desktop”.

    CG

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.