Wyse FTP Configuration / Upgrade / VNC access

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #53821
    Avatarmkurpichau
    Participant
    • Total Post: 4
    • Newbie

    Dear forum gurus!

    pls help me out a little bit. I recently inherited a small business to support that uses approximately Dell Wyse 5040 AIO thin clients. These clients were all purchased a few years ago and are currently out of warranty. I am not very familiar with Dell Wyse units but from what i understand here, previous IT admin never setup anything like Central Configuration, no FTP management, nor WDM.

    Each and every terminal is manually programmed and in a way they function well: they all connect via RDP to the terminal server. However since most of my work i normally do remotely, i was trying to figure out how to enable VNC connectivity to the Wyse clients. I also wanted to create a uniform environment for these clients: bring them all to latest ThinOS 8.6 as some are ThinOS 8.2, some are 8.0, etc.

    I decided to try with enabling VNC first and miserably failed. This is what i tried to do:

    1. On my FTP server i enabled anonymous login
    2. Created following folder structure: c:\inetpub\ftproot\wyse\wnos\
    3. Placed wnos.ini file in wnos folder and put following code in it:
    Service=vncd Disable=No
    VNCPassword=12345678 Encrypt=No
    VNCPrompt=No
    4. In one of the clients i click Desktop – System Setup – Central Configuration
    5. Under File Server/Path i entered IP address of my FTP server
    6. Restarted thin client and then tried to connect to it via TightVNC and got following error: No connection could be made because the target machine actively refused it.

    Then i tried to upgrade the machine to 8.6.

    This is what i did:
    1. Installed USB imaging tool
    2. Downloaded following Marlin image: ThinOS 8.6_015 English Merlin Image file for Dell Wyse 5040 thin clients with PCoIP
    3. Pushed it to USB key (Sandisk Cruiser)
    4. Booted from USB and tried to install the image and got following error message:]

    Error while validating security key (error code 233)
    Please review the following reason may be Error while validating security key
    – Eeprom validation
    – Mismatch between security key of the device and security key present in the XML file of image package
    – Check if you are trying to deploy correct image for the intended platform. Re-register the correct image package.

    Please help me out figure this out

    #53822
    ConfGenConfGen
    Keymaster
    • Total Post: 11270
    • Jedi Master
    • ★★★★★★★

    Error 1: enter IP/Wyse as the Fileserver path on the Client

    Error 2: you have chosen the wrong image. Either you have selected a ThinOS including PCoIP image and only have a unit with ThinOS, or vice versa.
    Whatever, once your fileserver works you can update all clients via that way. Easier and faster.

    CG

    #53824
    Avatarmkurpichau
    Participant
    • Total Post: 4
    • Newbie

    Wow, this is great, thank you so much ConfGen!

    I believe now the clients are connecting to FTP server but i still have issues:

    Client 1: i tried to only use this settings in wnos.ini:

    Service=vncd Disable=No
    VNCPassword=12345678 Encrypt=No
    VNCPrompt=No

    upon starting the client pops up with Dell logo username and password and a checkmark “Check here to change password” and i have no idea what this username/password it’s asking me about.

    Client 2: i tried to use a sample wnos.ini file i downloaded from Dell Wyse support and after rebooting it’s now prompting me to enter password for VMWare Horizon and i can’t even get rid of it anymore, because i cannot get access to System Setup (it’s greyed out)

    thank you so much in advance for your help

     

    #53825
    ConfGenConfGen
    Keymaster
    • Total Post: 11270
    • Jedi Master
    • ★★★★★★★

    Add

    Privilege=high
    SignOn=no

    to your wnos.ini

    CG

    #53826
    Avatarmkurpichau
    Participant
    • Total Post: 4
    • Newbie

    Amazing! that helped. thank you!!!

    I am no longer prompted and it looks like i can use tightvnc.

    I was able to also remove VMware broker from the machine that “became” vmware horizon machine.

    i am going to play a little bit with settings of wnos.ini – to see if i can create default connections – do you have on most useful wnos.ini settings so i can create consistency in the network? for example time is wrong on most Dell Wyse terminals, and connection names vary from machine to machine, creating slightly chaotic environment.

    Also how do i now update to 8.6 using FTP?

    #53827
    ConfGenConfGen
    Keymaster
    • Total Post: 11270
    • Jedi Master
    • ★★★★★★★

    Download the Configuration Generator from this website.
    Download the firmware from Dell.com/support and copy the extracted file to your wnos folder.

    CG

    #53833
    Avatarmkurpichau
    Participant
    • Total Post: 4
    • Newbie

    Wow this utility is great! Thank you.

    i was able to upgrade my terminals now to 8.6.511.

    Do you recommend BIOS update as well? I see BIOS in the terminals is from 2015?

    I also started getting certificate errors after upgrade but i saw another post where you recommended this setting:

    SecurityPolicy=low

    and it worked for me.

     

    #53881
    ConfGenConfGen
    Keymaster
    • Total Post: 11270
    • Jedi Master
    • ★★★★★★★

    Yes, BIOS updates should be done

    CG

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.