WTOS “include” parameter

  • This topic is empty.
Viewing 15 posts - 1 through 15 (of 21 total)
  • Author
    Posts
  • #472
    AvatarDpizzle
    Member
    • Total Post: 19
    • Regular Joe
    • ★★

    Hello all,

    I have come across the “include” parameter in the administrator’s guide for 5.2 and it mentions referencing another ini file based on a variable such as a terminal’s MAC address. I have followed the instructions and have not gotten it to work properly yet. But the bigger question is when and where would this statement be useful? what kind of situations would it be helpful to add a specific set of controls to a device by MAC? printers maybe?

    Thanks in advance

    #9738
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Hi,

    Thats an interesting one…

    In a normal wnos.ini deployment if you have signon=1 you ask a user to log on to the terminal. You can take that username and create a username.ini which appends to the wnos.ini.

    So, say you have a setting that a particular user should always need you can include this in the username.ini.

    In VDI environments with a WTOS aware connection broker there is no wnos.ini. The connection broker takes the username and hands back the variuos settings.

    This include command can be used in this environment to pull in a username.ini based on a variable. Here is an example…

    include=$mac.ini

    On log in the device looks for a user ini based on the MAC address of the terminal, this ini could have a printer set up for example. In this case any user logging into this device would get that printer.

    This command was created so a user ini could be used in a connection broker environment and the standard username.ini will normally do the same job however to concept of basing settings on terminal rather than username could be very useful,

    Cheers,
    -TT

    #9743
    AvatarDpizzle
    Member
    • Total Post: 19
    • Regular Joe
    • ★★

    I spoke to a Wyse Product Manager and he suggested that it is possible to create “1 off” terminals using the include parameter and the unit’s MAC address. So i basically copied my wnos.ini file changed the signon=yes to no, and added an auto-connecting RDP session to a published Internet Explorer session on one of our terminal servers, and I am now able to use the client a s purely Kiosk terminal, while maintaining the integrity of the other clients that require logins.

    Just thought I would give an update on this situation.

    #9949
    Avatardbla
    Member
    • Total Post: 14
    • Regular Joe
    • ★★

    I’ve been using this one for a while. I use it when I need to setting to “stick” to a specific device without affecting other users and devices on the ftp server. For example, if I want to configure a locally attached printer for a device that is always available regardless of whom is logging into it. I’ve also used this to set display settings.

    in the wnos.ini I just add include=$mac.ini

    in your wysewnos directory create a folder “inc”
    place your $mac.ini files within that folder, the device matching the mac address will pick up that file automatically at boot, in the device event log you should be able to see it using the new .ini file.

    This should work in any version higher than 5.2.0_46. Might work with earlier 5.2.0 releases, but can’t be sure of this one.

    What drives me nuts is that Wyse won’t officially support this functionality.

    Hope this helps
    ..

    #11127
    Avatarwigadore
    Member
    • Total Post: 13
    • Regular Joe
    • ★★

    I seem to be having issues with this and I hope someone can help.

    I have two V10L’s which are on system version 6.0.0_14 and I have a wnos.ini file like this.

    connect=ica 
    icon=ica.bmp
    description="IS Desktop"
    browserip=ica
    application=Desktop
    httpBrowsing=1
    autoconnect=1
    fullscreen=yes
    lowBand=yes
    colors=256

    include=$008064622ace.ini
    include=$00806462a8fe.ini

    Inside my inc folder under the wnos folder I have the two ini files as such


    signon=0
    deskColor="0 78 152"
    vncPrompt=0
    Dualhead=no Mainscreen=1 Orientation=hort
    Resolution=800x600 Refresh=60

    and


    signon=0
    deskColor="0 0 0"
    vncPrompt=0
    Dualhead=no Mainscreen=1 Orientation=hort
    Resolution=1024x768 Refresh=60

    I reboot both clients and they both configure with the setting in the first ini file. The second ini file seems to be ignored by the client with that MAC address. WHY???

    #11130
    AvatarDpizzle
    Member
    • Total Post: 19
    • Regular Joe
    • ★★

    The include line should look like this

    include=$MAC.ini

    and the ini files in the ‘inc’ directory should be:

    008064622ace.ini
    00806462a8fe.ini

    after you make those changes the thin clients should use the new settings.

    Let us know how it goes

    #11133
    Avatarwigadore
    Member
    • Total Post: 13
    • Regular Joe
    • ★★

    I thought that MAC needed to be replaced by the actual MAC Address. Oops.

    As for the settings they are still not changing. The resolution, background color, and dual vs single screen are not working. Any idea why?

    #11134
    AvatarDpizzle
    Member
    • Total Post: 19
    • Regular Joe
    • ★★

    Are the ini files in the inc folder named with the correct MAC address of the unit you are trying to control? Its pretty easy to fatfinger a MAC address.

    Otherwise your code looks the same as mine does.
    that should be the structure and location of the files.
    /wnos
    wnos.ini

    /wnos/inc
    0080645121af.ini

    #11135
    Avatarwigadore
    Member
    • Total Post: 13
    • Regular Joe
    • ★★

    I agree with the fat finger as I have done that many times before. I have checked and double checked it and they are typed correctly.

    wysewnos has the wnos.ini file
    wysewnosinc has the 0080645121af.ini

    The only thing that they are doing right is configuring the published app in the wnos.ini file. The resolution and dual/single screen config in the 0080645121af.ini files are being ignored.

    Could you post your wnos.ini and one inc file? Thanks for the help so far.

    #11136
    AvatarDpizzle
    Member
    • Total Post: 19
    • Regular Joe
    • ★★

    Here is a wnos file that is very similar to mine, but not exactly mine, as mine has the password hashes and IP addresses in it.



    ;*************************************************************
    ;* *
    ;* This wnos.ini file was generated with the *
    ;* Configuration File Generator *
    ;* Copyright by Thomas Moellerbernd *
    ;* *
    ;*************************************************************


    ;*************************************************************
    ;* General 1 *
    ;*************************************************************

    autoload=1
    AdminMode=yes Admin-Username=MEAFMNABMK Admin-Password=MEAFMNABMK
    Privilege=High EnableTrace=yes

    ;*************************************************************
    ;* General 3 *
    ;*************************************************************

    Autopower=yes

    ;*************************************************************
    ;* Display *
    ;*************************************************************

    Resolution=1024x768 Refresh=60
    Screensaver="20" LockTerminal=no Type=2 Image=screensvr.jpg

    ;*************************************************************
    ;* Time *
    ;*************************************************************

    Timeserver=pool.ntp.org Timeformat="12-hour format" Dateformat=dd/mm/yyyy
    TimeZone='GMT - 07:00' ManualOverride=yes Daylight=yes Start=030507 End=100507 TimeZoneName="US Mountain Standard Time"

    ;*************************************************************
    ;* Network *
    ;*************************************************************

    Device=Ethernet Speed="10M HD" MTU=500
    SignOn=Yes ConnectionManager=Hide DisableGuest=yes
    MaxVNCD=1
    VncPassword="OACLPKDKONGIJNFJIPFJILEBJGFH" Encrypt=yes
    VncPrompt=No Accept=

    ;*************************************************************
    ;* Printing *
    ;*************************************************************

    PrinterMap=printermap.ini

    ;*************************************************************
    ;* General Session *
    ;*************************************************************

    SessionConfig=ALL UnmapPrinters=no

    include=$MAC.ini

    here is a inc file.


    Resolution=1280x1024 Refresh=60
    Dualhead=yes Mainscreen=2 Orientation=horizontal
    Desktop=techservwallpaper.jpg Layout=center
    SCreenSaver=10 Type=2 Image=techservsrcnsvr.bmp

    Device=Ethernet speed="Auto"

    If you haven’t tried it yet, I would recommend trying out the configuration generator out to create the wnos an ini files.

    #11137
    Avatarwigadore
    Member
    • Total Post: 13
    • Regular Joe
    • ★★

    I am going to try doing a manual edit…but where do I find this configuration generator you speak of. Again tahnks for your help and speedy replies.

    #11138
    AvatarDpizzle
    Member
    • Total Post: 19
    • Regular Joe
    • ★★

    the configuration generator is actually on this site under downloads and WTOS.

    #11140
    ConfGenConfGen
    Keymaster
    • Total Post: 9896
    • Jedi Master
    • ★★★★★★★

    You can download it from my HP

    Cheers
    ConfGen

    #11156
    Avatarwigadore
    Member
    • Total Post: 13
    • Regular Joe
    • ★★

    Thanks for the Config Tool. Makes life alot more simple. I am still stuck on one issue now. I would like to set the ICA resolution in the mac.ini files for the client itself as I have some users that still like 800×600. So far I have only been able to set this in the wnos.ini file only. I am sure it’s simple, but my head hurts and I am not getting far fast!

    #11158
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    I generally do not set the resolution in the .ini file as it means managing the resolution for each user which is a pain, if a user changes machine you have to change everything again.

    I set:
    Privilege=none lockdown=no ShowDisplaySettings=yes EnableKeyboardMouseSettings=yes

    This locks the unit down but allows users to set their own screen res and mouse settings.

    I have not tried the resolution= command in the include= file but as this is a global in may not work as the include is designed to add connect= strings.

    You could use a DHCP reservation to point a few units to a new wnos.ini or use WDM Enterprise with DDC,

    Cheers,
    -TT

Viewing 15 posts - 1 through 15 (of 21 total)
  • You must be logged in to reply to this topic.