WTOS 6.1

  • This topic is empty.
Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #916
    Avatardshaun
    Member
    • Total Post: 59
    • Back Stage Pass
    • ★★★★

    Hey guys

    Just wanted to know how we would go about upgrading my WTOS version on my S10 winterm units to 6.1. Currently i have 5.3.0_09 on my units.

    Thanks

    #11641
    ConfGenConfGen
    Keymaster
    • Total Post: 10981
    • Jedi Master
    • ★★★★★★★

    There are two ways to upgrade.
    1. with costs: Contact Wyse to buy an upgrade
    2. without (direct) costs: if you already have a maintenance contract you can get it for free. If not you should buy maintenance and then refer to point 1.

    Regards
    CG

    #11650
    Avatardshaun
    Member
    • Total Post: 59
    • Back Stage Pass
    • ★★★★

    Thanks for that 😀

    #11651
    Avatardshaun
    Member
    • Total Post: 59
    • Back Stage Pass
    • ★★★★

    ok so now i have the RCA_wnos i need. Now i have placed the file in to the wnos directory but no results. I have tried placing the file in a couple of places in the ftp with no results. What do u reckon?

    Thanks

    DShaun

    #11652
    ConfGenConfGen
    Keymaster
    • Total Post: 10981
    • Jedi Master
    • ★★★★★★★

    The easiest way to find out which path the unit is looking for is to check the FTP server logs.
    This will show you the path the unit tries to access and you can adjust this.

    CG

    #11663
    Avatardshaun
    Member
    • Total Post: 59
    • Back Stage Pass
    • ★★★★

    Found the ftp logs. Everything seems ok. It obviously grabs the wnos.ini file, however the logs shows

    “sent /Rapportserver=[ip address]/wnos/RCA_wnos”

    I dnt think this is right. How would i go about changing the location so its reads the RCA_wnos file in the same location as the wnos.ini file

    Thanks

    dshaun

    #11664
    Avatardshaun
    Member
    • Total Post: 59
    • Back Stage Pass
    • ★★★★

    Also must point out if i didnt make it clear, that the wnos.ini is located on a different server than the ip address used in trying to retrieve the RCA_wnos. I want both on the same location

    #11665
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Hi,

    Quick question, are you using the 186, 161 and 162 option tags in a DHCP server? The S10 should grab the firmware from the same server as the wnos.ini server.

    Recently I discovered a bug that prevented this happening when WDM and the above option tags are used.

    If you are not the device is not looking at the server you expect so check your 161 option tag setup,

    Cheers,
    -TT

    #11673
    Avatardshaun
    Member
    • Total Post: 59
    • Back Stage Pass
    • ★★★★

    Hey,

    Yeah, currently im using 161 and 162 for ftp settings and 186 for WDM. If i remove the 161 and 162 tags on the dhcp server, the S10 units can’t grab the wnos.ini file. The 161 tag is pointing to the correct server and 162 to the correct directory. I also unticked the ftp tickbox on WDM to see if that would help but no result. If there is a bug, i might just reinstall WDM, post the results and hopefully it works.

    Thank for the help

    #11674
    Avatardshaun
    Member
    • Total Post: 59
    • Back Stage Pass
    • ★★★★

    hey guys
    Unfortunately no result i get the same result in the ftp logs

    00:24:50 10.1.21.81 [1050]sent /Rapportserver=[ip address of WDM Server]/wnos/RCA_wnos 550 3

    Any ideas what the problem is or whether i can get the RCA_wnos file to be picked up by S10 units in the same location as the wnos.ini file???

    Thanks

    #11675
    Avatardshaun
    Member
    • Total Post: 59
    • Back Stage Pass
    • ★★★★

    oh and ignore the other post on the other thread, accidentally posted it there

    #11677
    Avatardshaun
    Member
    • Total Post: 59
    • Back Stage Pass
    • ★★★★

    i got it to work, or more like the WYSE Tech support did. Too many dhcp tags apparently were confusing the unit.

    Seems all well now

    Thanks for the help guys

    #11678
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Hi,

    OK this is the issue I have seen as well, its a problem in the 5.3.x WTOS code not WDM.

    Contact Wyse and get the latest 5.3.20 code as this fixes the issue (I may be able to PM this to you).

    Now you still need to upgrade, remove the 186 tag and G-Key the units. This will force the unit to read the location correctly from the 161/162 tag. After they upgrade place the 186 tag back or put the line RapportServer= in the wnos.ini file.

    If the G-Key is not an option the bug is that it pulls the wnos.ini from the WDM server (186 tag) and the firmware from the 161/162 location so point these to the same WDM server path and that will allow the upgrade to happen,

    Cheers,
    -TT

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.