WT1200LE and network printer

  • This topic is empty.
Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #126
    AvatarAnonymous
    Member
    • Total Post: 162
    • Jacked into The Matrix
    • ★★★★★★

    Hi,

    I try to connect a network printer to my WT1200LE terminal. I’ve filled in the settings on Printer Setup, Netbios, SMB 1 -> \10.0.0.205HP8000 (is the server and the sharename of that printer), printer driver = HP Laserjet 8000 Series PCL. I got always the messagebox “invalid credentials”. I tried several users (even the administrator), but the credentials are always not valid. What do I wrong ? How can I configure the printers ? Is it normal that the printersettings are disappeared when I restart the terminal ?

    Thank you for your help.

    Inge

    #8657
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Hi,

    Make sure you have the latest firmware as early Blazer 5x code only allowed you to connect to printers with guest access (email Wyse support). Also the best way to set this up is via the wnos.ini file. You can set up the printer with an accout the authenticate with via this file, see the blazer downloads sertion of this site for examples and the settings reference,

    -TT

    PS wnos.ini example (each entry on one whole line):

    PrintCredentials=yes Username=user1 Password=password Domain=mydomain

    Printer=SMB1 Host=demanica Name=CanonMP7 PrinterID=”Canon MP780 Series Printer” enabled=yes

    Printer=LPT1 Name=”HP Laserjet 4″ PrinterID=”HP Laserjet 4 enabled=yes

    DefaultPrinter=SMB1

    #8659
    AvatarInge
    Member
    • Total Post: 3
    • Newbie

    Thanks for your help.

    I’ve created a wnos.ini file, but the terminal didn’t accept the printcredential part. So I thought the firmware was not good, and I download the one on the website. But now, the firmware is downgraded (I had 5.00 and now 4.4).

    How can I get my old firmware back ?

    Thanks.

    Inge

    #8660
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    You will need to contact Wyse technical support for the latest version, I will try and email you some extra details as you are a member.

    Also set the Autoload=2 in the wnos.ini to stop terminals downgrading to older versions,

    -TT

    #8661
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Hi,

    I have sent you an update via email – email me direct if you don’t get it,

    Cheers,
    -TT

    #8663
    AvatarInge
    Member
    • Total Post: 3
    • Newbie

    Hi,

    Thanks for all your help, but I haven’t still access to the printer. The messagebox “invalid credentials” is displayed when I select “test printer” at the printer settings.

    This is the line I added to wnos.ini
    PrintCredentials=yes Username=wyse Password=wyseterm

    where the username is a local user in the printserver.
    Is the password encrypted ?

    This is the wnos.ini file :

    signon=0
    Autoload=2

    #Set correct language
    language=fr

    DefaultPrinter=SMB1

    Printer=SMB1 Host=10.0.0.205 NAME=HP8000 PrinterID=”HP Laserjet 8000 Series PCL” enabled=yes
    PrintCredentials=yes Username=wyse Password=wyseterm

    I have no username.ini files.

    What’s wrong with this ?

    Thanks.

    Inge

    #8664
    AvatarInge
    Member
    • Total Post: 3
    • Newbie

    Hi,

    Problem is solved !

    The wins and DNS server was wrong.

    I’ve changed it and it is OK.

    Thanks for your great help !

    Regards,
    Inge

    #9927
    Avatardudely
    Member
    • Total Post: 2
    • Newbie

    can you provide a little more detail as to what the fix actually was? I am experiencing the same issue, however just a bit different results. When attempting to print from teh Virtual machine, the Blazer OS immediately pops up and says “invalid credentials”. Using domain account, the login credentials are validated and the print job is succesful. However, every time you attempt to print, it does the same thing. It’s rather annoying. DNS and Wins entries in the blazer OS are correct for the network, so I don’t think that’s my problem, unless I’m missing something.

    Thanks,
    Dudely

    #9931
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Hi Dudely,

    In the wnos.ini if you are using SMB you will need to specify the credentials to authenticate to use the printer.

    Now obviously you don’t want to put the user details in a file but create an account that only has rights to print to the windows print share. Test this on a PC and if it works set it up in the file like this.

    PrintCredentials=yes Username=wyse Password=wyseterm

    This will be a low privilege account with rights on the domain, maybe use a local account on the print server. If you don’t like this setup just use LPR as the print server (add the Unix Print support on Windows server)

    Cheers,
    -TT

    #9932
    Avatardudely
    Member
    • Total Post: 2
    • Newbie

    Say however that I’m not using WNOS… just booting and connecting to RDP session. Is it possible to force Blazer to hold that setting/s?

    ‘Cause I’m not using WNOS 😀

    I will try your suggestion and see how it goes.

    Thanks!

    #9933
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Hi,

    No, you will need the wnos.ini to do this – besides you know you want to 😉

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.