MQTT Not Working on new server

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #105154
    AvatarKyle079
    Participant
    • Total Post: 19
    • Regular Joe
    • ★★

    Recently spun up a new WMS server in Azure. We are running WMS 3.2. We spun this up as most of our staff is now working remote and we did not want to open our internal WMS server on 443 to the outside. Wyse terminals are checking in and able to access the server on 443 for pulling config, but they are not getting any updates from MQTT. I have verified I can connect to 1883 on the WMS server from inside and outside our network (See Below).  Also verified the address is correct within MongoDB. What am I missing here?

     

    From WMS Server:

    PS C:\windows\system32> get-nettcpconnection –LocalPort 1883

    LocalAddress LocalPort RemoteAddress RemotePort State AppliedSetting
    ———— ——— ————- ———- —– ————–
    ******.3.4 1883 *********.190 64210 Established Internet
    ******.3.4 1883 *********.190 58405 Established Internet
    ******.3.4 1883 *********.190 57104 Established Internet
    ******.3.4 1883 **********.240 50430 Established Datacenter
    ******.3.4 1883 *********.190 17246 Established Internet
    0.0.0.0 1883 0.0.0.0 0 Listen

    PS C:\windows\system32> cd “C:\Program Files\DELL\WMS\MongoDB\bin”
    PS C:\Program Files\DELL\WMS\MongoDB\bin> mongo localhost -username stratus -p –authenticationDatabase admin
    MongoDB shell version v4.2.12
    Enter password:
    connecting to: mongodb://127.0.0.1:27017/localhost?authSource=admin&compressors=disabled&gssapiServiceName=mongodb
    Implicit session: session { “id” : UUID(“69f95f2b-1601-412f-be5f-07cfdc5b93bf”) }
    MongoDB server version: 4.2.12
    > use stratus
    switched to db stratus
    > db.getCollection(‘bootstrapProperties’).find({‘name’: ‘stratusapp.server.url’})
    { “_id” : ObjectId(“6047df1174ef2e993a02b94f”), “name” : “stratusapp.server.url”, “value” : “https://wms.*********.com
    :443/ccm-web”, “isActive” : true, “committed” : true }
    > db.getCollection(‘bootstrapProperties’).find({‘name’: ‘stratusapp.server.url’})
    { “_id” : ObjectId(“6047df1174ef2e993a02b94f”), “name” : “stratusapp.server.url”, “value” : “https://wms.*********.com:443/ccm-web”, “isActive” : true, “committed” : true
    > db.getCollection(‘bootstrapProperties’).find({‘name’: ‘mqtt.server.url’})
    { “_id” : ObjectId(“58f043979645e71756d468fb”), “name” : “mqtt.server.url”, “value” : “tcp://wms.*********.com:1883”, “isActive” : “true”, “committed” : “true” }
    > db.getCollection(‘bootstrapProperties’).find({‘name’: ‘stratus.external.mqtt.url’})
    { “_id” : ObjectId(“6047df1174ef2e993a02b951”), “name” : “stratus.external.mqtt.url”, “value” : “tcp://wms.*********.com:1883”, “isActive” : “true”, “committed” : “true” }

    From Remote Computer:

    PS C:\Windows\system32> Test-NetConnection -ComputerName wms.*******.com -Port 1883 -InformationLevel Detailed
    ComputerName : wms.*******.com
    RemoteAddress : ******.240
    RemotePort : 1883
    NameResolutionResults : ******.240
    MatchingIPsecRules :
    NetworkIsolationContext : Internet
    InterfaceAlias : Ethernet 5
    SourceAddress : ******.141
    NetRoute (NextHop) : *******.1
    TcpTestSucceeded : True

     

    #105157
    AvatarKyle079
    Participant
    • Total Post: 19
    • Regular Joe
    • ★★

    Meant to type MQTT, had typed Wyse too many times today.  🙂

    #105168
    ConfGenConfGen
    Keymaster
    • Total Post: 11270
    • Jedi Master
    • ★★★★★★★

    Looks good to me. No idea.
    Another question, why don’t you use WMS Pro. It already has a Cloud instance.

    CG

    #105195
    AvatarKyle079
    Participant
    • Total Post: 19
    • Regular Joe
    • ★★

    Simply cost. Azure instance is $850 a year. WMS Pro would be $13000 a year.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.