wnos.ini file

  • This topic is empty.
Viewing 15 posts - 1 through 15 (of 21 total)
  • Author
    Posts
  • #1399
    Glen
    Member
    • Total Post: 26
    • Regular Joe
    • ★★

    Can anyon help with a wnos.ini file for S10?
    I am trying to get the S10 to log into our citrix farm and go to a published desktop without the user having to choose the application.
    I need a login screen that takes the users domain credentials and passes them through to the published desktop.
    So if I get a disconnection it will go back to that particular session without going to a different server.

    #13657
    ConfGen
    Keymaster
    • Total Post: 11428
    • Jedi Master
    • ★★★★★★★

    Hi Glen,

    put the following lines in the wnos.ini file:

    SignOn=Yes

    PnliteServer=yourPNserver ReconnectAtLogon=2 ReconnectFromButton=2 AutoConnectList=”pubDesktop”

    BTW, these are only 2 lines. Signon is #1 and Pnlite….Deskop” is #2

    Cheers
    CG

    #13668
    Glen
    Member
    • Total Post: 26
    • Regular Joe
    • ★★

    Thanks for the help!
    It works great
    I have Blazer V6.2.0_01 and I want it to map USB drives (memory sticks)!
    I have a paramaters document that I am working through but it is for version 6.1.
    To Map and assign the Z drive to USB sticks it suggests what I have below.

    Mapdisks=yes
    Mapdisksunderz=yes

    This does not work though
    It is saying in the Event Log

    Invalid Statment: Mapdisks=yes
    Invalid Statement: Mapdisksunderz=yes

    We have Blazer V6.2.0_01

    Glen

    #13671
    ConfGen
    Keymaster
    • Total Post: 11428
    • Jedi Master
    • ★★★★★★★

    Hi Glen,

    first of all you should contact Wyse to get an upgrade to 6.2.08 which is the current release version.
    Then post your wnos.ini here and we will have a look what’s wrong.

    CG

    #13682
    Glen
    Member
    • Total Post: 26
    • Regular Joe
    • ★★

    Hi CG
    I have 6.2.11 and the problem I have now is that the memory stick has to be plugged in before the user logs on the workstation.
    If the user logs without it pluged in it will not map.
    Is it possible for it to work if the stick is plugged in after logon.
    My wnos.ini file is below
    Thanks for your help Glen

    SessionConfig=ALL MapDisks=yes
    SignOn=Yes
    AutoSignoff=yes
    privilege=none Lockdown=yes HidePPP=yes HidePN=yes HideSysInfo=no
    PnliteServer=192.168.15.130 ReconnectAtLogon=2 ReconnectFromButton=2 AutoConnectList=”Student Desktop”
    DomainList=tcc
    Resolution=1024X768
    NoticeFile=copyrt.txt
    #Set a logo up in the login box
    FormURL=TC_logo.gif
    #Set school crest as Screen Saver
    ScreenSaver=1 SoftSaver=no LockTerminal=no Type=3 Image=scrsvr.gif

    #13684
    ConfGen
    Keymaster
    • Total Post: 11428
    • Jedi Master
    • ★★★★★★★

    The described behaviour is a standard one within Citrix environment.
    To overcome this you have to map all disk under one letter. This way WTOS fools the ICA session that there is one drive although maybe not attached. All drives that are beeing attached while already connected will be mapped as folders beneath Z:
    Here is the wnos.ini parameter:

    SessionConfig=ICA MapDisksUnderZ=yes

    HTH
    CG

    #13731
    Glen
    Member
    • Total Post: 26
    • Regular Joe
    • ★★

    Thanks again CG
    I tried that without success!
    I changed that line as you stated From

    SessionConfig=ALL MapDisks=yes
    to
    SessionConfig=ICA MapDisksUnderZ=yes

    and nothing mapped at all.
    The only way it works at all is the first entry. But we then have the original issue of not being able to plug in the Memory stick after logon.

    #13733
    ConfGen
    Keymaster
    • Total Post: 11428
    • Jedi Master
    • ★★★★★★★

    Do not change the line but add mine to yours instead.
    Best would be for you to use my ConfGen tool to generate the correct syntax.

    ;*************************************************************
    ;* General Session *
    ;*************************************************************

    SessionConfig=ALL MapDisks=yes

    ;*************************************************************
    ;* ICA *
    ;*************************************************************

    SessionConfig=ICA MapDisksUnderZ=yes

    Regards
    CG

    #13777
    Glen
    Member
    • Total Post: 26
    • Regular Joe
    • ★★

    I did use the config Gen but I must not have had it correct as it made the file as I originally stated.
    Thanks for your help is all doing exactly what I need it to do now.

    #13778
    ConfGen
    Keymaster
    • Total Post: 11428
    • Jedi Master
    • ★★★★★★★

    Glad I could help.

    CG

    #13803
    Glen
    Member
    • Total Post: 26
    • Regular Joe
    • ★★

    Hi again
    I have some Wyse 1125SE terminals that I would like to work in a simalar way as the S10.

    The OS version is 4.4.509f.
    They don’t seem to follow all the commands in the wnos.ini file (it doe’s do some)
    My wnos.ini file that works great with my S10 units is below:

    # Map local disks in session
    SessionConfig=ALL MapDisks=yes

    #Add TCX Licensing
    #TCXlicense=XXXXX-XXXXX-XXXXX-XXXXX-XXXXX

    #Sign in parameters
    SignOn=Yes
    AutoSignoff=yes

    #Set user privledges
    privilege=none Lockdown=yes HidePPP=yes HidePN=yes HideSysInfo=yes

    #Set ICA Session
    PnliteServer=192.168.15.130 ReconnectAtLogon=2 ReconnectFromButton=2 AutoConnectList=”Student Desktop”

    #Set Domain in logon box
    DisableDomain=yes
    DomainList=tcc

    #Set Screen resolution
    Resolution=800X600

    #Set Notice prior to logon
    #NoticeFile=copyrt.txt

    #Set a logo up in the login box
    FormURL=TC_logo.gif

    #Set school crest as Screen Saver
    ScreenSaver=1 SoftSaver=no LockTerminal=no Type=3 Image=scrsvr.gif

    I can use a seperate wnos.ini file, but can I get this os to behave like my S10 units does with the connections.
    The most important line is below!
    #Set ICA Session
    PnliteServer=192.168.15.130 ReconnectAtLogon=2 ReconnectFromButton=2 AutoConnectList=”Student Desktop”

    #13806
    ConfGen
    Keymaster
    • Total Post: 11428
    • Jedi Master
    • ★★★★★★★

    The firmware you are using is to old. Starting with 5.2 you have USB support. 5.2, which is also the latest available for 1200 and 1125, has also the Reconnect and AutoConnectList parameter.
    Contact Wyse to buy an upgrade if you do not have maintenance.
    It (upgrade and maintenance) is cheap and really worth the money.

    CG

    #13808
    Glen
    Member
    • Total Post: 26
    • Regular Joe
    • ★★

    I have contacted Wyse and they indicate that the firmware is the latest available for the 1125SE!
    Do you believe that is correct?
    Or is there a version 5.2 firmware for the 1125

    #13810
    thinkthin
    Member
    • Total Post: 1686
    • Jacked into The Matrix
    • ★★★★★★

    No, as ConfGen stated 5.2x is the most recent code for the 1125 however you will need to buy the upgrade,

    Cheers,
    -TT

    #13813
    ConfGen
    Keymaster
    • Total Post: 11428
    • Jedi Master
    • ★★★★★★★

    I have just checked with some friends at Wyse. 5.2.062 is the latest code for 1125, 1200 and 1200+.

    CG

Viewing 15 posts - 1 through 15 (of 21 total)
  • You must be logged in to reply to this topic.