wlx.ini update

  • This topic is empty.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #5929
    Massoger
    Member
    • Total Post: 4
    • Newbie

    I’ve been struggling trying to get a demo R50L to pull the wlx.ini file from the ftp server.

    I did an upgrade to the new firmware to build 11.0.112, SUSE version 11.

    I tried both manual configuration of the ftp settings and the dhcp config and neither version seem to be able to pull the ini file from the server.

    I can open Firefox and browse to the ftp server and actually open the ini file, so I know it’s not a permission issue, or a networking issue.

    My last resort is to downgrade to the previous version of the firmware (if even possible) and test it again.

    Any suggestions before I go that route?

    I’ve been working with a WYSE sales engineer as well and we haven’t been able to resolve it.

    Thanks for your help!

    #18440
    ConfGen
    Keymaster
    • Total Post: 11410
    • Jedi Master
    • ★★★★★★★

    Let us know the exact path where the wlx.ini is saved and the exact value you have entered on the client in the Fileserver field. And also which user you are using for FTP connect.

    CG

    #18449
    Massoger
    Member
    • Total Post: 4
    • Newbie

    The original config was this….using IIS FTP with default config settings.

    The path of the wlx.ini file is C:InetpubftprootWyseWLXwlx.ini

    On the client the path is ftp://xx.xx.xx.xx/Wyse/WLX/

    After playing around with the client path and using wireshark to packet trace I changed the client path to ftp://xx.xx.xx.xx/Wyse/ and it started working.

    BUT I also put the wlx.ini file in both the C:InetpubftprootWyse folder AND the C:InetpubftprootWyseWLX so I’m not sure which ini file it is actually reading from. Any ideas??

    I am logging into the R50L using the admin and I’m logged into the FTP server as the admin.

    Thanks again!
    Dave

    #18452
    ConfGen
    Keymaster
    • Total Post: 11410
    • Jedi Master
    • ★★★★★★★

    The path on the FTP server where the wlx.ini lies should be ftprootwysewlxwlx.ini.
    In this case the client path has to be xx.xx.xx.xx/Wyse
    This means that the Linux devices always add the folder /wlx to the given FTP path. This behaviour is hardcoded.
    If your wlx.ini lies in ftproot/mycompany/mylocation/mydepartment/wlx/ then the path on the client has to be the same except the /wlx.

    BTW, to make it even moe confusing. If the folder /wlx is not present or there is not wlx.ini in the wlx folder, then the Linux units also look for the folder /wnos instead of /wlx and a wnos.ini. This is done to get compatible to WTOS devices.

    CG

    #18465
    Massoger
    Member
    • Total Post: 4
    • Newbie

    😀 Thank you! The fact that linux appends /wlx automatically makes it all make more sense!

    Thanks for the help, it’s updating via ftp now!

    Dave

    #18468
    ConfGen
    Keymaster
    • Total Post: 11410
    • Jedi Master
    • ★★★★★★★

    Say greetings to the Wyse SE you have worked with 😉

    CG

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.