WDM doesn’t work when WTOS clients attempt to check in

  • This topic is empty.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #480
    AvatarDpizzle
    Member
    • Total Post: 19
    • Regular Joe
    • ★★

    Hello all I have a rather complicated problem that Wyse support has been less than helpful with.

    I am attempting to set up WDM 4.5.1 to act as our asset manager for our S10’s and V10L’s. I have installed WDM on a fresh install of W2k3 Standard Server around 5 times. I have also installed it on WIndows XP Pro. I have tried Virtual PC, Virtual Server, VMWare Server, and two physical computers. Each time the thinclients will report that they have completed a full check-in using

    PUT /hserver.dll?blah blah blah.

    For a while it just appeared that there was no response from the WDM software, so i installed a packet sniffer on the computer and started to watch the traffic from the thinclients and the WDM computer. I found that after a thinclient finishes its full check-in the WDM server responds with a “http1.1 400 bad request” Which is totally useless interms of troubleshooting.

    I checked the logs for IIS and found that these strings were winding up in the error logs and not the “sucessful transaction log” When i copy & pasted the EXACT string that the thinclient was using into IE or FireFox the WDM software recognized it as the thinclient that sent the checkin string.

    Does anyone have any idea what I could be doing wrong? What settings that I might be missing, or just that the WDM software doesn’t like me.

    #9774
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Hi,

    To be clear for me, your S10’s will not appear in the console of your new WDM server even after you enter the IP of it on the terminals?

    Cheers,
    -TT

    #9777
    AvatarDpizzle
    Member
    • Total Post: 19
    • Regular Joe
    • ★★

    I finally figured out the problem after 5 weeks of headaches. Our network is an administrative network and as such we have two DNS domain suffixes provided by DHCP. When the WTOS attempts to check into the WDM server it sends a URL with a space in it, and it doesn’t know to insert a %20 to remedy the problem. Once i discovered that it was including a space as opposed to listing them separately I was able to remove the second suffix and everything started working right away.

    #9778
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Nice work!!!

    Zero chance of figuring that one out in the forum, glad its all go now. Thanks for posting back the issue,

    Cheers,
    -TT

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.