WDM and TFTP issue

  • This topic is empty.
Viewing 15 posts - 1 through 15 (of 18 total)
  • Author
    Posts
  • #1025
    AvatarFritzsCorner
    Member
    • Total Post: 14
    • Regular Joe
    • ★★

    Hello,

    I am trying to troubleshoot an issue I am having trying to pull or push any soft of image to V50L Wyse devices. I am running WDM 4.5.3 on Server 2003 SP2 and on the surface everything seems to work fine. I can discover the devices.. I can boot them to the PXE server it can open a TFTP connection etc.. The problem I am having is that every time I try and push or pull an image the device will reboot, contact the PXE server, open the TFTP connection, search and find the interface, etc. but then I get the message “Launch Attempt [mac address] and it repeats about 15 times and then I get a message unable to open file and it reboots and repeats the same process. It is booting to the correct PXE server and I don’t have any other PXE servers on this network. I have the proper IP helpers in place and I was able to get things setup and tested back in December and it all worked.

    What has changed since this time is the server build has gone from SP1 to SP2, added a few hotfixes and that is about it. They are managed by group policy and according to the team that manages the servers they haven’t changed the policy’s between the build. I have also been able to get it running and working fine on my own VMware lab environment without issues. In my talks with the Wyse support tech we both feel there has to be something in our server build or group policy that is breaking this functionality but I have so far been unable to find it.

    Does anyone here have any experience with a similar issue or suggestions on where I should start looking? I have gone between or server team and Wyse and both are pointing their fingers at each other and I don’t seem to be getting anywhere.

    I appreciate any help or suggestions!

    Thanks

    #12168
    ConfGenConfGen
    Keymaster
    • Total Post: 11009
    • Jedi Master
    • ★★★★★★★

    Copy the folder toolssa from the install folder of WDM to ftprootrapport.
    Looks like there are some files missing.

    CG

    #12170
    AvatarFritzsCorner
    Member
    • Total Post: 14
    • Regular Joe
    • ★★

    Thank you for the response. The Wyse support tech had me do this as well but I am still having the same problem. I am certain there is something wacky in our server build that is breaking it but for the life of me I can’t find it.

    #12171
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Hi,

    In the master software repository do you have this defined as an IP or the FQDN of the WDM server?

    Cheers,
    -TT

    #12182
    AvatarFritzsCorner
    Member
    • Total Post: 14
    • Regular Joe
    • ★★

    Thanks for the response. It was defined as an IP. I tried the FQDN and it will still connect to PXE server and open the TFTP connection but still fails with the Launch Attempt message. I was able to schedule some time with one of our server guys to take a closer look and see what he can find.

    Thanks again guys!

    #12184
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    NP, it must be and IP address as FQDN are not supported.

    Lets us know if you find anything more on the issue,

    Cheers,
    -TT

    #12286
    AvatarFritzsCorner
    Member
    • Total Post: 14
    • Regular Joe
    • ★★

    Well we finally got things working.

    We applied the default permissions and user right assignments policies for IIS, and made the changes below.

    1. Removed IUSR from the Guests Group
    2. Added IUSR to the Users Group
    3. Gave the Rapport user Read + Execute permissions to the C:Program FilesWyseWDMTFTPRoot Directory
    4. Set DEP to turn on for essential windows programs and services only.

    I am going through some validation steps right now and backing out of each change 1 by 1 until it breaks again to make sure each configuration was required.

    Thanks for all the help.

    Aaron

    #12329
    Avatarjohn2kvtr
    Member
    • Total Post: 2
    • Newbie

    Aaron,

    I’m having the same difficulty. In step 4 from above you mention “DEP”. What is that, where did you make the change?

    TIA.

    John

    #12330
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Properties of “My Computer – Advanced – Performance Settings – Data Execution Prevention”

    Cheers,
    -TT

    #12388
    Avatarjohn2kvtr
    Member
    • Total Post: 2
    • Newbie

    Thanks for the response.

    We found that the Software Repository’s setting for MASTER was using the servername. We changed it to the servers IP address and that fixed it.

    #12391
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Great! Thanks for posting back the solution…

    #12700
    Avatarrland
    Member
    • Total Post: 16
    • Regular Joe
    • ★★

    I too am having this issue and I have done all of what has been suggested. I am just stuck in this neverending reboot. I boot to the PXE server and then get the message :
    “File open error for root.i2u…unable to continue” Rebooting in 30 seconds. I am not getting any help from Wyse tech support and they have told me to try the things that I have already found here in this forum. Any ideas? I am using WDM 4.5.3 and the PXE server is Windows Deployment Services. If anyone has any suggestions please let me know. Thanks.

    #12709
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Hi,

    WDM has its own TFTP service so shut down the Windows Deployment Service as it will conflict with the WDM service. If the Windows Deployment Service is on a different server an is used for PC’s configure it only to respond to objects in AD,

    Cheers,
    -TT

    #12715
    Avatarrland
    Member
    • Total Post: 16
    • Regular Joe
    • ★★

    I have disabled the TFTP service for Windows Deployment Services but i get the the prompt and it finds the PXE server but just says TFTP……… and times out. I am not sure what I need to do from there. Thanks in advance!

    Ryan

    #12716
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Hi,

    Are you sure there is no other conflicting tftp servers on the network? Also are there any DHCP option tags in use like Options 66, 67 or 43? These will point the client to the incorrect location.

    Also check the options in WDM to make sure PXE/TFTP in enabled. When the client boots and starts the PXE process you should see the message about the “boot server”, this should be the IP of the WDM server.

    Once we are sure the Wyse client is attempting to boot from the WDM server we can then check to see why the TFTP service on the WDM server is not responding or working.

    From your post I have assumed you have re-copied the files manually in to the tools folder,

    Cheers,
    -TT

Viewing 15 posts - 1 through 15 (of 18 total)
  • You must be logged in to reply to this topic.