VNC access on R50L running sletc 11

  • This topic is empty.
Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #6121
    AvatarLavarius
    Participant
    • Total Post: 57
    • Back Stage Pass
    • ★★★★

    We’ve been running Sletc 10 fine, but now we are looking to pilot some 11 stations. We want to be able to vnc into these machines when need be. But the ini files don’t seem to be enabling the vnc server. I’ve even re-imaged and used the configuration generator. I’m able to activate it manually in the Remote Desktop area, so i don’t think it’s a problem with not having a package installed. Any insights would be very appreciated.

    #18936
    ConfGenConfGen
    Keymaster
    • Total Post: 9912
    • Jedi Master
    • ★★★★★★★

    Please post your wlx.ini.

    Thanks
    CG

    #18943
    AvatarLavarius
    Participant
    • Total Post: 57
    • Back Stage Pass
    • ★★★★

    This is our production one for our SLETC 10 devices:

    Fileserver=ftp://xx.xx.xx.xxx
    Rootpath=/rootpath
    EnableLocal=yes
    EnableGKey=yes
    Update.Mode=Addons
    Update.Preserve_changes=no
    Privilege=Low Lockdown=yes
    NewAddons=gcalctool,cleanup,java-1_4_2-sun
    RemoveAddons=wine,cabextract,ies4linux,java
    ;Autopower=yes
    ;Bootorder=UHN
    Desktop=

    ;*************************************************************
    ;* General 3 *
    ;*************************************************************

    TCXLicenseKeys=xxxxx-xxxxx-xxxxx-xxxxx-xxxxx
    TCXUSBVirtualize=yes

    ;*************************************************************
    ;* Display *
    ;*************************************************************

    Resolution=1280×1024

    ;*************************************************************
    ;* Time *
    ;*************************************************************

    Timeserver=timeserver.com
    Timeformat=”12-hour format”
    TimeZone=”America/New_York” ManualOverride=1

    ;*************************************************************
    ;* Network *
    ;*************************************************************

    PermitSSHRootLogin=yes
    SignOn=Yes
    DefaultUser=thinuser
    Autologin=yes Countdown=1
    ChangeAdminPassword=*******
    ChangeRootPassword=*******
    ChangeThinUserPassword=*******
    DisableDomain=yes
    VncPasswd=password
    UsePasswd=1

    I’ve also used this one more recently one just the SLETC 11 pilot box.

    Fileserver=ftp://xx.xx.xxx.xxx
    Rootpath=/rootpath
    Update.Mode=Addons
    PowerButtonAction=interactive
    Update.Preserve_changes=yes
    Privilege=Low Lockdown=yes
    Bootorder=UHN

    ;*************************************************************
    ;* General 2 *
    ;*************************************************************

    MouseSpeed=1

    ;*************************************************************
    ;* Time *
    ;*************************************************************

    Timeserver=timeserver.com
    Timeformat=”12-hour format”
    TimeZone=”America/New_York” ManualOverride=1

    ;*************************************************************
    ;* Network *
    ;*************************************************************

    EthernetSpeed=Auto
    Autologin=Yes
    DefaultUser=thinuser
    ChangeAdminPassword=*******
    ChangeThinUserPassword=*******
    ; If you are using an older version of SUSE code please use:
    ; VncPasswd=clear_text Password

    VncPasswd=**hashed password**
    ; If you are using an older version of SUSE code please use:
    ; UsePasswd=yes

    VNCAuthTypes=vnc

    #18947
    ConfGenConfGen
    Keymaster
    • Total Post: 9912
    • Jedi Master
    • ★★★★★★★

    Can you try to add

    DisableVNC=no

    to your SELTC11 wlx.ini?

    CG

    #18949
    AvatarLavarius
    Participant
    • Total Post: 57
    • Back Stage Pass
    • ★★★★

    that should be default.

    #18950
    ConfGenConfGen
    Keymaster
    • Total Post: 9912
    • Jedi Master
    • ★★★★★★★

    Yes, but in the latest build it isn’t.
    RemoteDesktop is no longer started by default and this prevents VND from working.
    DisableVNC=no activates this.

    CG

    #18952
    AvatarLavarius
    Participant
    • Total Post: 57
    • Back Stage Pass
    • ★★★★

    is there more recent documentation the the “UTF-8’en-us’Wyse_Enhanced_SLE_INI Ref_Guide_APR2010”

    Because that says it’s no by default, and it’s all i’ve been able to find on ini files.

    #18953
    ConfGenConfGen
    Keymaster
    • Total Post: 9912
    • Jedi Master
    • ★★★★★★★

    No it isn’t at this point of time.
    I was not 100% correct in the last post. DisableVNC=no is still the default but as RemoteDesktop is not enabled by default you have to set this in your wlx.ini to make it work.

    CG

    #18956
    AvatarLavarius
    Participant
    • Total Post: 57
    • Back Stage Pass
    • ★★★★

    Thanks for that by the way, it did work. that was not very clear because of the way it was written in the documentation. And i thought i had already tried it.

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.