v90le turns off write filter to update – No WDM!

  • This topic is empty.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #1896
    Avatarrcarmack
    Member
    • Total Post: 16
    • Regular Joe
    • ★★

    We are apparently getting requests to update our thin clients, yet we have no WDM server on our network. What is causing these to update? The IP address of the WDM is 172.18.x.x, which is a private IP not located inside of our network. Is there any way I can disable updates being sent to these thin clients?

    #15214
    ConfGenConfGen
    Keymaster
    • Total Post: 11116
    • Jedi Master
    • ★★★★★★★

    I don’t think anybody is really sending a package to your clients but the clients found the WDM server and this is causing the update.
    Enter the WDM’s IP in the client image and all should be good.

    CG

    #15216
    Avatarrcarmack
    Member
    • Total Post: 16
    • Regular Joe
    • ★★

    We do not have any type of WDM on our network. The IP address is a private IP, but not the private range that we use in our network. We use 192.168.x.x, the WDM it picked up is a 172.16.x.x.

    #15219
    ConfGenConfGen
    Keymaster
    • Total Post: 11116
    • Jedi Master
    • ★★★★★★★

    OK, looks like I misunderstood you.
    To sumarize:
    – you have Xpe client in a 192.168.x.y. subnet
    – these clients get some update packages from a WDM server with 172.16.x.y. IP
    Correct?
    Does your network has a route to a 172.16. subnet?
    Looks like someone has installed a WDM server in your network, maybe for testing and either wants to fool you or just forgot about it.

    Two things I would do:
    – Try to find this WDM server
    – Install my own WDM server and let the clients check-in to my WDM server. This way they will no longer communicate with the other one. At least if this other WDM server was just forgotten.

    The thing is, that all XPe client that do not have a WDM server preconfigured try to find a WDM server by sending out continously DHCP broadcasts. As WDM act as a DHCP proxy it will “hear” this broadcast and answer the client with its own IP. This IP will then be saved on the client which could be seen by the “Update” announcement.

    CG

    #15223
    Avatarrcarmack
    Member
    • Total Post: 16
    • Regular Joe
    • ★★

    That is correct. We do not have any routes to a 172.16.x.y subnet.
    I am going to set up a WDM server here to try to get the clients to pick me up. Will they be able to now that they have found an IP address of another WDM server? Thanks for your reply, it helps me understand what is going on here.

    #15226
    ConfGenConfGen
    Keymaster
    • Total Post: 11116
    • Jedi Master
    • ★★★★★★★

    It depends on the HAgent (WDM agent) running on XPe. Latest ones accept the IP address via DHCP option tag. Older ones don’t.
    If there is one IP entered in Control Panel – WDM then the client will no longer search for a WDM server. You will have to manually enter the IP in these clients.

    CG

    #15732
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    This was posted by Amerist but deleted – I am re-posting it….

    I just wanted to add my 2 cents. I have had this same issue where there is no WDM on the network anymore (there used to be but we removed it) and yet the HAgent on the XPE winterms would sometimes detect a check-in request on the network even though there’s no WDM at that IP any more.

    What we determined is that since the WDM server had been removed its IP address was added back into the DHCP pool and occasionally a computer was picking up this IP address and for whatever reason it was producing the same kind of broadcast that WDM would produce and cause devices to do the checkin routine where they disable their write filter and reboot.

    What we ended up doing was excluding that IP from the DHCP pool so no other machine can take that IP unless it was configured staticly. Also on every XPE winterm that we deploy we disable the HAgent. Since doing this we haven’t seen this “phantom WDM check-in” phenomenon.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.