v90: Simple RSP

  • This topic is empty.
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #1139
    AvatarJoe
    Member
    • Total Post: 104
    • Legend in Own LunchBox
    • ★★★★★

    I’m having problems writing an RSP script for my v90. All I want to do is configure a proxy server.

    I did the following:

    1. Created a text file called myProxy.rsp. Inside the text file I put the following code:


    [Version]
    Number=myProxy
    Description=Configure proxy on v90 devices
    OS=XP
    Category=XPe Tools

    [Script]
    CO "XP"
    QU
    LU YES
    MR "Proxy.reg" "user"

    EL

    I created a directory called myProxy. Inside myProxy I created a file named proxy.reg with the following contents:


    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USERSoftwareMicrosoftWindowsCurrentVersionInternet Settings]
    "ProxyServer"="myproxy.mycompany.com"

    I import the file into WDM (v4.5.1). It imports successfully. I locate the package and drag/drop it onto my view with my v90 and schedule the job.

    The thin client prompts to update, and I accept it. I’ve mapped a drive to the thin client from another computer so I can watch it copy files and I see it create a file called tempreg.reg. After it does that the job fails with this message:

    Try 1:FTP Failed:-1 FTP In MergeReg Failed Line#: 11 Cmd:MR “myProxyProxy.reg” “user”

    The write filter is disabled while I’m trying this. I’ve tried it logged in as Administrator as well as user, neither seem to work and both yield the same results — the error above.

    I’ve also duplicated this with the DST patch downloaded directly from WYSE.com. Is there something I’m overlooking?

    I don’t see many scripts using “LU YES”, but it’s supposed to lock the unit and remove the splash screen if it fails. That doesn’t actually work either. It leaves the tempreg.reg file and the splash screen. I’ve tried LU as well as LU* and I get the same results.

    help? I have a nice dent in my desk that matches my face and I don’t know how much more I can take! 🙂

    #12704
    Avatarthinkthin
    Member
    • Total Post: 1686
    • Jacked into The Matrix
    • ★★★★★★

    Hi,

    All looks good although I don’t think there is a space in the user section:

    MR “Proxy.reg””user”

    Strange question but there is a file in C:inetpubftprootrapportmyProxy called Proxy.reg?

    #12713
    AvatarNeo
    Member
    • Total Post: 8
    • Newbie

    If you are logged into the local terminal as the User when you push this file you should not need the added “user” switch at the end of your merge line, I don’t think. At that point the User account is also the Current_User in the registry and it should merge straight up with no other direction.

    #12718
    Avatarthinkthin
    Member
    • Total Post: 1686
    • Jacked into The Matrix
    • ★★★★★★

    Hi Neo,

    Hmm, you have got me thinking now! From memory the Hagent runs as system so the merge reg command runs in the “system” user context. Because of this user setting need to have the correct hive loaded to merge or they end up in the “system” registry hive.

    Not an issue for HKLM commands as they are shared, just HKCU is the issue.

    But to be honest, now you mention it I would have to check again! I don’t have access to a terminal now, do you mind checking it out and posting back?

    Thanks Neo!
    -TT

    #12721
    AvatarJoe
    Member
    • Total Post: 104
    • Legend in Own LunchBox
    • ★★★★★

    @thinkthin wrote:

    Hi,

    All looks good although I don’t think there is a space in the user section:

    MR “Proxy.reg””user”

    I stripped the space out and it didn’t help. I’m getting this error.

    Try 1:FTP Failed:-1 FTP In MergeReg Failed Line#: 11 Cmd:MR “myProxyProxy.reg””user”

    This i just an observation, but if you look at the MR command, it’s not displaying , or what the value should be. Is that normal?

    Strange question but there is a file in C:inetpubftprootrapportmyProxy called Proxy.reg?

    I did verify that the Proxy.reg file exists. In fact, I can map a drive to the thin clients C: drive and watch it create the temporary file, tempreg.reg. At first I thought it might be because this file might exist from a previous failed attempt so I deleted it — but it still creates it. It appears to be an exact duplicate of the reg file that I’ve created right down to the file size. It’s there and getting copied over properly.

    But to be honest, now you mention it I would have to check again! I don’t have access to a terminal now, do you mind checking it out and posting back?

    The hagent runs as system (you can confirm by logging on as administrator and opening the system applet in the control panel and viwing the logon tab for the hagent service). Any changes to HKCU *should* be made to the system account profile at that point unless there is something intercepting the calls to write to HKCU and translating it, but I don’t believe there is anything doing that.

    I did give it a try without the “user” parameter on the MR command, and it still didn’t work. I get this error:

    Try 1:FTP Failed:-1 FTP In MergeReg Failed Line#: 11 Cmd:MR
    “myProxyProxy.reg”

    At this point, I think it’s something up with the hagent not liking the reg file. Creating a reg file isn’t rocket science, but it sure is giving me a headache! 🙂

    Just to rule out my image, I dumped a fresh image right from Wyse on it. I’m going to try updating the hagent and see if that makes a difference. I’ll update when I have more info!

    In the meantime —
    Are there any restrictions on the REG file? Do they need to be a certain text format for the Hagent to understand it properly? Line unicode or ascii?

    #12722
    AvatarJoe
    Member
    • Total Post: 104
    • Legend in Own LunchBox
    • ★★★★★

    I downloaded the 5.0.0.7 hagent from Wyse and imported it into WDM. I pushed the package to my v90 and I got the following error:

    Try 1:FTP Failed:-1 Line#: 31 Cmd:SF “XPe_HAgent_5007HAgent.ini” “C:Program FilesWDMHAgent.ini”

    I did a file compare on hagent.ini it was the same as what was in the WDM repository, so the files are getting copied properly. Is it possible that this isn’t the line causing the problem? Maybe I have some larger problem with WDM?

    #12723
    AvatarJoe
    Member
    • Total Post: 104
    • Legend in Own LunchBox
    • ★★★★★

    I manually installed the newest hagent. The job now completes successfully, but it doesn’t actually work. I tried it with all the incarnations of the MR command we discussed above.

    Any ideas?

    I’m probably going to give Wyse a call when I get back from vacation.

    Thanks for looking, and for all the help!

    #12731
    ConfGenConfGen
    Keymaster
    • Total Post: 11280
    • Jedi Master
    • ★★★★★★★

    Hi Joe,

    this script is working fine:

    [Version]
    Number=XPeDesktop
    Description=Change Desktop
    OS=XP
    Category=Other Packages
    USE_Pxe=NO

    [Script]
    CO "XP"
    SF "wyse.bmp" "c:windowswyse.bmp"
    MR "wa.reg" "user"
    RB

    with this wa.reg file:

    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USERControl PanelDesktop]
    "Wallpaper"="c:\Windows\wyse.bmp"

    Try removing a CRF at the end of your reg file or delete it already exist.
    I can also send you my package and see if this is worknig in your environment also.

    CG

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.