V50 will not connect to FTP server….

  • This topic is empty.
Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #408
    Avatarzofty
    Member
    • Total Post: 13
    • Regular Joe
    • ★★

    Hi,

    I’m having a fustrating time implementing 25 V50s across my enterprise.

    I have created a test DHCP, FTP Server environment on VMware to test my WLX.INI config file which is a copy of my WNOS.INI file I use for my blazer devices.
    All works fine no probs.

    BUT…

    When I connect the V50 to my production FTP server no FTP requests are broadcast from the V50 to my FTP server (I have captured data using Wireshark).

    Connect it back to my test FTP server – all works fine. (Wireshark captures requests!)

    161 & 162 option tags have been set.

    Any help or advice will be much appreciated. I’m tearing my hair out on this one.

    #9522
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Hi,

    Is it possable that the swich has not enabled the post yet on boot? Maybe set portfast on.

    Cheers,
    -TT

    #9523
    Avatarzofty
    Member
    • Total Post: 13
    • Regular Joe
    • ★★

    Thanks for the prompt reply thinkthin.

    I have suspected it maybe something on the switch. I passed on your comments to my network guy.

    He will switch portfast on for my port. The port is currently in STP blocking mode.
    So that may explain it.

    I have a question; We also have 1200LE & S10 devices- they work perfectly fine. Why is this? Do they ignore STP?

    I will post soon. Let the forum know how I got on.

    Zofty

    #9528
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Hi,

    Thats wierd that the S10 works in the same environment, post back how you got on,

    -TT

    #9540
    Avatarzofty
    Member
    • Total Post: 13
    • Regular Joe
    • ★★

    OK now all kinda works 😀

    Basically I have gone with static IP addressing.
    Wireshark now picks up FTP requests.

    NOTE: I could only set static address till the network cable was pulled out.

    Disabling STP/Fastport did work but it is a setting required for our Avaya voip phones. So its not recommended to disable.

    Running Wireshark showed that the V50 could not get an initial DHCP offer till they booted into the GUI and tried again.
    It looks like unless the initial DHCP address is gained, No FTP requests are sent.

    #9541
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Hi Zofty,

    Actually I would have recommended to enable PortFast anyway as it normally breaks the winterms for the same reason it breaks the phones.

    So your issue is that the Linux Winterms do not get a DHCP address on the production network???

    I would always recommend DHCP so this is very strange. Is there anything unusual in the DHCP scope for the phones that could be playing with the units? Also, try DHCP again but remove the 161 and 162 tags from the scope and manually configure the ftp server location – does the unit get a IP now?

    Maybe we are getting closer now,

    Cheers,
    -TT

    #9542
    Avatarzofty
    Member
    • Total Post: 13
    • Regular Joe
    • ★★

    Yep, No DHCP offered initially on the production network – tries again at GUI load.

    These are the option tags I have set:

    Option Name Vendor
    003 Router Standard
    161 FTPServer Standard
    162 FTPdirectory Standard
    176 Avaya Phone Standard
    006 DNS Servers Standard
    015 DNS Domain Name Standard
    044 WINS/NBNS Servers Standard
    046 WINS/NBT Node Type Standard
    135 Domain suffix search order Standard

    #9550
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Hi Zofty,

    The option tags look fine, just to point out that when the terminal boots it attempts a network boot and has the “Requesting DHCP” screen. This is normal and without a WDM server on the network it will not show an IP address.

    You can prevent this by changing the boot order in the BIOS or from the BootOrder= in the wlx.ini file.

    Once the device boots what does the system log say? Is there a “failed to retrieve system profile”? From what you say the device is still not getting the wlx.ini in the wlx folder. We need to see from the system log if it contacts the ftp server at all,

    Cheers,
    -TT

    #9553
    Avatarzofty
    Member
    • Total Post: 13
    • Regular Joe
    • ★★

    Hi,

    OK so the first DHCP attempt is expected (trying for WDM)

    I can only get the V50 to recieve the wlx.ini from ftproot/wyse/wlx when a static ip is applied…so the wlx.ini is in the right place.

    Otherwise if the V50 is DHCP the error line “failed to retrieve system profile” appears in the system log.

    Any ideas to get the V50 recieving the ini while in DHCP mode – also please note: when the device is in DHCP and the 161,162 option tags are used. Funny sysmbols are displayed not the FTP server IP or path as expected. Is this normal for a V50? It happens on more than one device and I have updated the firmware.

    Regards,

    Zofty

    #9554
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Interesting, no you should not get strange symbols in those fields. They should be propagated correctly

    I can only get the V50 to receive the wlx.ini from ftproot/wyse/wlx when a static ip is applied…so the wlx.ini is in the right place.

    In the example above your 162 tag should be simply “/” (without the quotes). The fact there is no error about accessing the ftp server indicates it contacted the ftp server but the path was wrong.

    Also check that the 162 option tag is set up as a plain string value, if you tick the array box or use a multi-string it will not work.

    I kinda feel we are getting close on this one, what do you think?

    -TT

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.