V10/PNAgent: “connection timed outâ€￾&“DNS/WINS canâ

  • This topic is empty.
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #1095
    AvatarPeGe
    Member
    • Total Post: 11
    • Regular Joe
    • ★★

    We can’t get PNAgent to work on our V10L thin clients.

    Published applications are presented on the desktop but when we try to start applications by double clicking on the icons we get:

    ICA[App. Name]: Connection timed out.

    In the eventlog we see:

    DNS/WINS can’t resolve [App. Name]

    Any help apprecicated.

    Thanks,
    Peter.

    #12459
    ConfGenConfGen
    Keymaster
    • Total Post: 10966
    • Jedi Master
    • ★★★★★★★

    Are you using wnos.ini? Post it please.
    Try changing the browsing protocol to HTTP or non-HTTP.

    CG

    #12460
    AvatarPeGe
    Member
    • Total Post: 11
    • Regular Joe
    • ★★

    Already tried HTTP and non-http without result. WNOS.INI, see below:

    ;*************************************************************
    ;* *
    ;* This wnos.ini file was generated with the *
    ;* Configuration File Generator *
    ;* Copyright by Thomas Moellerbernd *
    ;* *
    ;*************************************************************

    ;*************************************************************
    ;* General 1 *
    ;*************************************************************

    Fileserver=10.111.1.7
    EnableLocal=yes
    Privilege=high HideConnectionManager=no
    Device=Audio Volume=10 Mute=No

    ;*************************************************************
    ;* Input Devices *
    ;*************************************************************

    Language=fr_be

    ;*************************************************************
    ;* Display *
    ;*************************************************************

    Resolution=1680×1050
    Screensaver=”20″ LockTerminal=no Type=1

    ;*************************************************************
    ;* Time *
    ;*************************************************************

    Timeserver=ntp.skynet.be Timeformat=”24-hour format” Dateformat=dd/mm/yyyy
    TimeZone=’GMT + 01:00′ ManualOverride=yes Daylight=yes Start=030507 End=100507 TimeZoneName=”Central Europe Standard Time”

    ;*************************************************************
    ;* Network *
    ;*************************************************************

    SignOn=Yes
    MaxVNCD=2
    VncPassword=”eserver”
    VncPrompt=No Accept=

    ;*************************************************************
    ;* Printing *
    ;*************************************************************

    Printer=LPD1 LocalName=HP Host=10.111.1.29 Queue=HP PrinterID=HP Enabled=yes

    ;*************************************************************
    ;* General Session *
    ;*************************************************************

    SessionConfig=ALL UnmapPrinters=no UnmapSerials=no Smartcards=yes MapDisks=yes DisableSound=no
    UniSession=yes

    ;*************************************************************
    ;* ICA *
    ;*************************************************************

    Seamless=yes
    DomainList=KVLVHOSTING
    PnliteServer=portal.kvlv.belbone.be
    SessionConfig=ICA DesktopMode=Window
    IcaBrowsing=HTTP

    ;


    ;- ICA Session 1 –
    ;- Each line but the last must end with a ‘ ‘ –
    ;



    CONNECT=ICA

    #12462
    AvatarPeGe
    Member
    • Total Post: 11
    • Regular Joe
    • ★★

    Additional information: when I right-click on a application on the V10 desktop I see 172.19.6.217 defined as the ‘Browser Servers’, this is the IP address of our PNAgent server.
    When I change the IP to 172.19.3.189 or .190 (our two Citrix servers) then the application work.

    So it seems that there is something wrong with the PNAserver, although on XP clients (Thin clients and PC’s) everything is working fine.

    #12464
    ConfGenConfGen
    Keymaster
    • Total Post: 10966
    • Jedi Master
    • ★★★★★★★

    First of all you can remove the ICA connection at the end of the file.
    Have you tried to use 172.19.3.189 or .190 as browser server?

    CG

    #12466
    AvatarPeGe
    Member
    • Total Post: 11
    • Regular Joe
    • ★★

    When I manually set the browser server to 172.19.3.189 or .190 then everything works, but can it be automated as a parameter in de WNOS.INI ?

    #12467
    ConfGenConfGen
    Keymaster
    • Total Post: 10966
    • Jedi Master
    • ★★★★★★★

    I meant using PnliteServer=172.19.3.189; 172.19.3.190 in your wnos.ini.

    CG

    #12469
    AvatarPeGe
    Member
    • Total Post: 11
    • Regular Joe
    • ★★

    Yep, is working. Thx !! But is this going to give us all the functionality’s like load balancing and reconnection? And still, why is the PNA url not working?

    But thanks anyway, we got a work-around !!

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.