V10L reconnect to active/disconnected session CitrixXenap5

  • This topic is empty.
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #6927
    asrv99
    Member
    • Total Post: 2
    • Newbie

    Hi Everyone,

    I am sure someone has come across this before,

    Have a V10L firmware 6.5.0_22 running Citrix Xenapp 5.0 farm 7 servers THCCTX01,02,03,04,05,06,07 . My config is pointing to the Web frontend PNA box.

    1. Launch several applications from Vl10L such as IE, Hospital Apps, Outlook etc.
    2. Disconnect V10L from Power and I can still see those session active in Citrix just waiting for a reconnect from somewhere.
    3. When Wyse finishes rebooting and I login it wont re-connect to the sessions I just opened:

    here is my WNOS.INI

    this was created using CONFIGEN tried removing adding reconnect at logon= 2

    cant seem to get this to work by re-connecting to these active sessions. If I open a session on the V10L then disconnect it in Xenapp 5.0 the session WTOS will try to reconnect after 20 seconds it just launches a new session which to me is correct but not what I need. I keep launching new sessions but it wont connect to any old or active secessions how can this followme sessions accomplished considering the config below?

    ;*************************************************************
    ;* *
    ;* This wnos.ini file was generated with the *
    ;* Configuration File Generator 6.1.01 *
    ;* Copyright by Thomas Moellerbernd *
    ;* *
    ;* http://www.technicalhelp.de *
    ;* *
    ;*************************************************************

    ;*************************************************************
    ;* General 1 *
    ;*************************************************************

    autoload=2
    AdminMode=yes Admin-Username=wyseadmin Admin-Password=xxxxxx
    Privilege=Low
    EnableTrace=yes
    Lockdown=yes
    ConnectionManager=hide
    Speebrowser=on

    ;*************************************************************
    ;* General 2 *
    ;*************************************************************

    formurl=”Trillium Logo.jpg”

    ;*************************************************************
    ;* Input Devices *
    ;*************************************************************

    Language=Us

    ;*************************************************************
    ;* Display *
    ;*************************************************************

    ; If you are using a version of WTOS code < 7.0.1_13 please use:
    ; Resolution=DDC Refresh=
    Screen=1 Resolution=DDC
    DesktopColorDepth=32
    Desktop=THC_Desktop.jpg Layout Layout=Stretch

    ;*************************************************************
    ;* Time *
    ;*************************************************************

    Timeserver=time.nrc.ca Timeformat=”24-hour format”
    TimeZone=’GMT – 04:00′ ManualOverride=yes Daylight=yes Start=030107 End=110207 TimeZoneName=”US Eastern Standard Time” DayLightName=”US Eastern Daylight Time”

    ;*************************************************************
    ;* Network *
    ;*************************************************************

    Device=Ethernet Speed=”Auto”
    SignOn=Yes ConnectionManager=hide EnableOK=Yes IconGroupStyle=Default
    DisableDomain=yes
    DomainList=”THC”

    ;*************************************************************
    ;* Wireless *
    ;*************************************************************

    IEEE8021X=yes network=wireless access=WPA2-ENT eap=yes eaptype=EAP-PEAP peapeap=EAP-MSCHAPV2 peapmschapun=thcxxxxxxx peapmschappwd=xxxxxxx
    Device=Wireless Mode=Infrastructure SSID=admin Channel=5

    ;*************************************************************
    ;* General Session *
    ;*************************************************************

    SessionConfig=ALL UnmapPrinters=no
    Reconnect=YES

    ;*************************************************************
    ;* ICA *
    ;*************************************************************
    IcaBrowsing=UDP
    Seamless=yes
    PnliteServer=10.21.160.72 ReconnectAtLogon=2 ReconnectFromButton=2
    SessionConfig=ICA DesktopMode=Fullscreen SessionReliability=yes OnDesktop=yes ProgressiveDisplay=yes AudioQuality=Default

    ;*************************************************************
    ;* Troubleshooting *
    ;*************************************************************

    Privilege=High EnableTrace=yes
    SaveSysinfo=ftp ScardLog=0xF

    #21325
    bspies
    Member
    • Total Post: 18
    • Regular Joe
    • ★★

    I compared your settings and mine and spotted two differences – but honestly not sure if they are related. you can always play with the settings and see if they help or not.

    as an FYI – In our config, the wyse terminals logon to the PNA site and auto start our published Desktop so that accounts for other differences you see here.

    The two settings I spotted at first glance that were different are:

    IcaBrowsing=HTTP
    – yours is UDP – not sure if this matters.

    Reconnect=no
    – yours is “yes”. I do not recall why I set this to no. Seems like this option and ReconnectAtlogon might mean the same thing but perhaps not?

    also I use =1 for my options because I only wanted disconnected sessions to reconnect. If you use 2, active sessions can be connected as well. We have no need for that so I think it would be confusing for our users. Most people do seem to use =2.

    ;*************************************************************
    ;* General Session *
    ;*************************************************************

    SessionConfig=ALL MapDisks=yes DisableSound=No MouseQueueTimer=20
    Reconnect=no

    ;*************************************************************
    ;* ICA *
    ;*************************************************************

    IcaBrowsing=HTTP
    Seamless=yes HideTaskBar=2 FullscreenReserved=yes
    PnliteServer=MYAPPS.ourdomain.PVT ReconnectAtLogon=1 ReconnectFromButton=1 AutoConnectList=”XA64 Farm:Citrix Desktop Fullscreen” Timeout=”10″
    LongApplicationName=yes
    SwitchApplication=yes
    SessionConfig=ICA DesktopMode=Fullscreen SysMenu=Remote SessionReliability=yes OnDesktop=Desktops AudioQualityMode=Medium mapdisksunderz=no Mapdisks=yes

    #21328
    asrv99
    Member
    • Total Post: 2
    • Newbie

    I tried changing the settings from UDP for IcaBrowsing=UDP to HTTP and set Reconnect = no it didnt have impact on reconnecting to the active sessions on Citrix. Also we are using published applications instead of desktops. Appreciate your recommendations I will keep digging into this con-fig. Although not sure what else to change here.

    *************************************************************
    ;* General 1 *
    ;*************************************************************

    autoload=2
    AdminMode=yes Admin-Username=wyseadmin Admin-Password=xxxxxx
    Privilege=Low
    EnableTrace=yes
    Lockdown=yes
    ConnectionManager=hide
    Speebrowser=on

    ;*************************************************************
    ;* General 2 *
    ;*************************************************************

    formurl=”Trillium Logo.jpg”

    ;*************************************************************
    ;* Input Devices *
    ;*************************************************************

    Language=Us

    ;*************************************************************
    ;* Display *
    ;*************************************************************

    ; If you are using a version of WTOS code < 7.0.1_13 please use:
    ; Resolution=DDC Refresh=
    Screen=1 Resolution=DDC
    DesktopColorDepth=32
    Desktop=THC_Desktop.jpg Layout Layout=Stretch

    ;*************************************************************
    ;* Time *
    ;*************************************************************

    Timeserver=time.nrc.ca Timeformat=”24-hour format”
    TimeZone=’GMT – 04:00′ ManualOverride=yes Daylight=yes Start=030107 End=110207 TimeZoneName=”US Eastern Standard Time” DayLightName=”US Eastern Daylight Time”

    ;*************************************************************
    ;* Network *
    ;*************************************************************

    Device=Ethernet Speed=”Auto”
    SignOn=Yes ConnectionManager=hide EnableOK=Yes IconGroupStyle=Default
    DisableDomain=yes
    DomainList=”THC”

    ;*************************************************************
    ;* Wireless *
    ;*************************************************************

    IEEE8021X=yes network=wireless access=WPA2-ENT eap=yes eaptype=EAP-PEAP peapeap=EAP-MSCHAPV2 peapmschapun=thcxxxxxxx peapmschappwd=xxxxxxx
    Device=Wireless Mode=Infrastructure SSID=admin Channel=5

    ;*************************************************************
    ;* General Session *
    ;*************************************************************

    SessionConfig=ALL UnmapPrinters=no
    Reconnect=No

    ;*************************************************************
    ;* ICA *
    ;*************************************************************
    IcaBrowsing=HTTP
    Seamless=yes
    PnliteServer=10.21.160.72 ReconnectAtLogon=2 ReconnectFromButton=2
    SessionConfig=ICA DesktopMode=Fullscreen SessionReliability=yes OnDesktop=yes ProgressiveDisplay=yes AudioQuality=Default

    ;*************************************************************
    ;* Troubleshooting *
    ;*************************************************************

    Privilege=High EnableTrace=yes
    SaveSysinfo=ftp ScardLog=0xF

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.