user.ini?

  • This topic is empty.
Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #184
    Avatarnohj68
    Member
    • Total Post: 9
    • Regular Joe
    • ★★

    On the old 3360 and 3125 TCs, you were able to login as administrator to the terminal, as opposed to a simple user. We’ve upgraded to the S50 clients. I have the users priviledge set to none, which gives the user no access to any control panel functions. My question is: Is there a way for me to login with administrative priviledges, other then going into the wlx.ini file and changing the priviledge to high? Is this done by using the user.ini file? And if so, how? Or is there a way of accessing/shadowing the client through Rapport as administrator?

    #8807
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Hi nohj68,

    First of the way the linux client works is totally different to to the CE based Wyse terminals (any terminal starting with a 3 is CE and with a 5 is Linux)

    To do what you are after is not a problem but you will need to be signing on to the terminal with sign=1. Then place a file in the ini folder under the WLX folder this ini will be called the .ini

    So, create a administrator.ini and in it put the line privilege=high. When you log on to the terminal as administrator you will have full access.

    Its takes a bit to get the idea but works well, personally I like the Linux OS more than CE as the ICA performance is better and you can do things like an AD LDAP login via the wlx.ini file – cool

    -TT

    #8809
    Avatarnohj68
    Member
    • Total Post: 9
    • Regular Joe
    • ★★

    Great, thanks for the info.. I do have one question, the admin.ini file, is that placed within the wlx.ini, or a seperate ini file in the WLX folder? Also, if we have the users logging directly in without signing in, how do I access the login screen to log in?

    I have a couple of other questionos dealing with the S50. I tried calling Wyse, but haven’t gotten much help (lately). The S50s and the whole Rapport thing is new to me, so I’m kind of learning as I go. Thanks for any help you can offer.

    #8816
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Hi,

    The ini file will be in a folder called ini so the structure looks like this:

    wlx (folder)
    |
    |—-ini(sub folder)

    The admin.ini will be in the ini sub folder.

    This works best with a login, you can set a default login with the username= password= command. This lets you “log off” from the terminal.

    I hope this helps, have a look at the params pdf and experiment, you will get the hang of it quickly!

    Feel free to ask loads of questions,

    Cheers,
    -TT

    #8817
    Avatarnohj68
    Member
    • Total Post: 9
    • Regular Joe
    • ★★

    Gotcha! I’ll try that out in a few minutes. My next question is in order for this login to work, there has to be a user signon, correct? Right now signon is set to 0 (which is another question I have). Is there a way to have the signon set to 0 but still get to login as admin? Does it involve enabling the 5 second countdown to login?

    Now, about the SignOn= command. I noticed that on some of the clients we are using (all S50s) the command works, and on others it doesn’t. I have SignOn=0 and Priviledge=None. On some clients it works perfectly, but on others, they are getting a login prompt for a user (guest) and password. Does this have something to do with firmware version?

    Thanks again for all your help. I lost my contact at Wyse and haven’t had much help from them since then.

    #8818
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Lets back up a bit here…

    If some devices are not getting the signon=0 then it tells me the ftp directory is not set correctly on the server tab on the terminal. So before we go on make sure you have done the following:

    1/ Use the DHCP option tags 161 and 162 to define the ftp server.
    2/ Use the ftp firmware or Rapport to ensure all terminals are on the same level of software.

    This should create a reliable and consistant environment for you.

    Next, are you using ICA or RDP? This will tell me what options you have to log in.

    Finally, yes we have to have signon=1 if you want 2 levels of privilege. We can make a user.ini the automatically logs the terminal in on start up. The only issue will be the user could select “logout” and would not know how to get back in without a reboot.

    The second option is we get users to log in to the terminal with thier AD username and password and have this information automatically start the ICA or RDP session. Only one login is required and the username and password will pass through and log the user into the server.

    Let me know which way you want to set it up and I will post an example and don’t forget to let me know what you are using – TS or Citrix.

    Cheers,
    -TT

    BTW – Wyse support will only really help if its a problem with hardware, really the VAR who sold the devices to you should be helping you set them up.

    #8820
    Avatarnohj68
    Member
    • Total Post: 9
    • Regular Joe
    • ★★

    First off, thanks in advance for your help.

    We don’t use DHCP, everyone has a static IP address. But, you are right about the setup of the server tab. I think part of the problem is that is not setup properly on the clients. I don’t think they are pointing to the /wyse directory. But, that’s easy enough to take care of. So, we can go forward under the assumption that all clients are pointing in the right place.

    Secondly, we are using ICA (Citric) and TEC connections.

    I figured we’d have to use a login. I was hoping not to because it will cause some confusion with the users, no doubt. But if that’s the way it has to be, then that’s the way it has to be. Using their “windows” login (AD) would probably be the best way to go. I’d rather them have to have an extra login then be able to mess around in the control panel or delete a connection in Connection Manager.

    As for Wyse, I did have a contact over there, and he was quite helpful. But the last time I contacted him with a question he told me to call support and if need be, they’d get him involved. So, I contacted Wyse CS but never heard back from them. After the 4th non-returned call, I came here for help.

    So, to recap….let’s go with the assumption that the Server tag is configured properly on all clients. The clients are configured with ICA and TEC connections and have static IP address, not DHCP.

    Thanks again for your help, I can’t tell you how much I appreciate it.

    #8832
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Thanks for the extra information, as always there are a few ways to achive what you are after. One way is to use PNagent as you are using Citrix. Here a a few sugestions.

    Citrix PNagent:

    – Have a Web interface server and create a PNagent site
    – Set the MPserver= command in the wlx.ini file with the IP of the PNagent server
    – You could either publish the icon to the desktop or create an icon with a connect statement and pass the user details through.

    AD:

    You can also do a LDAP look up and log in with AD username and passwords to the terminal and then pass this information on to a Citrix shortcut.

    – Use the confgen tool to configure a wlx.ini file that logs in to AD
    – build a connect= statement to the Citrix applicaion, make sure you pass the username and password through or the user will have to authenticate twice.

    connect=ica
    browserip=192.169.1.1
    application=desktop
    username=$UN
    password=$PW
    domanname=$DN
    fullscreen=1

    The final choice is to log the user in automatically as a default user using .ini files only however if the user selects logout instead of shutdown they will not know how to log back in.

    Hopefully this is of help, have a play with the confgen tool and the Linux params guide (which I just updated with the latest version). Hopefully you will find a solution,

    Cheers,
    -TT

    #10108
    Avatarnohj68
    Member
    • Total Post: 9
    • Regular Joe
    • ★★

    I’m revisiting this old thread. I was sidetracked at work and never fully finished this problem, but I’m going to give it a shot and have the users login using their AD logins. It won’t be for a week or 2, but I’ll post results.

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.