USB Wireless keyb / mouse & TCX

  • This topic is empty.
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #5469
    echappatte
    Member
    • Total Post: 3
    • Newbie

    Hi All,

    Since many weeks I read this forum (and FWM site): great content.

    But I have a problem with ThinOS, TCX USB and “advanced” keyb / mice devices.

    I use Logitech devices, I have done many tests with Cordless Desktop® MX™ 3100 kit. The keybord and the mice are recognized by WTOS, and it work. But TCX won’t forward them to Windows XP virtual machine, so these devices are not seen in peripheral and SetPoint (Logitech advanced configuration manager) don’t see anything; so I am unable to use the lot of advanced keys/functionalities.

    I have try to add the VID & PID in TCX USB, without succes. I have also tried to disable legacy USB in BIOS, dont work better.

    I think TCX detect keyb & mice as standard peripheral, and it think “this is a standard mice & keybord, ok, don’t forward”

    What can I do to forward these USB devices with TCX ?
    Anyone here is using advanced keyboard or mouse ?

    Thank you for your help,

    E.Chappatte

    #17011
    ConfGen
    Keymaster
    • Total Post: 11409
    • Jedi Master
    • ★★★★★★★

    You are right. Some default devices will not be forwarded.
    Other than add the PID/VID to the wnos.ini AND TCX USB config in the session there is nothing you can do.

    CG

    #17013
    echappatte
    Member
    • Total Post: 3
    • Newbie

    ConfGen, thank you for your reply.

    Ok.. this mean that all advanced keyboard can’t be used with advanced functionalities…

    This is a problem; do you know if TCX will be updated with a possibility to correct this ?

    #17014
    ConfGen
    Keymaster
    • Total Post: 11409
    • Jedi Master
    • ★★★★★★★

    Other than add the PID/VID to the wnos.ini AND TCX USB config in the session there is nothing you can do.

    Have you tried that?

    CG

    #17019
    echappatte
    Member
    • Total Post: 3
    • Newbie

    Sorry, I have read to fast your reply…

    I have add this in vnos.ini :

    Device=vusb ForceRedirect=0x046D,0xC512,0x03,0x01,0x01

    and I have forwarded the device with VID/PID in TCX too.

    With this configuration, all extended functionalities (keyb extra keys, mouse buttons, detection in SetPoint, etc) works… but the basic functionalites of mouse and keybord (= moving mouse and typing keys) don’t work !!

    Since the virtual machine is connected, mouse and keyboard don’t work more in ThinOs… because the device is forwarded !
    And, with RDP, the control for mouse and keyboard is done in ThisOs.

    In conclusion, I can have basic control OR advanced control, but not the two in the same time ! 😕

    Thank you again ConfGen for your great help.
    If you have another idea for me ?

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.