USB printer works but shows error

  • This topic is empty.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #1616
    Avatartomhenderson
    Member
    • Total Post: 3
    • Newbie

    I have a Wyse S10 with a usb printer (canon MF4140) attached. I’ve installed the driver on the windows virtual machine and set up the printer in the wnos.ini file. The printer shows up in windows and prints perfectly, but every time I print the RDP session is minimized and I get an error in the Wyse OS: “Printer LPT1: offline”. Clicking ok brings back the RDP session.

    Any ideas how I can stop the error message?

    Printer setup in wnos.ini:
    Printer=LPT1
    name=”Office Printer”
    printerid=”Canon MF4100 Series UFRII LT”

    #14540
    ConfGenConfGen
    Keymaster
    • Total Post: 11116
    • Jedi Master
    • ★★★★★★★

    Please post the complete wnos.ini.
    Which firmware are you using?

    CG

    #14544
    Avatartomhenderson
    Member
    • Total Post: 3
    • Newbie

    I believe I have the latest firmware. I’ll check when I get into the office.


    # wnos.ini
    # Install firmware if available
    autoload=2

    # Use a login screen
    signon=1
    formurl=pack.bmp
    deskcolor="0 78 152"

    # No connections are defined here. User must log in to an account.

    # Set up printer for all users:
    Printer=LPT1
    name="Neighbourhood Office Printer"
    printerid="Canon MF4100 Series UFRII LT"

    Connections are set up in the user.ini files. Here is one:


    # tom.ini
    # User Privileges:
    privilege=High
    lockdown=no
    hidesysinfo=no
    hideppp=no
    hidepn=no
    hideconnectionmanager=no
    enablenetworktest=yes
    enabletrace=yes
    showdisplaysettings=yes
    enablekeyboardmousesettings=yes

    # Connections:
    connect=rdp
    description= "Office PC"
    icon="neighbourhood.bmp"
    fullscreen=yes
    host=192.168.100.61
    username=Neighbourhood
    #14545
    Avatartomhenderson
    Member
    • Total Post: 3
    • Newbie

    System Version: 6.2.0_98

    #14546
    ConfGenConfGen
    Keymaster
    • Total Post: 11116
    • Jedi Master
    • ★★★★★★★

    You ini files look fine except two small issue which does not do an harm in your case. If you are splitting parameters over several lines using the “” sign there should never be a “” sign at the end of the last line. In your cases both times this is the end of the files so no problem here but keep it in mind or use my ConfGen tool to create the ini files.
    I guess you had a typo in the last reply and have firmware version 6.2.08 and not .098 in use.
    But nevertheless I have no clue why you do see this issue. I would contact Wyse to get the latest code. I should be around 6.2.016 or a bit higher. Maybe this was a known issue and it is already fixed.

    CG

    #20294
    Avatarschwoaz
    Member
    • Total Post: 1
    • Newbie

    I know this topic is old,
    but now we have the same issue with V10LE and 7.0_113
    Not all Clients will print this PopUp only around 50 of 1900.
    All Clients have the same Config, the Printer Cable is alright.
    The Printers are connected via Parallel Cable.

    wnos.ini

    FactoryDefault=yes
    signon=no
    S10WDMFlash=128MB
    Serial=COM1 Baud=115200 Parity=None Stop=1 Size=8 Flow=NONE
    VncPrompt=No Accept
    VncPassword=#####
    DeskColor=”255 255 255″
    ThinPrintEnable=yes
    adminmode=yes username=##### password=######
    ## Privilege Level
    Privilege=none Lockdown=yes

    ##Include device specific ini
    Include=$mac.ini
    SessionConfig=ALL UnmapPrinters=no UnmapSerials=no Smartcards=yes MapDisks=yes DisableSound=no DisksReadOnly=no
    TimeZone=’GMT + 01:00′ ManualOverride=yes Daylight=yes Start=030507 End=100507 TimeZoneName=”Central Europe Standard Time” DayLightName=”Central Europe Daylight Time”

    mac.ini
    FormURL=####.jpg
    Desktop=####.jpg
    connect = ICA Browserip=##### Application=”Desktop” description = “#####” Autoconnect=1 LocalCopy=yes Password=$PW Domainname=$DN Disablesound=yes Mapdisks=no Smartcards=no UnmapPrinters=no UnmapSerials=no icon=rapport.ico Experience=13 fullscreen=yes
    Printer=LPT1 Name=”LaserDrucker” PrinterID=”Lexmark” Enable=yes EnableLPD=yes
    NetworkPrinter=#####/LaserDrucker
    Language=de_ibm
    Resolution=1280×1024 Refresh=60

    Regards

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.