Upgrade firmware via FTP

  • This topic is empty.
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #5503
    Flip
    Member
    • Total Post: 27
    • Regular Joe
    • ★★

    I am trying to upgrade the firmware of our S50 Wyse device via FTP.

    I am following the instructions in this pdf :

    https://support.wyse.com/OA_HTML/csksxvm.jsp?nSetId=29699&nUsePub=NO&jttst0=6_23871,23871,-1,0,&jtfm0=_0_1_0_-1_f_nv_&etfm1=&jfn=ZGCCF2ADCD25B26AA07D90C29C09B1E97B18485F10C2793E319B469C364F78CCE254F278F23101131BE7C2355152200D6FDC&oas=FgSMQIREPjFstGf0K3egWA..

    The problem is that I am using a FTP device where the root path is not /wyse but /disk1/wyseFTP/wyse, I put that in the FTP tab of the network information in the control panel, but everytime I reboot the device the path has been changed back to /wyse and I get an error that the FTP server could not be used.

    Changing the FTP server itself and all the other settings are not a problem, but the root path seems to be reset to the default of /wyse everytime.

    Does anyone have any ideas what is going wrong ?

    I cannot set a home directory for the FTP user, so I will have to be able to change the root path.

    #17108
    ConfGen
    Keymaster
    • Total Post: 11410
    • Jedi Master
    • ★★★★★★★

    Are you using DHCP option tag like OT161 or 162?

    CG

    #17110
    Flip
    Member
    • Total Post: 27
    • Regular Joe
    • ★★

    @ConfGen wrote:

    Are you using DHCP option tag like OT161 or 162?

    CG

    No we do not, what do those tags do anyway ?

    The thing is we wanted to upgrade from another server, one that is not our DHCP server.

    It seems I had to change the following lines in our ini file to change the root path, the changes I made in the control panel were never used :

    FirmwareRootPath=/disk1/wyseFTP/wyse

    #17111
    Flip
    Member
    • Total Post: 27
    • Regular Joe
    • ★★

    It seems even though I did not check “Use ini files for Configuration” in the System preferences, it kept on taking /wyse as the root path, even though I entered a different path in the network settings.

    #17114
    ConfGen
    Keymaster
    • Total Post: 11410
    • Jedi Master
    • ★★★★★★★

    Try to reset the unit to default and try again.

    CG

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.