Unwanted Factory Reset

  • This topic is empty.
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #7189
    Avatard_fisher
    Member
    • Total Post: 3
    • Newbie

    Trying to update our V10L terminals from WTOS 7.0_217 to 7.1_036. Went into admin mode and manually changed the fileserver path on some test terminals. They are now pointing to the new WTOS. Reboot and the WTOS update starts. Reboots when its done and loads what appears to be a device reset to factory defaults.

    To fix the problem I have to manually configure the central configuration info again. I can point it either WTOS location and everything works. If I go back to the old version again a second attempt to update works perfectly (no factory default).

    At first I thought the field tech I was working with must be selecting the box to reset to factory defaults before he reboots. But if he did that it wouldn’t even start the WTOS update. I’m stumped.

    Doug

    #21968
    ConfGenConfGen
    Keymaster
    • Total Post: 11217
    • Jedi Master
    • ★★★★★★★

    Looks like you have
    FactoryDefault=1
    in your wnos.ini.

    CG

    #21976
    Avatard_fisher
    Member
    • Total Post: 3
    • Newbie

    @ConfGen wrote:

    Looks like you have
    FactoryDefault=1
    in your wnos.ini.

    CG

    I wish it was that simple. Neither the current or the new wnos.ini files have FactoryDefault=1. I previously added FactoryDefault=0 during my troubleshooting. It didn’t help.

    #21979
    ConfGenConfGen
    Keymaster
    • Total Post: 11217
    • Jedi Master
    • ★★★★★★★

    Stupid question, but you have the same wnos.ini in the second location, haven’t you?

    CG

    #21991
    Avatard_fisher
    Member
    • Total Post: 3
    • Newbie

    I have different wnos.ini files in both locations. I have verified that they are being read and work properly (except when updating the WTOS version).

    Here is another twist. If I update a device it performs the unwanted reset to factory default the first time only. If I downgrade to 7.0_217 and upgrade it again everything works as desired. The issue only exists the first time ever that the device was upgraded. This is why we didn’t catch the problem in our testing. Our test devices get updated/downgraded a lot while our deployed devices stay constant.

    I no longer think the problem has anything to do with the wnos.ini settings. I did a test where the wnos.ini file was the same so the only change was the WTOS update. I also tested where I removed almost everything from the new wnos.ini file. Still doesn’t work. The reset to factory default still happens. After that test, the only lines remaining were

    autoload=1
    Fileserver=xxxxxxxxxxxx Username=xxxxxxxx Password=xxxxxxxx
    Rootpath=wyse/test

    I think I need to open a case with Wyse. Until they can find a permanent solution I may have to abandon the update to 7.1_036. Now I just have to make sure my new wnos.ini file will work as desired with 7.0_217.

    Still open to any suggestions.
    -Doug

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.