Trouble reading xen.ini

  • This topic is empty.
Viewing 15 posts - 1 through 15 (of 30 total)
  • Author
    Posts
  • #7332
    chojin2000
    Member
    • Total Post: 14
    • Regular Joe
    • ★★

    Hello,

    First off I want to say that I really like this site and appreciate this community.

    I am currently working on a VDI project and we are using Wyse Xenith clients. Model # Cx0

    I have read many posts on here and the Wyse Xenith Administrators Guide about using the DDC to host the xen.ini file in the wnos folder.

    Currently I have DHCP pushing out options 161, 162 and 181.

    The problem I am having is that the settings specified in my xen.ini file (which I am using ConfGen to create) are not getting applied.

    When I start up the client I see a message saying “Contacting File Server…” It is on the screen for about a minute before it times out and continues on without any settings being applied.

    Does anyone here have any ideas about what is preventing the xen.ini from being processed?

    Thanks in advance.

    #22251
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    Where exactly have you saved your xen.ini? What are the values of OT 161, 162 and 181?

    CG

    #22261
    chojin2000
    Member
    • Total Post: 14
    • Regular Joe
    • ★★

    I currently have my xen.ini file on the DDC. Path is: inetpubwwwrootwysewnos

    DHCP options (which the client is getting):
    161 – FQDN of DDC server
    162 – /
    181 – FQDN of XenDesktop server

    I feel like I have these settings right and that maybe IIS is misconfigured. We ran wireshark and we can see where it’s trying to connect and we get 500/internal error.

    Any ideas?

    #22262
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    Have you added http:// in front of the FQDN?
    What value does the Fileserver field on the Xenith itself show?

    CG

    #22265
    chojin2000
    Member
    • Total Post: 14
    • Regular Joe
    • ★★

    I have tried adding http and even tried just adding the IP address instead of FQDN. The value on the client is the FQDN of DDC server with a / at the end.

    #22266
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    Then remove the /wyse folder or move the /wnos folder to inetpub/wwwroot

    CG

    #22267
    chojin2000
    Member
    • Total Post: 14
    • Regular Joe
    • ★★

    Tried that and still nothing.

    #22268
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    what happens when you enter http://fqdn/wnos in any browser on your PC? Can you see and open the wnos.ini?

    CG

    #22269
    chojin2000
    Member
    • Total Post: 14
    • Regular Joe
    • ★★

    I am unable to open the xen.ini.

    I can navigate to it and see it but I get the following message:

    The page cannot be displayed because an internal server error has occurred.

    #22270
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    I guess you do not have set the appropriate MIME settings. Your webserver does not know anything about *.ini files.

    Be sure to create/activate the two required MIME Types (.ini and .) under IIS (on a per site
    basis) to enable downloading. Also be sure your Web server can identify the file types
    used by Wyse thin clients.
    To create/activate .ini:
    1. On your IIS server, use the File Types menu to add a New Type.
    2. In the File Type dialog box, enter the Associated extension .ini and Content type
    (MIME) text/plain.
    3. Click OK to apply the settings.
    To create/activate .:
    1. On your IIS server, use the File Types menu to add a New Type.
    2. In the File Type dialog box, enter the Associated extension . and Content type (MIME)
    text/plain.
    3. Click OK to apply the settings.

    CG

    #22271
    chojin2000
    Member
    • Total Post: 14
    • Regular Joe
    • ★★

    I did that too.

    That was in the Wyse Xenith Admin guide.

    #22273
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    What about NTFS permissions?

    CG

    #22275
    chojin2000
    Member
    • Total Post: 14
    • Regular Joe
    • ★★

    I added anonymous logon to the wyse directory and it has read & execute, list folder contents, read.

    #22276
    chojin2000
    Member
    • Total Post: 14
    • Regular Joe
    • ★★

    Just tried accessing /wyse/wnos/xen.in through a browser on the DDC and received a message I have not seen before.

    HTTP Error 500.19

    Error Code: 0x800700b7

    Config Error: Cannot add duplicate collection entry of type ‘mimeMap’ with unique key attribute ‘fileExtension’ set to ‘.ini’

    I don’t really understand this…I am looking at the server and I have the mime types I created are there (. and .ini)

    #22279
    ConfGen
    Keymaster
    • Total Post: 11485
    • Jedi Master
    • ★★★★★★★

    Just for testing, can you put the wnos folder to an ftp server and try this?

    CG

Viewing 15 posts - 1 through 15 (of 30 total)
  • You must be logged in to reply to this topic.