ThinOS 9.0.3030 Keyboard Problem

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #53364
    AvatarIhuru
    Participant
    • Total Post: 11
    • Regular Joe
    • ★★

    Good morning together

    I am new to this forum. Read a lot about the update from ThinOS 8.6 to ThinOS 9.

    I have tested the update with two Wyse 3040 and it works.
    Now I have the following problem:

    In the WMS I have configured the following:

    Locale: German
    Keyboard layout: German (Switzerland)

    When I’m on the Wyse 3040, the keys are right.
    When I am logged into Citrix, the following keys are wrong:

    The character !
    The characters above the number 1 and 3

    With the Wyse 3040 and the old software 8.6.303 it’s no problem.

    What am I doing wrong?

    #53366
    ConfGenConfGen
    Keymaster
    • Total Post: 11270
    • Jedi Master
    • ★★★★★★★

    This is a known big in the Citrix Workspace app.
    There will be a workaround in the next ThinOS release expected 9th of November.
    If you need an urgent workaround let me know.

    CG

    #53483
    AvatarIhuru
    Participant
    • Total Post: 11
    • Regular Joe
    • ★★

    good morning

    I have made the update:

    Citrix_2006_1146.pkg-V2006.1146
    Root_9.0.4024.pkg-V9.0.4024

    The keyboard layout on the Wyse 3040 is set to “German (Switzerland)”.

    in the Citrix session i then used the keyboard layouts
    ENG English US keyboard as default
    DEU German (Germany) German (Switzerland) keyboard

    -> It is wrong that the English keyboard layout comes
    -> The German (Switzerland) keyboard layout now brings the “right” characters

    The problem is not solved

    #53491
    ConfGenConfGen
    Keymaster
    • Total Post: 11270
    • Jedi Master
    • ★★★★★★★

    -> It is wrong that the English keyboard layout comes

    What’s wrong with showing the default layout?

    CG

    #53496
    AvatarIhuru
    Participant
    • Total Post: 11
    • Regular Joe
    • ★★

    Good morning

    An error occurred during the translation. Sorry.

    On the Wyse is set to german (switzerland).
    This is the only language in the current environment, even in Citrix.

    with the new firmware an additional language is added, english. this additional language is then unfortunately the default language in Citrix

    #53497
    Avatarahereng
    Participant
    • Total Post: 28
    • Regular Joe
    • ★★

    Hi,

    I got the same problem, but using “Solution #2” on the vda seams to have solved the problem for me.

    https://support.citrix.com/article/CTX223316

    Alexander

    #53498
    Avatarahereng
    Participant
    • Total Post: 28
    • Regular Joe
    • ★★

    Correction..  It seams to have solved the problem for some users..

    Alexander

    #53502
    AvatarPhibue
    Participant
    • Total Post: 39
    • Frequent Flyer
    • ★★★

    Same here. New Firmware / Citrix Package didn’t solve the keyboard layout issue.

    #53503
    Avatarahereng
    Participant
    • Total Post: 28
    • Regular Joe
    • ★★

    After resetting the devices to factory-settings, it currently seems as it is working.

    Alexander

    #53506
    ConfGenConfGen
    Keymaster
    • Total Post: 11270
    • Jedi Master
    • ★★★★★★★

    In Citrix Workspace app, the Keyboard Dynamic synchronization mode functions differently between a Windows client and a
    Linux client. In general, on a Linux client, the keyboard output follows the client keyboard layout, which is different from the
    Windows VDA layout. Windows clients follow Windows VDA layout which is same as the Windows client keyboard layout. If a
    Linux client keyboard is synchronized to VDA, users may observe unpredictable output when working in a Windows VDA with a
    keyboard output that follows the Linux client keyboard layout. Also, in dynamic synchronization mode, Citrix Workspace app for
    Linux does not support VDA users to switch the keyboard layout inside a VDA session.
    In the server default mode, both Linux and Windows use the session (VDA) side keyboard layout with a predictable output. In
    this release, ThinOS has a customized Citrix package where the keyboard layout is set to server default mode, for predictable output. The keyboard layout that you select on the thin client is not automatically synchronized in the VDA session.
    VDA users must select or switch the keyboard layout inside the VDA session using the Windows Input Method Editor (IME)
    language bar.
    As a VDA administrator, you must configure the VDA desktop with the required keyboard language layout options. The IME
    language bar must be enabled on the Windows lock screen. The VDA user can select the appropriate keyboard language layout
    on the Windows lock screen.
    In scenarios such as opening a new application in a VDA session, locking or unlocking the VDA session, the keyboard layout falls
    back to the VDA default layout. For example, EN_US. This is a known issue for a Linux client in the server default mode. You
    can customize VDA registry settings for a consistent keyboard layout in the VDA session.
    ● For a desktop operating system VDA, the feature is enabled by default.
    ● For a server operating system VDA, you can enable the feature using the system registry.
    ○ In the system registry of VDA, go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard
    Layout.
    ○ Create a DWORD entry IgnoreRemoteKeyboardLayout=1.
    By default, the IgnoreRemoteKeyboardLayout entry is unavailable. The default keyboard is set to ENG, irrespective
    of the Control Panel setting.
    For example, open an application, lock, or unlock the session, the keyboard is set to ENG. To resolve this issue, ensure
    that you set IgnoreRemoteKeyboardLayout=1.

    CG

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.