T50 Firmware Upgrade via FTP

  • This topic is empty.
Viewing 15 posts - 1 through 15 (of 19 total)
  • Author
    Posts
  • #8001
    Avataraintsowyse
    Member
    • Total Post: 19
    • Regular Joe
    • ★★

    Hi,

    I am new to the wyse devices, and have inherited a site with 100 T50 units.

    I am able to upgrade via WDM to the latest firmware 028, however some devices do not checkin via WDM therefore I cannot push to them. A reboot does not have any effect on this.

    Therefore I would like to try do the firmware upgrade via the ftp server and ini file, however I cannot get this to work.

    Can anyone advise on the config for this?

    My config for this part in the ini file is as follows;

    Fileserver=x.x.x.x
    Rootpath=/wyse
    Rapportserver=x.x.x.x
    Update.Mode=Both
    SIGNON=NO
    AUTOLOAD=2

    There is no attempt from the device (test device with own ini file) to pull upgrade via ftp.

    Any ideas?

    Thanks,

    #24225
    ConfGenConfGen
    Keymaster
    • Total Post: 9810
    • Jedi Master
    • ★★★★★★★

    What files have you placed where exactly?

    CG

    #24227
    Avataraintsowyse
    Member
    • Total Post: 19
    • Regular Joe
    • ★★

    Hi,

    I have tried a few options of locations, copying the files from the rapport folder, which WDM uses and works, and put them in the

    root/wyse/
    root/wyse/wlx/
    root/

    etc

    have tried quite a few locations.

    the files are the .img files;

    bootloader,cmos,mbr,par1,par3

    What am i doing wrong?

    thanks for the assistance!

    #24229
    ConfGenConfGen
    Keymaster
    • Total Post: 9810
    • Jedi Master
    • ★★★★★★★

    The problem are the files you are using. Those are only for WDM or USB upgrade.
    There aren’t any ftp upgrade file available afaik, that’s why I’ve asked you for the file. Thought you may got some 😉

    CG

    #24230
    Avataraintsowyse
    Member
    • Total Post: 19
    • Regular Joe
    • ★★

    ah I see, I didnt see any other files @wyse, I will have another look.

    What format do the ftp files have?

    Thanks!

    #24234
    ConfGenConfGen
    Keymaster
    • Total Post: 9810
    • Jedi Master
    • ★★★★★★★

    I can only speak about the SUSE based Linux units.
    Those files are named
    latest-image.raw
    latest-image.raw.info

    CG

    #24238
    Avataraintsowyse
    Member
    • Total Post: 19
    • Regular Joe
    • ★★

    Hi,

    Have not been able to locate an files for download, besides WDM related,

    Any ideas where I can find these?

    Thanks,

    #24239
    Avataraintsowyse
    Member
    • Total Post: 19
    • Regular Joe
    • ★★

    I have downloaded the addons file from wyse, and it contains the following file that i think may be the ftp image-

    wyse-ubnt-img-upgrade_1.0.0-1.028_armel

    if so, can anyone advise how to configure the ini file to pull this?

    thanks

    #24241
    ConfGenConfGen
    Keymaster
    • Total Post: 9810
    • Jedi Master
    • ★★★★★★★

    Good finding.
    Yes, this should do it.
    Copy the file in ftprootwyseaddons (if your wlx.ini is in ftprootwysewlx)
    Create a text file called directory (no extension)
    Copy the full name of the addons in the text file
    Add these two lines to your wlx.ini

    AutoInstallPackagesURL=”ftp://your_ftp_server_address wyse addons”
    NewAddons=wyse-ubnt-img-upgrade_1.0.0-1.028_armel.deb

    Reboot the client

    CG

    #24242
    Avataraintsowyse
    Member
    • Total Post: 19
    • Regular Joe
    • ★★

    hi,

    still not working, i have

    copied the file ubnt-img-upgrade_1.0.0-1.028_armel.deb to ftproot/wyse/addons/

    created txt file called directory and put a line in there with just ubnt-img-upgrade_1.0.0-1.028_armel.deb

    added the below two lines to my ini file-

    AutoInstallPackagesUrl=ftp://x.x.x.x/Wyse/addons
    NewAddons=wyse-ubnt-img-upgrade_1.0.0-1.028_armel.deb

    rebooted client,

    any ideas?

    thanks

    #24244
    ConfGenConfGen
    Keymaster
    • Total Post: 9810
    • Jedi Master
    • ★★★★★★★

    This line is wrong

    AutoInstallPackagesUrl=ftp://x.x.x.x/Wyse/addons

    Compare with mine. No backslashes!!

    CG

    #24246
    Avataraintsowyse
    Member
    • Total Post: 19
    • Regular Joe
    • ★★

    HI,

    have changed to

    AutoInstallPackagesURL=ftp://x.x.x.x Wyse addons

    still no effect, any further suggestions?

    thanks

    #24249
    ConfGenConfGen
    Keymaster
    • Total Post: 9810
    • Jedi Master
    • ★★★★★★★

    Where is your wlx.ini file?

    CG

    #24250
    Avataraintsowyse
    Member
    • Total Post: 19
    • Regular Joe
    • ★★

    since i am testing this out, i have a specific file for my test t50, which sits in;

    ftprootwysewlx

    this file works as i can set other options, and they get picked up.

    what are your thoughts?

    thanks

    #24251
    Avataraintsowyse
    Member
    • Total Post: 19
    • Regular Joe
    • ★★

    got this working, the correct format is-

    AutoInstallPackagesUrl=ftp://x.x.x.x/Wyse/addons/

    i didnt have the / after addons when i tried initially,

    after performing the upgrade, you are always prompted to do a login manually, even if the ini says autologin,

    do you know how we can prevent this initial manul login? as ideally doing a large scale upgrade we dont want to have to login on each one,

    thanks

Viewing 15 posts - 1 through 15 (of 19 total)
  • You must be logged in to reply to this topic.