Stop Citrix from disconnecting due to inactivity

  • This topic is empty.
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #2942
    nddearth
    Member
    • Total Post: 8
    • Newbie

    Looking for a solution where the Citrix idle time can be reset from the terminal via a log on script or addon or whatever!

    I have some S30s with large monitors that display critical data. The citrix farm is schedule to disconnect devices after 90 minutes of inactvity and this is causing issues.

    An interim solution has been to silo out a small number of citrix blades and not have the disconnect happen, but it not the desirable long term solution.

    Any ideas?

    thx.

    #16054
    ConfGen
    Keymaster
    • Total Post: 11340
    • Jedi Master
    • ★★★★★★★

    Looks like you are searching for a way to simulate a mouse movement to reset the idle time, correct?
    What about a Citrix policy to exclude these monitoring units from the idle time policy?

    CG

    #16065
    nddearth
    Member
    • Total Post: 8
    • Newbie

    To answer your question, yes we are trying to simulate a mouse movement or a key stroke. But using a command from a sendkey application via a logon script has proven unsuccessful. Citrix still thinks the client is idle.

    I will ask out Citrix team about your second question, though they came up with the entire separate farm idea so the exclusion policy doesn’t seem likely.

    #16082
    ConfGen
    Keymaster
    • Total Post: 11340
    • Jedi Master
    • ★★★★★★★

    I do not see the need for a new farm. One policy should be enough.

    CG

    #16121
    ConfGen
    Keymaster
    • Total Post: 11340
    • Jedi Master
    • ★★★★★★★

    What you can try is to change the idle timeout directly on ICA listener (MS Terminal Services Configuration console) and then assign the kiosk systems to that server
    Not that nice, but maybe a solution. I haven’t tried that myself but the local setting should have a higher priority as the farm setting.

    If this does not work a second farm is needed as idle timeout cannot be set via policy (as I found out). So, my first thought will not work. 🙁

    CG

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.