Sporadic DHCP Problem. Request goes out as BootP.

  • This topic is empty.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #6889
    AvatarSDuke
    Member
    • Total Post: 1
    • Newbie

    We have a sporadic DHCP problem with our V10L machines. I have placed wireshark at both the dhcp server subnet and the wyse client subnets. Is see DHCP discover from the Term, DHCP Offer from the Server, but I don’t see a DHCP request coming back from the Term. Instead I see a Bootp request. Since it is BootP the DHCP server does not respond and the terminal does not get an assigned Address. This is happening with both Wired and Wireless connections on the V10L.

    WYSE Firmware v. 6.4.0_24
    This only occurs on our V10L’s

    Here’s what we’ve know.
    1. Factory reset doesn’t fix it.
    2. Turning off Network Boot in the BIOS doesn’t work.
    3. Other Devices at the Site don’t have this problem. Including Windows Desktops, Wyse 1200LE, and Wyse S10, printers, etc.
    4. Turning off Portfast on the Switches hasn’t resolved this.
    5. We upgraded our DHCP server from Windows 2003 to 2008 R2 in an attempt to fix the issue.
    6 We saw this problem on previous Wyse Firmware and updated to 6.4.0_24

    Any help would be appreciated.

    Thank you.

    #21222
    ConfGenConfGen
    Keymaster
    • Total Post: 11109
    • Jedi Master
    • ★★★★★★★

    This could happen when Portfast is disabled. You should enable it again.
    Other than that you should consider upgrading the firmware to the latest 7.1 code as there you can disable Bootp request via wnos.ini.

    CG

    #21466
    Avatarsanguire
    Member
    • Total Post: 4
    • Newbie

    I am a colleague of SDuke. We have upgraded to the latest 7.1 Firmware. We have also completely disabled spanning tree protocol (which means that there is no need for portfast because the switch interface stays open). We have also added the wnos.ini option to disable BootP. We have also added the KeepDHCPRequestIP=yes option as well as the TCPTimeOut=2 option. None of these appear to resolve the issue. The problem seems to be exacerbated across WAN connections with Latencies > 10ms. However, at these same sites, our S10 devices have no issues at all. Any suggestions would be greatly appreciated.

    Thank you.

    #21565
    Avatarjahos
    Member
    • Total Post: 2
    • Newbie

    Hello,
    Have you been able to resolve this?
    I have exactly the same issue.
    portfast enabled, even spanning tree disabled, TCPTimeout set to 2 . Nothing helps. Thin clients send out bootp request.

    regards

    #21567
    Avatarjahos
    Member
    • Total Post: 2
    • Newbie

    Ok, resolved it myself.
    arp cache timeout on cisco router changed from 4 hours to 10 secs. Now all V10LE thin clients always get an ip address.

    Jan

    #21756
    Avatarnickb_2010
    Participant
    • Total Post: 9
    • Regular Joe
    • ★★

    I solved this problem by amending the DHCP server. We use a Windows 2003 DHCP Server and by default it’s set to BOOTP/DHCP. If open the properties of the scope in DHCP snap-in, then select advanced, you will options for DHCP only, BOOTP only or Both. It’s set to BOTH by default. Change this to DHCP and WTOS devices will connect by DHCP.

    Hope this helps

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.