SmartCard redirection not working in RDP Direct connection ThinOS 9.1

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #104969
    PeterPeter
    Participant
    • Total Post: 13
    • Regular Joe
    • ★★

    We have setup a new RDP Server Running Windows TS 2019 and I have setup in WMS to use RDP Direct connection collection to connect directly to the server. Connecting to the server from Windows 10 IOT works fine and the SmartCard is redirected, but using ThinOS 9.1 and RDP Direct connection collection does not redirect the SmartCard at all. I have double checked that the “Map SmartCard” option is on (and have tried to shut it of as well). I can see the certificate in the SmartCard part of ThinOS, so I know that the unit can read the card. What is wrong?

    #104985
    ConfGenConfGen
    Keymaster
    • Total Post: 11287
    • Jedi Master
    • ★★★★★★★

    Have you tried USB redirection?

    CG

    #105107
    PeterPeter
    Participant
    • Total Post: 13
    • Regular Joe
    • ★★

    Yes, I tried to redirect the smart card manually without success. The clients smart cards work fine in Citrix, but when I connect with RDP to the same server it does not work. I upgraded to the latest release of both ThinOS and WVD-packages released yesterday, but it did not fix the issue. Trying smart card authentication to the AD also works fine with the Citrix broker, but when changed to the RDS-broker I just get a login error with the smart cards. And after password authentication the cards are not redirected to the session.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.