Scanners on C10LE redirected via TCX on PS4+

  • This topic is empty.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #6310
    tdilbert
    Participant
    • Total Post: 4
    • Newbie

    I have a client that is a full Citrix setup on Presentation Server 4.5 (Windows 2003) using Wyse C10LE thin clients.

    They would like to redirect locally connected USB scanners (fi-6140dj) via TCX. Yesterday I installed TCX Server 4.0.121 on their Citrix server but found that only the first scanner redirected by TCX would show up under “Scanners and Cameras”.

    So if User B tried to scan a document, rather than using the scanner connected to his Wyse Terminal, Windows would look for the scanner connected to User A’s Wyse terminal because he was the first person to have a USB scanner redirect via TCX.

    Anyone else experience anything like this?

    #19657
    ConfGen
    Keymaster
    • Total Post: 11417
    • Jedi Master
    • ★★★★★★★

    In a PS environment there is no session security. This means that every device that has been attached to the server can be seen by every user on this server.
    Therefore it is not recommended to use TCX USB redirection on PS.
    This will work great in a XenDesktop or View environment.

    CG

    #19658
    tdilbert
    Participant
    • Total Post: 4
    • Newbie

    @ConfGen wrote:

    In a PS environment there is no session security. This means that every device that has been attached to the server can be seen by every user on this server.
    Therefore it is not recommended to use TCX USB redirection on PS.
    This will work great in a XenDesktop or View environment.

    CG

    See that’s the thing I can’t seem to wrap my head around.

    I can understand that everyone would be able to see each other’s scanners if they are redirected via TCX on PS4, but I would have thought that in this circumstance it would just add an additional device under “Scanners and Cameras”. So it would be something like;

    fi-6140dj or “user1 fi-6140dj”
    fi-6140dj(1) or “user2 fi-6140dj”
    fi-6140dj(2) or “user3 fi-6140dj”

    I’m finding that it’s redirecting all the scanners (if you look under “Device Manager”) but it is only showing one scanner under “Scanners and Camera”. That just doesn’t seem right to me… something is going wrong here.

    #19753
    tdilbert
    Participant
    • Total Post: 4
    • Newbie

    Anyone else had this problem? Any resolutions?

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.