S30 re-imaging problem

  • This topic is empty.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #584
    Avatarmxxx
    Member
    • Total Post: 4
    • Newbie
    • β˜…

    Hi,
    I’ve got an S30 with what appears to be a corrupt image (it displays the splash screen with a big gap across the middle and wont boot past that point) so i’m trying to re-image it. I’ve never done this before but i’ve been reading the guides here and on the Wyse website and they’ve been very helpful.

    I’ve got an XP pro laptop with firewall and AV disabled, i’ve installed DHCP turbo and IIS, configured the FTP settings as per the guide on the WYSE website, setup the DHCP scope (again as per the guide on the WYSE website) and run WSI using the image I downloaded from Wyse website.
    I’ve setup an IP of 10.0.0.12 on the laptop and connected via a crossover cable, when the terminal boots it picks up an ip (10.0.0.13) from the DHCP server and shows a proxy address(i dont know what this means)
    of 127.0.0.1
    It then says ‘rapport’ followed by
    UD 127.0.0.1
    then it says ARP Timeout a few times and carrys on trying to boot.

    These messages suggest its trying to update on 127.0.0.1 (a loopback address). Please correct me if i’m wrong because i’m new to this.
    If that is whats happening, what have I done wrong?

    I have connected another machine to the laptop and am able to connect to the FTP server. initially it wouldnt connect on port 69 (that TFTPD32 was listening on) but when I changed the port in the IIS FTP Server settings from 21 to 69 it then connected ok.
    Please help as im confused and cant find any answers elsewhere πŸ˜•

    #10145
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • β˜…β˜…β˜…β˜…β˜…β˜…

    Hi,

    I think you almost have it! Change the ftp port back to 21.

    Try plugging in the crossover cable with the unit plugged in (so the the NIC is active). I think when you installed WSI the NIC was down so it picked up the loopback address. Unistall WSI (not DHCP turbo) and install again.

    When you set up the job check TFTP32.exe which shold open and have 10.1.1.12 as the ip it is listening on,

    Cheers,
    -TT

    #10146
    Avatarmxxx
    Member
    • Total Post: 4
    • Newbie
    • β˜…

    Hi TT,
    Thanks, you really know your stuff. I did as you said and reinstalled WSI with the S30 plugged in and its now communicating with TFTP32.exe

    Unfortunately, i’ve hit another stumbling block as it tries to update and fails with a message on the log screen of WSI saying ‘Failed – Firmware is not compatible’.
    I’ve tried it with both the latest and one previous version of the firmware that are available on the WYSE site but keep getting this. Does this really mean the firmware is not compatible or could I be doing something wrong.
    I dont have the .bin file in the inetpub folder its in the root of the C drive but I dont know if this makes any difference. Also there are 2 .bin files with the firmware, one says FTP the other says PXE, im using the PXE one, is this right?

    Finally, when setting up WSI it asks for a ‘flash size’ parameter, does it matter what I put in here?

    #10147
    Avatarmxxx
    Member
    • Total Post: 4
    • Newbie
    • β˜…

    Hi TT,
    Not to worry, i’ve managed to get it to work. I found another post in the WDM section relating to the same problem, to fix it I just changed the =YES to NO in the push.i2c file and hey presto, image went down lovely and the terminal is now fully operational.
    Thanks, your site has been invaluable! πŸ˜€

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.