S10 – Omnykey CardMan 3121 – Citrix

  • This topic is empty.
Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #3438
    AGO
    Participant
    • Total Post: 7
    • Newbie

    Hi guys …

    I know i’m missing something here but i dunno where to begin really o.O I’m using Wyse S10 Clients with WTOSv6.4.0_06 (also tested with 6.3.0_12 and 6.2.0_27) and shared Desktops from a citrix presentation server 4.0 environment.

    We use a software that is in need of reading SmartCards from an omnikey cardman 3121 usb reader. We do not use’m for login credentials or something like that, this cards are used for logging data from our cars and trucks and the software (running in a citrix session) need to access the reader but no success so far.

    The reader is recognized as CCID reader when the s10 starts, when i plug a card in i see that the client try to login with the cards data .. so i think everything is working to this point. Then – when i’m logged in – the CardReader don’t show up in the OmniKey Diagnostic Tool an no Connection to the reader is possible.

    Is there a chance at all to get this working? Or are this cardreaders only useable for login scenarios?

    .. the wnos.ini:

    autoload=2
    EnableLocal=yes
    AdminMode=yes Admin-Username=**** Admin-Password=****
    Privilege=Low Lockdown=yes HideSysInfo=yes HidePPP=yes HidePN=yes HideConnectionManager=yes
    FormURL=logo.gif
    Device=Audio Volume=0 Mute=Yes
    AutoSignoff=yes Shutdown=yes
    Shutdowncounter=10
    AddCertificate=root_****.crt
    FixLicense=clean
    Language=De
    Device=Keyboard NumLockOff=yes
    Resolution=1280x1024 Refresh=60
    DeskColor="0 0 64"
    DesktopColorDepth=32
    Screensaver="120"
    ShutDownInfo=yes
    Timeserver=ntplocal Timeformat="24-hour format" Dateformat=dd/mm/yyyy
    TimeZone='GMT + 01:00' ManualOverride=yes
    Device=Ethernet Speed="100M FD"
    HideIP=yes
    #LowBand=yes
    SignOn=Yes HideConnectionManager=Yes EnableOK=Yes DisableGuest=yes LastUsername=yes
    DisableDomain=no
    DomainList=****
    #RegisterWINS=yes
    SessionConfig=ALL UnmapPrinters=no UnmapSerials=no Smartcards=yes MapDisks=yes DisableSound=yes UnmapUSB=yes
    IcaBrowsing=http
    SessionConfig=ICA DesktopMode=Fullscreen SessionReliability=yes DiskMapTo=E
    Seamless=yes FullscreenReserved=yes
    PnliteServer=citrix.******.com ReconnectAtLogon=1 ReconnectFromButton=1 #AutoConnectList="DESKTOP_*****"
    Alternate=yes

    .. by the way, usb sticks working fine. so there is no problem with citrix policies i think …

    It’s working with RDP but not with Citrix, what did i missed!?

    #16229
    ConfGen
    Keymaster
    • Total Post: 11417
    • Jedi Master
    • ★★★★★★★

    The thing with smartcards is, that they are only the PC/SC port is mapped in the session. Therefore the Onmikey tool is not able to see the reader.
    But you should be able to contact the reader via PC/SC from your application (if your app supports that).

    You wrote it is working fine via RDP? Then check out this
    http://support.citrix.com/article/CTX113731

    CG

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.