S10 ftp configuration

  • This topic is empty.
Viewing 15 posts - 1 through 15 (of 19 total)
  • Author
    Posts
  • #891
    Avatarnath_e
    Member
    • Total Post: 30
    • Frequent Flyer
    • ★★★

    Hi,

    I’m trying to setup a winterm to talk to ftp server but keep getting error ‘cannot access system profile’

    The ftp server is on a linux box, roothomeftpwysewnos

    I am unsure what I need to put in the file server box though.

    We use dhcp normally but for testing this winterm I have configured a static ip address but still cannot get the above error when contacting the file server.

    Please help!

    Thanks

    #11510
    ConfGenConfGen
    Keymaster
    • Total Post: 10968
    • Jedi Master
    • ★★★★★★★

    Hi,

    what folder the client looks in depends on the FTP users root path and the string you enter as Fileserver on the client.
    Let’s use a anonymous user which has root/ftp/home as his ftproot folder.
    In this case you have to enter as a fileserver: IPaddresswyse

    The folder /wnos you are using is appended automatically by the client.

    HTH
    CG

    #11511
    Avatarnath_e
    Member
    • Total Post: 30
    • Frequent Flyer
    • ★★★

    Ok, now it still says cannot access system profile, but then underneath it says ‘checkling software ftp:wnos/RCA_wnos …’ but nothing else happens.

    I don’t have a copy of the of software there though does that matter?

    As it still says cannot access system profile does this mean I am not getting any further?

    I’m wondering if the ftp share is in the incorrect location on the server?

    Also, does it matter if I am using DHCP but haven’t configured anything on DHCP yet? I don’t want to chang DHCP yet as I am juist playing with one winterm, rather than break them all!

    #11512
    ConfGenConfGen
    Keymaster
    • Total Post: 10968
    • Jedi Master
    • ★★★★★★★

    I can answer all your questions with NO.
    The next step would be to look in the FTP logs. This will show you which directory the client is looking in.
    Or use a network sniffer to get the same info.
    RCA_wnos is, btw, the firmware. If you will get a newer fw once you can just drop it in the same folder and the unit will autoupgrade itself.

    #11526
    Avatarnath_e
    Member
    • Total Post: 30
    • Frequent Flyer
    • ★★★

    Ok, I’m see this in the ftp log.

    “RETR /wyse/wnos/wnos.ini”
    Client “[ip address]”, “550 Failed to open file.”

    It sounds like a permission problem, but not sure how as anonymous user has access to overwrite files.

    #11527
    Avatarnath_e
    Member
    • Total Post: 30
    • Frequent Flyer
    • ★★★

    I can read the file now. The directory on the server was wrong. the wnos.ini file was under wyse/wnos/ini/ but I’ve moved the wnos.ino file to thw wnos folder and it now works.

    Now I have a different problem. I have to sign on as a guest first but I don’t want to. I want it to auto connect to the rdp connection. How do I get it do this. I’ve downloaed the config generator but it doesn’t work for me :- (

    My wnos.ini file says:
    privilege=1
    resolution=1280×1024
    CONNECT=RDP
    Host=mullet.sks.xbridge.com
    Description=”Simply Business (Mullet)”
    AutoConnect=yes
    Fullscreen=yes
    Experience=0
    Domainname=NCC
    LocalCopy=no

    AutoSignoff=yes Shutdown=yes
    Shutdowncounter=1

    #11528
    Avatarnath_e
    Member
    • Total Post: 30
    • Frequent Flyer
    • ★★★

    Don’t worry, I’ve found the command. It’s all good.

    Thanks for your help, I’m sure I’ll be back here very soon!

    #11529
    ConfGenConfGen
    Keymaster
    • Total Post: 10968
    • Jedi Master
    • ★★★★★★★

    Great that your fixed the FTP issue.
    The good thing is that you are using the right tool to create your wnos.ini file.
    The bad think is that you are removing and modifying lines from the generated file.
    Re-add the line SignOn=no and the login window will disappear. Change Privilege=1 to either none, low or high.

    #11530
    Avatarnath_e
    Member
    • Total Post: 30
    • Frequent Flyer
    • ★★★

    The config generator doesn’t work for me. I get an application error every time I try to run it. The data below is what I copied and modified from somewhere else and using the admin guide.

    My file now reads .

    autoload=0
    signOn=no
    privilege=1
    Desktop=Logo.JPG Layout = tile
    [all my rdp conenctions]
    LocalCopy=no
    AutoSignoff=yes Shutdown=yes
    Shutdowncounter=1

    What’s the difference with privilege=high as apposed to privilege=1?

    #11531
    ConfGenConfGen
    Keymaster
    • Total Post: 10968
    • Jedi Master
    • ★★★★★★★

    I don’t think privilege=1 is supported. I only know of none, low and high.

    What error do you get when using ConfGen? Never heard of an error. Please send a screenshot of the error to support @ technicalhelp

    Thanks
    CG

    #11534
    Avatarnath_e
    Member
    • Total Post: 30
    • Frequent Flyer
    • ★★★

    Privilige = high means they can do everything yeah?

    I’ve sent the error details as requested.

    #11543
    ConfGenConfGen
    Keymaster
    • Total Post: 10968
    • Jedi Master
    • ★★★★★★★

    Yes, high means everything. Low=something and none=nothing

    I got your mail. Try to add these settings to the registry. Looks for me, that the tool is not allowed to write to the registry.

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINESOFTWARETechnicalHelp]

    [HKEY_LOCAL_MACHINESOFTWARETechnicalHelpConfGen]
    “Language”=”en-US”

    #11618
    ConfGenConfGen
    Keymaster
    • Total Post: 10968
    • Jedi Master
    • ★★★★★★★

    Hi Nathan,

    have you tested this already?
    Is it working now for you?

    CG

    #11619
    Avatarnath_e
    Member
    • Total Post: 30
    • Frequent Flyer
    • ★★★

    I tried adding the registry changes in HKEY Local machineSoftware but still not working.

    I add the folder TechnicalHelpConfGen then added “Languag”=”en-US” as the data value.

    Still same error.

    #11620
    ConfGenConfGen
    Keymaster
    • Total Post: 10968
    • Jedi Master
    • ★★★★★★★

    – Still the same error message?
    – Are you starting it locally or from a network share?
    – What OS?
    – Are you admin?

Viewing 15 posts - 1 through 15 (of 19 total)
  • You must be logged in to reply to this topic.