Remote Desktop hotkeys

  • This topic is empty.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #6602
    Doug
    Member
    • Total Post: 13
    • Regular Joe
    • ★★

    Does anybody know how to cause the remote desktop client to send the “special keys” to the remote session?

    I have set the “Apply Windows Key combinations” selection to
    – “In full screen mode only” AND
    – “On the remote computer”

    However neither work. I use Alt+Tab extensively and keep getting the thin clients apps rather than the remote session.

    The alternative keystrokes are just a pain when you cross over from thin to fat client.

    Is there something else I should be doing to get this to work?
    I have searched for the better part of two days on this and found several
    other cases where the remote desktop client does everything from not-sending any special keys like me to the exact opposite, not-leaving any special keys local. No useful resolutions anywhere so far.

    I have found that it must use a keyboard hook to grab and forward the keys but cannot get any deeper or more useful information than that. Such as some possible registry settings keeping it from operating,etc..

    Any help would be appreciated.

    #20423
    Doug
    Member
    • Total Post: 13
    • Regular Joe
    • ★★

    Hmm.. Nobody?

    How about this, Does anybody use XP or XPe where this feature does work?

    (Trying to figure out if it is a Wyse or Microsoft issue)

    #20594
    Doug
    Member
    • Total Post: 13
    • Regular Joe
    • ★★

    I tried the Wyse support route. There solution was (of course) to simply upgrade to the newest image which they pointed me at.
    After trying this and failing due to the imager not finding “/dev/sda1” (IDE vs SATA I guess?) they told me the unit was too old. (Wyse v90 Dual video) and out of their service responsibility.

    I decided I didn’t have anything to loose so I backed up the image and started playing with it. Finally managed to “dd” the new image onto the second partition of the flash drive and get it to boot.

    Lo and behold the rdp client worked.

    I did not want to go through that process with all of the thin clients though so I copied the image up to the san on it’s own aoe lvm and set up etherboot gpxe for the thin clients.

    It worked great on the original thin client but subsequent cloning of the lvm seemed to cause multiple issues with the other thin clients.

    I assumed memory issues since the original was 1G and the others are 256Meg so I cut and hacked the startup apps and services till it was down to using ~100MB at rest.

    The original TC was stable but the clones again had issues from the “lsass.exe wrong password” issue before login to random svchost.exe failures after login.

    I then tried the fbreseal process with the same results.

    So I got the initial problem fixed only to land another one.

    I figured while I was hacking I should at least pinpoint the original issue.

    My method was just to start shutting down services until the hot keys stopped responding when in remote session.

    What I found was that the hot keys stopped going to the remote session after the “Terminal Services” Service was stopped.
    This is interesting since this _should_ be “Server” component but somehow the client is using some part of it for the hot key hooks.

    Anyway, I remember an article here some time ago regarding the packaging of the terminal services functionality to replace the vnc server on the V90’s, however I cannot find reference to it anywhere now.
    Does anybody have any pointers?

    I may end up making the rounds to image all the clients manually If I cannot find a way to make the lvm cloning work.

    I just read a article about the temp folder not being big enough for the thin client to install apps correctly and it causing many errors that don’t seem to be related.
    This could possibly be my issue. Need more hours in the day and fewer other responsibilities.

    Hope this helps somebody.
    Thanks for any feedback.

    Doug

    #20596
    Doug
    Member
    • Total Post: 13
    • Regular Joe
    • ★★

    I found the RDP Package it is called “Enable_RDC”.
    I downloaded, extracted to folder, copied to TC, ran the reg file, manually ran the .rsp file commands in a command prompt…

    cd C:WindowsSystem32
    rename remotepg.dl_ remotepg.dll
    regsvr32 /s remotepg.dll

    Closed remote session and opened it again and I now have special keys in the remote session!
    This is on an old wyse image that I have not updated.

    It seems all the files were there on the thin client all along, they were just not enabled/configured.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.