Redirecting a printer to TS session

  • This topic is empty.
Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #7891
    Avatarnmuleski
    Member
    • Total Post: 8
    • Newbie

    We have a R10L ThinOS device that has a HP LaserJet 1022 printer plugged into it. I have setup the printer in the global INI as follows:

    Printer=LPT1 Name=”HP LaserJet 1022″ PrinterID=”HP LaserJet 1022″ Class=”TXT” Enabled=yes EnableLPD=no

    The client connects to a Server 2008 R2 farm and uses the TCX suite for redirection.

    The problem is that I cannot get the printer to show up as a redirected printer. I have to manually add the printer (using LPT1 as the port) as a device before I can print to it. Once I do that it prints fine.

    How can I avoid having to setup the printer and just have it redirect when I log on?

    #23964
    ConfGenConfGen
    Keymaster
    • Total Post: 9812
    • Jedi Master
    • ★★★★★★★

    Make sure the value for PrinterIdentification is exactly the same as the printer driver name that has been installed on the TS Server.
    That way the printer is autocreated. No TCX is needed for that.

    CG

    #23980
    Avatarnmuleski
    Member
    • Total Post: 8
    • Newbie

    That was the issue, once I changed the printer id it redirected automatically. Thanks!

    #24032
    AvatarHybridUK
    Member
    • Total Post: 9
    • Regular Joe
    • ★★

    Hi, sorry to jump in on this, but I too am facing the exact same issue with locally attached HP 1022’s.

    My config shows:

    Device=usbprinter AlwaysOnline=yes
    Printer=LPT1 Name=”HP1022″ PrinterID=”HP1022″ Class=”PCL5″ Enabled=yes

    yet in the RDP session, the printer isn’t showing….

    Any pointers at all guys?

    Many thanks

    #24033
    Avatarnmuleski
    Member
    • Total Post: 8
    • Newbie

    I have to use Class=”TXT” in my INI file. I use a PCL5e driver on the server but the only way it works is with Class=”TXT”

    Also, like ConfGen suggested, make sure your PrinterID= portion is EXACTLY the same as the print driver name.

    Other things to check:
    -Is there a GPO disabling redirected printers?
    -Do you have the proper drivers installed on the servers? I’ve found that universal drivers don’t work well with the Wyse TOS devices.

    #24034
    AvatarHybridUK
    Member
    • Total Post: 9
    • Regular Joe
    • ★★

    Thanks for your quick response.

    I have changed the line to say:

    ;*************************************************************
    ;* Printing *
    ;*************************************************************

    Device=usbprinter AlwaysOnline=yes
    Printer=LPT1 Name=”HP LaserJet 1022″ PrinterID=”HP LaserJet 1022″ Class=”TXT” Enabled=yes EnableLPD=yes

    ;*************************************************************
    ;* General Session *
    ;*************************************************************

    SessionConfig=ALL UnmapPrinters=no MapDisks=yes
    Reconnect=yes

    However it still won’t map the map.

    I don’t have any GPO’s disabling this from working so i’m a little confuzzeled. The server is running Windows 2008 r2 and I have put the drivers into Printer Management drivers pool on the server. The driver name is HP LaserJet 1022 so i’ve put that as the printerID. Is this correct, or do I need to use the path of the .inf file in here instead?

    Thanks for the help and support. Muchly appreciated.

    #24035
    Avatarnmuleski
    Member
    • Total Post: 8
    • Newbie

    Just to be sure, this is text you need in the PrinterID field:

    #24036
    AvatarHybridUK
    Member
    • Total Post: 9
    • Regular Joe
    • ★★

    I’ve actually managed to get the printer to map now. The issue I have now is as soon as I print to it, it errors out.

    nmuleski – would you mind pasting in the line of code you ended up using please?

    I can get another printer to work fine using LPD queues, but not a 1022 locally attached. I can see the printer is picking up the drivers too as the features are all there when I go to printer properties.

    #24037
    Avatarnmuleski
    Member
    • Total Post: 8
    • Newbie

    Here is the line in my INI:

    Printer=LPT1 Name=”HP LaserJet 1022″ PrinterID=”HP LaserJet 1020″ Class=”TXT” Enabled=yes EnableLPD=no

    #24038
    AvatarHybridUK
    Member
    • Total Post: 9
    • Regular Joe
    • ★★

    Ah, I guess you must be using a different driver to what I am for the 1022.

    I’ve just installed the 1020 driver across to see what happens as per your line, but this too fails on printing. 🙁

    Long shot, but would you still happen to have the drivers you used at all?

    I have a load of offices with these printers but will end up being pretty useless if I cannot get them to go.

    #24039
    Avatarnmuleski
    Member
    • Total Post: 8
    • Newbie

    Are you running Server 2008 R2?

    #24040
    AvatarHybridUK
    Member
    • Total Post: 9
    • Regular Joe
    • ★★

    Hi, yes it’s running server 2008 r2. Any other pointers would be great or if you have your drivers handy, even better.

    #24041
    Avatarnmuleski
    Member
    • Total Post: 8
    • Newbie

    I have the drivers if you have Dropbox account or something I can upload them to.

    #24042
    AvatarHybridUK
    Member
    • Total Post: 9
    • Regular Joe
    • ★★

    Hi yes, I have a dropbox account. Could you PM me your e-mail address and i’ll set you up a share.

    Or an e-mail if it’s easier? I think the last set I downloaded was only 3MB.

    Appreciate your time. 🙂

    #24043
    AvatarHybridUK
    Member
    • Total Post: 9
    • Regular Joe
    • ★★

    wow – I’ve managed to get it to work. I added the HP 1020 driver and used your line. I also removed the LPD queues I had in there too.

    Many thanks for your help nmuleski. Muchly appreciated.

Viewing 15 posts - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.