Reboot issue ThinOS

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #53028
    AvatarRobaHelpdesk
    Participant
    • Total Post: 4
    • Newbie

    Hi We experience multiple reboots due to the reboot parameter in ThinOS.

    Checked also the latest and greatest version 8.6_421 but problem still exists;

     

    We have a standard INI file containing;

    Reboot=yes time=2:00

    No problems here, all TC are rebooting at 2:00 at night…

    If we add Reboot=yes time=12:00 in a custom (mac address) INI file we end up with 2 reboots…

    first reboot at 2:00 and second at 12:00

    I don’t want that! I want to overrule the first schedule, not add the sond one…

    If I add to the custom (mac address) INI file;

    Reboot=no

    Reboot=yes Time 12:00

     

    It still reboots twice. The “reboot=no” doesn’t seem to have any effect…

     

    How to end up with one reboot time and overruling the reboot time in the standard wnso.ini?

     

    Any suggestions are welcome.

     

     

     

     

     

    #53029
    ConfGenConfGen
    Keymaster
    • Total Post: 9723
    • Jedi Master
    • ★★★★★★★

    Easy to solve.
    Move the Include=$mac parameter in your wnos.ini one line above the Reboot parameter. Best would be then if the Reboot parameter is the last one in your wnos.ini.
    Add Exit=all as the last line in your Mac.ini.
    That way the INI parser with stop reading the wnos.ini before reading the Reboot parameter and does not jump back to your wnos.ini after reading the Mac.ini.

    CG

    #53030
    AvatarRobaHelpdesk
    Participant
    • Total Post: 4
    • Newbie

    Thanks, that did the trick indeed…

     

    With this solution I also had to add the “Reboot=Yes Time=2:00” to all exception/custom INI files because of the “Exit=All”…

    Notepad++ is also my friend 😉

     

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.