Read only USB access

  • This topic is empty.
Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #946
    AvataraLiE
    Participant
    • Total Post: 320
    • Jacked into The Matrix
    • ★★★★★★

    To make a long story short, is it possible to have read only access to any USB devices connected on a V10L/S10 etc. all WTOS oriented terminals ?

    I have contacted Wyse already about this and i thought to put this on the forum and see if anyone got an idea. Wyse says it isn’t possible but working on a solution, so untill then all users with an S10/V10L have full access to any USB device connected.

    As i’m still contacted with Wyse about this i will contineu to post any news regarding this.

    I hope i don’t need to tell you guys why i want this option available 🙂

    #11769
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Hehe, OK don’t tell us 🙂

    Are you using Citrix, maybe you could do this server side? I know Linux has this option but WTOS is only on or off for the mapping,

    Cheers,
    -TT

    #11777
    AvataraLiE
    Participant
    • Total Post: 320
    • Jacked into The Matrix
    • ★★★★★★

    Yeah we are using Windows 2003 + Citrix Metaframe 4.5 and there is an windows policy for citrix client but this only applies to windows client …. so this will not work for WTOS.
    And indeed we are talking here about the client drive mapping, using the policy you can force all client drive maps tobe read only.

    story continue’s

    #11781
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Hi,

    Now I have not tested but the Citrix Policies apply to the ICA connection and this would be independent of the ICA client. (well so I would have thought!)

    So you tested the policy on a WTOS and the drive is not read only with it enabled?

    Cheers,
    -TT

    #11787
    AvataraLiE
    Participant
    • Total Post: 320
    • Jacked into The Matrix
    • ★★★★★★

    @thinkthin wrote:

    Now I have not tested but the Citrix Policies apply to the ICA connection and this would be independent of the ICA client. (well so I would have thought!)

    So you tested the policy on a WTOS and the drive is not read only with it enabled?

    Yup we did, and the policy only applied to windows PC/Laptop etc. and when you log on the server using a WTOS terminals USB was writable. The thing is we do not use the onboard pnagent from WTOS.
    If you turnon the terminal it will connect to a server (citrix load balance will take care off the load) and you will see the login window and able to login.

    #11909
    AvataraLiE
    Participant
    • Total Post: 320
    • Jacked into The Matrix
    • ★★★★★★

    Good news regarding read only access for mass storage device using WTOS, can’t tell you guys more but this is coming soon.

    will update my post when i have more info

    #11919
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Cool, will look forward to it! Thanks for keeping us updated!

    #12409
    AvataraLiE
    Participant
    • Total Post: 320
    • Jacked into The Matrix
    • ★★★★★★

    It looks like all beta tests have been done now and we could see this option soon in the upcoming firmware updates. From what i have seen you are able to set this option using the wnos ini and also using the gui.

    Just a small and final update

    #12775
    AvataraLiE
    Participant
    • Total Post: 320
    • Jacked into The Matrix
    • ★★★★★★

    As from firmware version 6.1.0.11 (V10L/S10) this option is available now.

    #12780
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Awesome, thanks so much for updating the thread!

    #12792
    ConfGenConfGen
    Keymaster
    • Total Post: 11110
    • Jedi Master
    • ★★★★★★★

    And this is the ini parameter:

    SessionConfig=ALL MapDisks=yes DisksReadOnly=yes

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.