Rapport Configuration Manager – Update Request

  • This topic is empty.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #216
    Avatartjsel
    Member
    • Total Post: 23
    • Regular Joe
    • ★★

    Hi All,

    I am evaluating WDM4.5 and my test term is a V90. When sending a package to my V90 with the write filter enabled, I noticed that it pops up that message regarding the update request (with update now and delay options). After I hit update now, it restarts, then upon logging in again the same message pops up this time with the options is specified in my script (update now only).

    Is there a way to set the initial Update request buttons and time?

    #8896
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Hi Tjsel,

    Have a look at the Rapport Script help file here:

    http://www.freewysemonkeys.com/site/modules.php?name=Downloads&d_op=viewdownloaddetails&lid=40&ttitle=Rapport_441_Script_Language_Help_File.zip

    The command you are looking for is the QU (Query User) it supports a number of options and time out settings. This command cuses the popup box. Normally its followed by a LU (lock User) which brings up the splash screen warning a job is on progress.

    You can configure the splash screen from options in the hagent directoty on the client,

    Cheers,
    -TT

    #8898
    Avatartjsel
    Member
    • Total Post: 23
    • Regular Joe
    • ★★

    Thanks for the reply

    I used QU in my script. My problem is that the Update Request Box shows twice (only when write filter is enabled). The first time it pops up it has the update now and delay buttons. From here I click the update now button and the v90 restarts. After it boots back up, I login, and then I am presented with the same Update Request Box this time with the buttons and time out I specified. How do I go about changing the specifications on that first box?

    Here is my script:

    [Version]
    Number=ChangeAdminPass
    Description=Changes administrator password
    OS=XP
    Category=Other Packages

    [Script]
    CO “XP”
    QU “1” “60”
    LU*
    EX “Net User Administrator password”
    EL*

    #8901
    Avatarkaraziel
    Member
    • Total Post: 74
    • Back Stage Pass
    • ★★★★

    There is an additional process that runs to manage WriteFilter

    It has its own QU command built in.
    There’s no easy way to modify it

    #8903
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Hi Karaziel,

    If you alter the global setting in under the Rapport-Configuration Manager-Preferances-Scheduling for the Default Query Buttons will this work around the issue? I have not tried this…

    #8904
    Avatartjsel
    Member
    • Total Post: 23
    • Regular Joe
    • ★★

    @thinkthin wrote:

    Hi Karaziel,

    If you alter the global setting in under the Rapport-Configuration Manager-Preferances-Scheduling for the Default Query Buttons will this work around the issue? I have not tried this…

    I tried to set the global settings but it does not apply to the write filter process, just the script.

    There is an additional process that runs to manage WriteFilter

    It has its own QU command built in.
    There’s no easy way to modify it

    Bummer… If you guys are able to find out any more info on this subject please let me know! I will be frequenting this site as I am about to rollout 500+ v90’s!

    Thanks!

    #8906
    Avatarkaraziel
    Member
    • Total Post: 74
    • Back Stage Pass
    • ★★★★

    The global only affects scripts where the timeout isn’t specific

    e.g.:

    ;This command will follow global value
    QU
    ;This command will use the specified value
    QU “120”

    I think the write filter process has 120 specified which is why it doesn’t change
    I’ll see if there’s an easy way to change that that in the DB.

    -k

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.