R50LE Configuration – WLX.INI

  • This topic is empty.
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #6055
    Avatarstibman63
    Member
    • Total Post: 1
    • Newbie

    We are looking for assistance in configuring the Remote Desktop (Sharing) functionality with the Wyse Enhanced SUSE Linux Enterprise software, version 11.0.121. We are using the ftp method to standardize our configuration of these devices via the WLX.INI file. We have been able to get the TZ, Autologin, and Autoconnect to a Citrix XenApp published desktop to work, but we are having trouble configuring the Remote Desktop (Sharing) parameters. We are using the confgen tool to create the file, and here is our file so far:


    ;*************************************************************
    ;* *
    ;* This wlx.ini file was generated with the *
    ;* Configuration File Generator 6.0.05 *
    ;* Copyright by Thomas Moellerbernd *
    ;* *
    ;* http://www.technicalhelp.de *
    ;* *
    ;*************************************************************

    Rapportserver=ply03252
    EnableGKey=yes
    PowerButtonAction=shutdown
    Update.Preserve_changes=yes
    EnableNMapplet=yes
    Autopower=yes
    Bootorder=UHN

    ;*************************************************************
    ;* Time *
    ;*************************************************************

    Timeserver=172.16.20.55
    Timeformat=”24-hour format”
    TimeZone=”US/Pacific” ManualOverride=1

    ;*************************************************************
    ;* Network *
    ;***********************************************************

    Autologin=yes
    DefaultUser=admin

    ; If you are using an older version of SUSE code please use:
    ; VncPasswd=clear_text Password

    VncPasswd=lFQx8SZjS9rZ.
    ; If you are using an older version of SUSE code please use:
    ; UsePasswd=yes

    VNCAuthTypes=vnc
    VncPrompt=yes

    ;*************************************************************
    ;* ICA *
    ;*************************************************************

    MPServer=ply0347.internal.sargento.com
    Seamless=no

    ;


    ;- ICA Session 1 –
    ;- Each line but the last must end with a ‘ ‘ –
    ;



    CONNECT=ICA
    MPServer=ply0347.internal.sargento.com
    Application=”Portionables Desktop”
    Description=”Sargento Desktop”
    AutoConnect=yes
    Fullscreen=no
    Resolution=default
    Reconnect=no
    Domainname=SARGENTO
    LowBand=yes
    IcaEnhancedAudio=yes
    IcaMultiMedia=yes
    LocalCopy=no



    For whatever reason, the settings under the “Network” secion of the wlx.ini file for VNC configuration, do not work. We are looking for some assiistance or direction as to whether it is possible to configure the Remote Desktop Prefernces via the wlx.ini? And if so, what are we missing in our file? Thanks for your assistance.

    #18736
    ConfGenConfGen
    Keymaster
    • Total Post: 9902
    • Jedi Master
    • ★★★★★★★

    Can you test and add
    DisableVNC=no
    to your wlx.ini?

    CG

    #20291
    AvatarWYSEGUY66
    Member
    • Total Post: 14
    • Regular Joe
    • ★★

    This is what Wyse told me on the R50L:

    On the R50 devices, VNC is disabled by default. To enable it, open the control center and click the remote desktop icon. See page 47 (actually page 38 in the doc) of the attached admin guide.

    he’s telling me that this needs to be enabled

    Setting Remote Desktop Preferences for Shadowing
    Clicking the Remote Desktop icon in the Control Center opens the Remote Desktop
    Preferences dialog box. Use this dialog box to select general (sharing and security) and
    advanced (network, security, and notification) preferences for use with remote
    administration (see “Using TightVNC to Shadow a Thin Client”) For example, you can set
    the Security Password (the password an administrator needs to use when shadowing the
    thin client) on the General tab

    I have not tested this as of yet, but if need be how can we enable it using the wlx.ini file.

    #20292
    AvatarWYSEGUY66
    Member
    • Total Post: 14
    • Regular Joe
    • ★★

    It’s actually under VNC Server preferences and not the Remote Desktop as stated above from Wyse. I was able to get VNC to shadow after enabling it from the VNC server preferences in the control panel.

    #20344
    AvatarWYSEGUY66
    Member
    • Total Post: 14
    • Regular Joe
    • ★★

    I worked with an Wyse Support Engineer on this issue.

    If you want to get it to work via the wlx.ini file you must use a base64 generator for your VNC password if your using one.

    DisableVNC=no (this will enable VNC on the device)
    VNCAuthTypes=none or VNC
    VncPrompt=no or yes
    UsePasswd= if you don’t want to use a password you need to remove this line completely.

    Test it out and see if it works for you

    I hope this helps,

    #20421
    AvatarLavarius
    Participant
    • Total Post: 57
    • Back Stage Pass
    • ★★★★

    There’s been a few posts regarding vnc on this OS, and the subsequent sp1. I haven’t heard anyone actually get it to work, even with the confgen password hash.

    If someone does get it to work, please post how you did 🙂

    #20826
    AvatarWYSEGUY66
    Member
    • Total Post: 14
    • Regular Joe
    • ★★

    I was able to get it to work and shadow sessions on a hit or miss basis (sometimes it works and sometimes not).

    If I want to configure the device remotely it kicks me out when I get into admin mode. I would say it’s partial functionality.

    #20830
    AvatarLavarius
    Participant
    • Total Post: 57
    • Back Stage Pass
    • ★★★★

    I’ve seen it work consistently with the new firmware 11.1.031.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.