Question on FTP folder and file placement when using WDM

  • This topic is empty.
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #6470
    bspies
    Member
    • Total Post: 18
    • Regular Joe
    • ★★

    Hello all,

    I am having an interesting time trying to figure out how to manage our soon-to-be-delivered C10’s. I have been using a demo from Wyse via Dell for a while and have found a way to get everything working but it does not make any sense to me, so I think I may have setup WDM and/or my FTP “sub-optimally” i.e. poorly.

    first let me explain what I am seeing.

    to get a global wnos.ini to work, add a screensaver, notice file etc and a mac.ini to work I need to:

    -put wnos.ini in C:inetpubftprootRapportWNOSwnos
    -the same wnois.ini in C:inetpubftprootWNOS
    -my mac files in C:inetpubftprootWNOSinc
    -the firmware files, notice file in C:inetpubftprootWNOS
    -pictures for background etc. in C:inetpubftprootWNOSbitmap

    What confuses me are those first two lines above – why do I need to have two copies of the same wnos.ini file in different places? I have found if I do not put the copy under C:inetpubftprootWNOS the mac file is never found, and in the FTP logs I see 550 errors trying to find the wnos.ini file in this location; even though every other configuration I am making in the INI file under RapportWNOSwnos is accepted (except the $mac line).

    also I notice in the FTP log it is the rapport user account reading the RapportWNOSwnoswnos.ini file; and then after that the Anonymous ftp account I configured in the wnos.ini is used to read the other files like the bitmaps, notice file etc.

    so am I doing something wrong or is this just the way it is?

    Thank you

    p.s. here is my INI file with some company name changes removed. This was created using ConfGen then a few manual edits later. to save space I have removed some of the confgen comments just to save space in this posting.

    p.p.s. I forgot to also add I am not using DHCP to configure the WDM or FTP server name. We were going to fire up new units, and manually add that then reboot them as required to get the central configuration applies to the units. We do not have much of an option due to the diverse locations these units are going to.


    ;*************************************************************
    ;* General 1 *
    ;*************************************************************

    autoload=2
    Fileserver=nullWDM01.something.PVT Username=anonymous Password=wyse@something.pvt
    Rapportserver=nullWDM01.something.PVT Retry=3
    AdminMode=yes Username=nulladmin Password=mypw1
    Privilege=None HidePPP=yes EnableNetworkTest=yes ShowDisplaySettings=Yes EnableKeyboardMouseSettings=yes SuppressTaskbar=auto KeepDHCPRequestIP=yes EnablePrinterSettings=no
    EnableCacheIni=yes

    ;*************************************************************
    ;* General 2 *
    ;*************************************************************

    FormURL=null.bmp
    Inactive=120
    Locale=English
    Device=audio Volume=24 mic_mute=1

    ;*************************************************************
    ;* General 3 *
    ;*************************************************************

    NoticeFile=Noticefile.txt Resizable=yes Timeout=100
    Autopower=yes
    AutoSignoff=yes
    BootOrder=HardDisk;USB;PXE
    SysMode=VDI toolbarclick=yes toolbardelay=1

    ;*************************************************************
    ;* Input Devices *
    ;*************************************************************

    Language=Us

    ;*************************************************************
    ;* Display *

    ;*************************************************************

    Screen=1 Resolution=DDC
    DeskColor=”0 0 0″
    DesktopColorDepth=16 RGB565=yes
    Desktop=DesktopWallpaper-1280×1024.jpg Layout=Stretch
    Screensaver=”30″ LockTerminal=yes Type=2 Image=null_screensaver.bmp
    ShutDownInfo=yes

    ;*************************************************************
    ;* Time *
    ;*************************************************************

    Timeserver=10.10.0.1 Timeformat=”12-hour format” Dateformat=mm/dd/yyyy
    TimeZone=’GMT – 07:00′ ManualOverride=yes Daylight=yes Start=030207 End=110107 TimeZoneName=”Mountain Standard Time” DayLightName=”Mountain Daylight Time”

    ;*************************************************************
    ;* Network *
    ;*************************************************************

    Device=Ethernet Speed=”Auto”
    SysName=DNS
    Terminalname=nullTC000 Reboot=yes
    SignOn=Yes ConnectionManager=Minimize EnableOK=Yes DisableGuest=yes LastUsername=yes SaveLastDomainUser=yes
    DisableDomain=yes
    DomainList=”domainname”
    ;SelectServerList=PNA ; MYAPPS.something.PVT
    PasswordServer=nullCTX23.something.PVT Connect=ICA Encryption=Basic
    MaxVNCD=1
    VncPassword=”mypw1″
    VncPrompt=Yes Reject=15 ActiveVisible=yes

    ;*************************************************************
    ;* General Session *
    ;*************************************************************

    SessionConfig=ALL MapDisks=yes DisableSound=No MouseQueueTimer=20
    Reconnect=no

    ;*************************************************************
    ;* ICA *
    ;*************************************************************

    IcaBrowsing=HTTP
    Seamless=yes HideTaskBar=2 FullscreenReserved=yes
    PnliteServer=MYAPPS.SOMETHING.PVT ReconnectAtLogon=1 ReconnectFromButton=1 AutoConnectList=”Citrix Farm:Citrix Desktop Fullscreen” Timeout=”10″
    LongApplicationName=yes
    SwitchApplication=yes
    SessionConfig=ICA DesktopMode=Fullscreen SysMenu=Remote SessionReliability=yes OnDesktop=desktops AudioQualityMode=Medium

    ;*************************************************************
    ;* General 2 Special *
    ;*************************************************************

    Include=$mac

    #20101
    ConfGen
    Keymaster
    • Total Post: 11409
    • Jedi Master
    • ★★★★★★★

    One simple change on your WDM will “fix” everything.
    Go to Configuration Manager – Preferences – WTOS and disable the one checkbox there.

    Here is what happens:
    Client comes up and checks in to WDM
    WDM passes the FTP folder “wnos” to the client and the FTP user rapport
    Client checks in this FTP structure
    It reads in your wnos.ini and uses the parameter “Fileserver…..” to change everything back to your desired FTP folder and user

    CG

    #20107
    bspies
    Member
    • Total Post: 18
    • Regular Joe
    • ★★

    Thank you so much. This did the trick!

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.