pxe boot

  • This topic is empty.
Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #161
    AvatarAnonymous
    Member
    • Total Post: 162
    • Jacked into The Matrix
    • ★★★★★★

    hi,

    i have a problem with 9150 that has pxe enabled. when i boot up the device it does not pick up an ip. after it boots up completely i can see that device on my rapport server. but since the pxe did not pick up an ip so it wont allow me to pull an image from that device. i can do everything like changing device name etc except for pulling an image from that 9150. funny part is, the 9150 that appears on the rapport has a different mac address that the one on the physical wyse terminal. it shows something like 44xxxxxx. can someone please help?

    #8741
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Wow, thats wierd as all Wyse NIC’s have a MAC that starts with 00 80 64.

    Is the device using the built in NIC? Is it on the same network as the Rapport server? If so try deleting the device out of Rapport and re-discover the device.

    If the device and the Rapport server are on different network segments have a look at the PXE docs on this site for setting up the IP helper,

    Cheers,
    -TT

    #8742
    AvatarAnonymous
    Member
    • Total Post: 162
    • Jacked into The Matrix
    • ★★★★★★

    thanks mate. the wyse terminal is using the inbulit nic and is on the same network (rapport server). i tried deleting the device on the server and re-discovered it but result the same. this time it picked up an ip from the dhcp server and appears well on the rapport server except for the MAC address – still showing the same – 444xxxxxx. since i have the MAC address appearing incorrect on the server i can do everything except for pulling image from that device. any thoghts?

    #8743
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Just a quick question, if you right click on the device is there an option “get device image (requires PXE)” ?

    #8744
    AvatarAnonymous
    Member
    • Total Post: 162
    • Jacked into The Matrix
    • ★★★★★★

    no….i do not get the option “get device image (requires PXE)” – this is the problem. since i dont get that option i cannot pull the image from the device.

    initially it did not even pick up an ip – but after several retries it finally picked up an ip and then i thought i would get the option “get device image (requires PXE)” – but it didn’t. i think it is not showing that option because it is showing wrong MAC address. once i will get the MAC address correct this problem would get resolved. any thoughts what would be going wrong with the MAC address?

    #8745
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    No Idea, the only time I have seen something like this was with a Cisco Switch. When portfast was enabled it resolved the problem. You ain’t using Cisco switches by chance are you?

    #8746
    AvatarAnonymous
    Member
    • Total Post: 162
    • Jacked into The Matrix
    • ★★★★★★

    we are using cisco switches and portfast is disabled. the network administrator won’t get convinced on enabling the port as it might affect the network performance.

    #8747
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Ahh. we may have the solution then…

    When disabled, spanning-tree recalulates the metrics for routing packets using this newly enabled port. This delay is what blocks the DHCP/PXE requests from reaching the Rapport server.

    Portfast is a spanning tree option that tells the server to instantly enable the port and recalculate routing metrics after the fact.

    Given that the switch will hold workstations not other switches there is no requirement for the spanning tree calculation on these ports.

    Ask the switch admin to humor you and set portfast on for one port on the switch, plug the terminal into this port and reboot it a few times and see what comes up in Rapport. If the Rapport server is on the same LAN segment PXE will now be enabled,

    Cheers,
    -TT

    http://itt.theintegrity.net/pmwiki.php?n=ITT.Spanning-TreeAndPortfast

    http://www.cisco.com/en/US/products/hw/switches/ps708/products_configuration_guide_chapter09186a00800eb766.html

    #8765
    AvatarAnonymous
    Member
    • Total Post: 162
    • Jacked into The Matrix
    • ★★★★★★

    Verifiy whether the NETBIOS server has been disabled on the device as well. This could account for the non-wyse MAC being reported to Rapport.

    If this service is disabled, then the Hagent is unable to determine the local MAC address. To maintain unique ID, the Hagent on the device then generates a random value and reports it.

    This could affect PXE as well, as the PXE broadcast during boot will have a different MAC address than the device listed in Rapport.

    TT is right, you need to enable PortFast on the switch.
    You can also test this by putting a hub between the swtich port and the device. This will keep the port active, basically bypassing the delay normally seen.

    -karaziel

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.