PXE Boot after Update over wlx.ini

  • This topic is empty.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #280
    AvatarRene
    Member
    • Total Post: 3
    • Newbie

    Hi,
    we have S10 and S50 Devices and set all Settings over wnos.ini and wlx.ini Files.
    Now when i set up a old device the client beginn to update the BIOS over the LAN.
    Now the Problem;
    we want to start over IDE and not over PXE but after the Upgrade the
    the BIOS stand autmatic of PXE Boot.
    Can i set the Boot order over the .ini File?
    Or we must set the boot order after Upgrade?

    Here my wlx.ini File:



    ;*************************************************************
    ;* *
    ;* This wlx.ini file was generated with the *
    ;* Configuration File Generator *
    ;* Copyright by Thomas Moellerbernd *
    ;* *
    ;*************************************************************

    Fileserver=SERVERIP
    Rootpath=ROOTDIR
    autoload=2
    Rapportserver=SERVERIP
    FirmwareServer=SERVERIP
    FirmwareRootPath=ROOTDIR
    Autopower=yes
    Shutdowncounter=3
    Bootorder=HUN

    ;*************************************************************
    ;* General 2 *
    ;*************************************************************

    keyboard=de_CH
    Language=de_CH.UTF-8

    ;*************************************************************
    ;* Display *
    ;*************************************************************

    Resolution=DDC

    ;*************************************************************
    ;* Time *
    ;*************************************************************

    Timeserver=TIMESERVER
    Timeformat="24-hour format"
    TimeZone=CET ManualOverride=yes Daylight=yes

    ;*************************************************************
    ;* Network *
    ;*************************************************************

    EthernetSpeed="Auto"
    SignOn=No

    IcaBrowsing=HTTP
    ;HideTaskBar=Yes

    ;
    ;- ICA Session 1 -
    ;- Each line but the last must end with a ' ' -
    ;

    Connection 1

    Kind regards
    Rene

    #9047
    Avatarrj
    Member
    • Total Post: 11
    • Regular Joe
    • ★★

    I have used the Bootorder=HUP on our S50 to change the bootorder.

    After the update the devices automatically changes to the bootorder in your wlx.ini

    I’m kind of newbie myself so I don’t know if using HUN (as in your wlx.ini) as bootorder automatically skips pxe-boot.

    – rj

    #9048
    AvatarRene
    Member
    • Total Post: 3
    • Newbie

    Hi,
    yes we have set the command:
    Bootorder=HUN
    But after a Upgrade the client start up over PXE.
    René

    #9049
    Avatarrj
    Member
    • Total Post: 11
    • Regular Joe
    • ★★

    I think you should try Bootorder=HUP not HUN.
    This works fine on our terminals.

    The documentation says:
    “Bootorder=HUP to set the boot order to. Hard disk/USB/PXE”

    – rj

    #9062
    AvatarRene
    Member
    • Total Post: 3
    • Newbie

    Okey,
    after the BIOS update the Settings are:
    PXE ==> USB ==> IDE
    The Client lost the Settings.
    when we make changes in the wlx.ini they are not running.
    Now we must go to the Client and set the Boot order!
    We have test all Settings:
    Bootorder=HUP
    Bootorder=HNN

    René

    #9065
    Avatarthinkthin
    Member
    • Total Post: 1707
    • Jacked into The Matrix
    • ★★★★★★

    Hi,

    Are you sure the device is actually reading the wlx.ini after the upgrade? Does the system log say “unable to access profile”. I think the terminals are not getting the file. Have you used the 161 and 162 DHCP option tags to force the file location?

    Cheers,
    -TT

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.